Print Page | Close Window

Authorize TO Emails not working?

Printed From: LogSat Software
Category: Spam Filter ISP
Forum Name: Spam Filter ISP Support
Forum Description: General support for Spam Filter ISP
URL: http://www.logsat.com/spamfilter/forums/forum_posts.asp?TID=7002
Printed Date: 21 November 2017 at 6:18pm


Topic: Authorize TO Emails not working?
Posted By: ImInAfrica
Subject: Authorize TO Emails not working?
Date Posted: 16 January 2012 at 12:46pm
Hi,
I have a list in my authorized to emails file as follows:

*@domain1.com
*@domain2.com
nam1@mydom.com
nam1@mydom2.com
nam1@mydom3.com
nam2@mydom.com
nam2@mydom2.com
nam2@mydom3.com
nam3@mydom.com
nam3@mydom2.com
nam3@mydom3.com

when i send an email to anyothername@mydom3.com it should reject, right?
I can see in the log:
EmailTO is not in AuthorizedTOEmail list...

BUT when I follow the SMTP conversation the rejection comes later.
A typical SMTP conversation should by

helo abc.abc.com
OK
mail from:<validemail@validdomain.com>
OK
rcpt to:<doesntexist@domain.com>
REJECTION here

however, what I am seeing is that after the 'rcpt to' i get 
OK

which of course is not right.

Which of my settings is causing this?

The log shows:
01/16/12 00:48:53:513 -- (2244) Detected TCP Connection: 70.99.xxx.xxx
01/16/12 00:48:53:513 -- (2244) Connection from: 70.99.xxx.xxx  -  Originating country : United States
01/16/12 00:48:53:700 -- (2244) Received MAIL FROM: <xxxx@tbcmg.com>
01/16/12 00:48:53:778 -- (2244) Received RCPT TO: xxxxx@xxxflorida.com
01/16/12 00:48:53:794 -- (2244) - EmailTO is not in AuthorizedTOEmail list...
01/16/12 00:48:53:794 -- (2244) 70.99.xxx.xxx - Mail from: xxxx@tbcmg.com To: xxxx@xxxflorida.com will be rejected
01/16/12 00:48:54:403 -- (2244) Start virus scan
01/16/12 00:48:54:450 -- (2244) Starting bayesian procedures
01/16/12 00:48:54:544 -- (2244) Blacklist cache - Added 70.99.xxx.xxx to limbo
01/16/12 00:48:54:778 -- (2244) SFDB - Added 70.99.xxx.xxx - Response: Error=0
01/16/12 00:48:54:778 -- (2244) Disconnect

I'd like Spamfilter, to disconnect the session when the recipient is invalid (assuming it's the only invalid recipient in the rcpt to list)

Thanks in advance for your pointers.

The spamfilter version I am 4.2.4.848



Replies:
Posted By: LogSat
Date Posted: 16 January 2012 at 2:09pm
Hi ImInAfrica,

I think the setting you're looking for is this one in the SpamFilter.ini file:

;If the "AuthorizedTO" whitelist is used to specify the list of valid email addresses that can be accepted, by default SpamFilter will terminate a connection when the remote server specifies an invalid address in the RCPT TO command. You can use the following option to disable this forced disconnect, and cause SpamFilter to simply reject the invalid recipient, and continue to accept additional ones

DisconnectOnNonAuthorizedTO=true


which was probably changed to "false" at one point. Please do let us know if it was already set to "true" so we can look into this more.


-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: ImInAfrica
Date Posted: 17 January 2012 at 7:53am
Hi Roberto,
I had this setting set as follows
DisconnectOnNonAuthorizedTO=1

I've changed it to true and will test, though i suppose =1 or =true is the same.




Print Page | Close Window