Print Page | Close Window

non delivery (NDR) not getting back to sender

Printed From: LogSat Software
Category: Spam Filter ISP
Forum Name: Spam Filter ISP Support
Forum Description: General support for Spam Filter ISP
Printed Date: 21 May 2019 at 8:56am

Topic: non delivery (NDR) not getting back to sender
Posted By: njtech
Subject: non delivery (NDR) not getting back to sender
Date Posted: 13 December 2010 at 8:35pm
I have spamfilter isp setup to forward to a exchange 2010 server. If a recipient sends to a invalid exchange address the recipient will get  a NDR (non delivery report) no problem works as desired.

However, if the email attachment size exceeds what is allowed on the
exchange server the ndr is never gets back to the recipient. At first
glance it appears its a exchange problem however if
I remove spamfilter the NDR works. any suggestions?

in the spam filter logs I see this:( I masked the actual email addresses and server name)

12/13/10 15:54:51:083 -- (24480) Error-email from to recipient --  was forwarded to myexchangeserver:25
12/13/10 15:54:51:083 -- (24480) There was an error sending the NDR to: sender@email The remote server 550 5.7.1 Unable to relay -- 
12/13/10 15:54:51:130 -- (24480) server error - myexchangeserver:25 said: 5.3.4 Message size exceeds fixed maximum message size -- 

Posted By: LogSat
Date Posted: 14 December 2010 at 10:24pm

By default SpamFilter will include the entire message in an NDR. If your Exchange server rejects an email from SpamFilter, then SpamFilter will generate an NDR for the sender, and will forward that NDR for delivery to your Exchange server. If the original rejection by Exchange was due to an excessive message size, the NDR will also be exceeding the max message size, as the NDR contains the original email within it.

To solve this issue, we actually recently posted a new SpamFilter build ( that includes support for the following option in the SpamFilter.ini file:

// New to VersionNumber = '';
{TODO -cNew Added support for a new parameter in the SpamFilter.ini file to control if the NDR will contain the entire original email or only its headers: IncludeOriginalMessageOnNDR=1}

If you thus set that value to "0" that should take care of the problem. You can manually add that parameter if it doesn't exist yet.

Roberto Franceschetti" rel="nofollow - LogSat Software" rel="nofollow - Spam Filter ISP

Print Page | Close Window