Print Page | Close Window

SF is whitelisting, but should not be.

Printed From: LogSat Software
Category: Spam Filter ISP
Forum Name: Spam Filter ISP Support
Forum Description: General support for Spam Filter ISP
URL: http://www.logsat.com/spamfilter/forums/forum_posts.asp?TID=6641
Printed Date: 16 December 2017 at 2:25am


Topic: SF is whitelisting, but should not be.
Posted By: yapadu
Subject: SF is whitelisting, but should not be.
Date Posted: 26 March 2009 at 10:07pm
When some releases a message from quarantine, it is automatically adding the sender to the 
tblwl_autowhitelistforcedelivery table, but I don't want that.

I have turned it off in the spamfilter.ini file using:

;If turned on, any quarantined (false positives) emails that the end user force-delivers will cause the sender to be automatically whitelisted
AutoWhiteListForceDeliveryEnabled=0

Is there something else I need to do to have it just release the message, but not whitelist the sender?


Thanks,

Robert G.



Replies:
Posted By: LogSat
Date Posted: 27 March 2009 at 3:53pm
Robert,

That setting, if disabled, will actually only prevent the whitelisting of incoming emails if the sender/recipient combination is present in the AutoWhiteList.

So setting AutoWhiteListForceDeliveryEnabled=0 will not prevent the addition of new entries to the tblwl_autowhitelistforcedelivery, but it will prevent SpamFilter from using the contents of that table to whitelist incoming emails.

If you wish to keep that table "clean" you will need to schedule a job that will routinely empty that table.

-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: yapadu
Date Posted: 27 March 2009 at 9:07pm
The reason I noticed it was actually because email was being whitelisted and allowed through.

I had released some SPAM from the quarantine, then a few days later I got more SPAM from the same sender and it was whitelisted and sent through.

X-SF-RX-Return-Path: <noreply@HEYLOOKATSHOP.INFO>
X-SF-HELO-Domain: HEYLOOKATTHISSHOP.INFO
X-SF-Originating-IP: 65.60.38.126
X-SF-WhiteListedReason: AutoWhiteList Force Delivery
X-Rejection-Reason: 16 - 557 Your domain HEYLOOKATTHISSHOP.INFO does not have a valid MX DNS record. Disconnecting...

The message was received, should have been quarantined because the sender has no valid MX record. Except a few days before I released a SPAM from that sender and it was whitelisted.

Based on your comment, the sender/recipient is in the file, but with the setting turned off it should not have been released correct?

I am trying to implement a system where people can release messages from quarantine, and have the option of whitelisting them or not.


Robert G.




Posted By: LogSat
Date Posted: 28 March 2009 at 2:25pm
Robert,

I'm very sorry, I missed the fact that on your initial posting you mentioned editing the "spamfilter.ini" file. That setting has actually been migrated, since SpamFilter v3.5, to the "Filters.ini" file located in the appropriate folder under the \SpamFilter\Domains directory structure. For SpamFilter ISP standard, the path is \SpamFilter\Domains\SFI\Filters.ini. For SpamFilter Enterprise, the setting, while stored in the Filters.ini file for each domain under that diretory structure, is actually retrieved from the "autowhitelistforcedeliveryenabled" setting in the "tbl_FilterSettings" in the database.

We also saw that the documentation is incorrect on this parameter, and we will be updating it shortly.

-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: yapadu
Date Posted: 29 March 2009 at 8:56pm
Ah, that makes sense now. I guess I can remove that value from the INI file so I don't make the mistake again.

Thanks

Robert G.



Print Page | Close Window