Print Page | Close Window

filter giving me invalid mx record

Printed From: LogSat Software
Category: Spam Filter ISP
Forum Name: Spam Filter ISP Support
Forum Description: General support for Spam Filter ISP
Printed Date: 19 July 2018 at 12:06am

Topic: filter giving me invalid mx record
Posted By: sepcity
Subject: filter giving me invalid mx record
Date Posted: 27 August 2008 at 2:40pm
I am getting an invalid MX record when I turn this filter on for I think all the outside domains like yahoo, hotmail and a couple others I noticed

X-Rejection-Reason: 16 - 557 Your domain does not have a valid MX DNS record.
Could that be something on my DNS server?

Posted By: jerbo128
Date Posted: 27 August 2008 at 9:53pm
This is caused by either
1 - incorrect DNS server settings in Spamfilter
2 - a DNS server that is not resolving correctly.
Try pointing the DNS servers settings in Spamfilter to a different DNS resolver (such as one of your ISP's servers)

Posted By: MokiTheGeek
Date Posted: 28 August 2008 at 8:48am

I am having the same type of issues. I have my ISP's DNS server configured within SpamFilter. The majority of the messages are resolved without problem however some get quarantined with failure to find MX record. If you look them up, even from the box they failed from, you get a reply no problem.

My first thought was this was a timeout issue so I upped the DNS timeout within the config file but it has had no effect.

Any suggestions? Also, does anyone use an outside commercial company for lookups to get around this kind of problem?

Posted By: Desperado
Date Posted: 28 August 2008 at 10:28am
The error can also be caused by a reply-to email being formed improperly ... such as - , rather than - . 
The clip of the log you included looks, however, like some sort of DNS issue.  On the machine that SpamFilter is installed on, try running with the "DNS Client" service stopped and see if the errors reduce.  If your ISPs DNS Resolvers fail for a lookup, the DNS Client service will cache that "bad" lookup ... not a good thing for a mail server.
In my setup, I have DNS resolvers that are used just for my mail servers and I clear their cache every 30 minutes.  This causes more "outside" lookups but less cached errors.  My DNS resolvers DO NOT forward the requests to our primary resolvers but rather, go directly to the authoritative DNS servers for lookups.

The Desperado
Dan Seligmann.

Posted By: StevenJohns
Date Posted: 29 August 2008 at 5:11am
I agree with Desperado, we run all of our mail servers with the DNS client service disabled. It puts a little more strain on our DNS servers, but we get reliable dns queries.

Posted By: Richard123
Date Posted: 20 October 2008 at 4:01am
Me also agree with (Desperado) it seems a good suggestion..

Securing Networks with Cisco Routers and Switches - 642-503 and CompTIA: - 220-601 Exam.

Posted By: Stranger
Date Posted: 29 October 2008 at 4:56pm
Try to check settings of your mail  server here -
also you can try to Verify how email going to your server...
It's important because lots of servers check for correct mail sender and user exist

Posted By: Amadeus0125
Date Posted: 12 March 2009 at 7:02am
Thanks for your inportant guidness its really usefull.

Print Page | Close Window