Print Page | Close Window

Whitelisted domains still get spam tagged

Printed From: LogSat Software
Category: Spam Filter ISP
Forum Name: Spam Filter ISP Support
Forum Description: General support for Spam Filter ISP
URL: http://www.logsat.com/spamfilter/forums/forum_posts.asp?TID=6213
Printed Date: 17 December 2017 at 2:59am


Topic: Whitelisted domains still get spam tagged
Posted By: Guests
Subject: Whitelisted domains still get spam tagged
Date Posted: 23 August 2007 at 10:01am
Connection from: 213.199.138.191  -  Originating country : Ireland
08-23-07 09:28:07:076 -- (4036) Bypassed all rules for: mailto:robbert@informatique.nl - robbert  from mailto:v-petede@microsoft.com - de@microsoft.com ( Whitelisted Email From Domain)
08-23-07 09:28:07:482 -- (4036) Found Keywords: [sample]
08-23-07 09:28:07:482 -- (4036) EMail from de mailto:de@microsoft.com - @microsoft.com to mailto:robbert@informatique.nl - robbert matches content filter rules - rejected.
08-23-07 09:28:07:482 -- (4036) Starting queueing procedures
08-23-07 09:28:07:482 -- (4036) EMail from mailto:v-petede@microsoft.com - v@microsoft.com to mailto:robbert@informatique.nl - robbert was queued. Size: 68 KB, 69632 bytes
08-23-07 09:28:07:498 -- (444) Sending email from mailto:v-pee@microsoft.com - v-pee@microsoft.com to mailto:robbert@informatique.nl - robbert@ --
08-23-07 09:28:07:592 -- (4036) Disconnect
08-23-07 09:28:07:732 -- (444) EMail from mailto:v-petede@microsoft.com - v@microsoft.com to mailto:robbert@informatique.nl - robbert@ --  was forwarded to iqmail:25
 
It seems like mail from my whitelisted domains still get SPAM tagged  in version 3.5.4.704 if they match another rule. This mail was received by robbert with the SPAM tag in the subject. Anybody?



Replies:
Posted By: LogSat
Date Posted: 23 August 2007 at 7:36pm
The tagging/not tagging is a very confusing option, especially considering that adding a ":tag" or a ":tagsubject" suffix to unfiltered emails must cause a different behavior than the "tag spam and deliver" options in the general configuration settings.. There have been many slight modifications to these tagging options in the past weeks. This is a current list of changes since build 704:

// New to VersionNumber = '3.5.4.710';
{TODO -cFix : When a recipient was whitelisted, in some cases SpamFilter would also whitelist additional, separate emails that could have been sent during the same SMTP session}
{TODO -cFix : If a recipient was whitelisted, additional "regular" recipients would be correctly rejected, but an incorrect logfile entry was added stating that they were being also whitelisted (which in fact they were not) }

// New to VersionNumber = '3.5.4.709';
{TODO -cFix : Reduced the number of memory leaks in PDF scans if documents use Cross-reference-Streams}
{TODO -cFix : When forwarding emails to the destination SMTP server, if such server rejected the emails due to a mailbox full error, SpamFilter would instead send an NDR with the incorrect bounce message "The following recipients are unknown"}
{TODO -cFix : Introduced bug in build 700 - If any filter is configured to "tag spam and deliver", SpamFilter was not processing spam with the following filters: keywords, Bayesian, images/PDF, SURBL. All other filters were applied correctly}
{TODO -cFix : Exception occurred during TestForReject: Access violation at address 0063F52E}

// New to VersionNumber = '3.5.4.707';
{TODO -cNew : Added option in SpamFilter.ini file: HideXSFWhiteListedReasonHeader}
{TODO -cNew : In SFE, SpamFilter is able to now startup even if the database server is unavailable}
{TODO -cFix : If a spam email is split so that it is delivered for whitelisted recipients but blocked for the rest, it was still being stored in the quarantine database for all receipients, including the whitelisted ones}
{TODO -cFix : The HTML parser used to detect blank html emails was expecting legitimate opening and closing html tags to define text, and was ignoring any text outside these tags. This could cause very short html emails to appear blank if they were not following correct html syntax. We are now auto-fixing the invalid html code to be less restrictive}

// New to VersionNumber = '3.5.4.705';
{TODO -cNew : "Exception occurred during FindMatchInStringList: Invalid pointer operation" errors could cause problems with the reloading of some black / white lists}
{TODO -cNew : Added the logging of the filesize when reloading the black / white list files}
{TODO -cNew : The SURBL blacklist is not being automatically sorted to allow user-defined order}
{TODO -cNew : Added options in [authentication settings] of SpamFilter.ini: ActiveDirectoryAuthAppendDefaultDomain, ActiveDirectoryAuthPrefixDefaultDomain to automatically append or prefix the default domain when authenticating users via SMTP AUTH}



-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: mikek
Date Posted: 24 August 2007 at 2:53am

Can't find build 710 in the download section (yet)...



Posted By: LogSat
Date Posted: 24 August 2007 at 7:42pm
Sorry, we jumped the gun on the release notes. Build 710 is being beta-tested, and is not public yet. We should be pre-releasing it shortly however, most likely within the next 12/48 hours.

-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: kp4711
Date Posted: 28 August 2007 at 5:26am
Roberto,
 
I have the same failure on my SF 704. At what time you will make ofically the release 710?
KP4711
 


Posted By: LogSat
Date Posted: 28 August 2007 at 6:22pm
710 is now publicly available in the registered user area.

-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP



Print Page | Close Window