Print Page | Close Window

Message conversion?

Printed From: LogSat Software
Category: Spam Filter ISP
Forum Name: Spam Filter ISP Support
Forum Description: General support for Spam Filter ISP
Printed Date: 17 July 2018 at 9:12pm

Topic: Message conversion?
Posted By: BillStewart
Subject: Message conversion?
Date Posted: 24 June 2004 at 11:15am

Hello all,

We have a web page that sends e-mail to an "info" account. Sometimes people cut-and-paste from MS Word into the text box in their browser, and if the text contains any non-ASCII characters (e.g. the fancy quote characters that Word inserts by default), then the message gets converted to quoted-printable format somewhere along the line. When it reaches my Exchange server (5.5), it attaches the e-mail as a .txt file attachment with the following notation in the message body:

This message uses a character set that is not supported by the Internet Service. To view the original message content, open the attached message. If the text doesn't display correctly, save the attachment to disk, and then open it using a viewer that can display the original character set.

I have spoken to the people that designed the web page, and this was their response:

You will need to configure your SMTP server so that it declares that it can accept 8 bit encoding during the "Helo" session initiation. This should prevent the conversion.

I'm asking here because SpamFilter is our incoming SMTP server, and this problem is a nuisance.

Any ideas?


Bill Stewart

Posted By: LogSat
Date Posted: 24 June 2004 at 11:09pm


In SpamFilter, try going to the Settings - Debug View tab. In there, enter the IP address of your webserver (assuming it is the one sending the email to SpamFilter). Then send the email using the browser.

You should see a trace of the SMTP commands. They should look something like the following. The fist command sent by the web server should be an "EHLO", (extended HELO). SpamFilter will respond with an 8BITMIME line indicating that it will accept such encoding. Should the webserver use the older "HELO" command rather than the newer "EHLO" command, there's no way to specify the encoding during the HELO session, and the web server must then fallback to other means in the email itself to specify the right formatting.

If you post your trace we may get an idea of what is happening.

Roberto F.
LogSat Software

>>EHLO wrkstn1


<<250 HELP


<<250 Ok


<<250 Address Okay

>>RCPT TO:<>

<<250 Address Okay


<<354 Start mail input; end with <CRLF>.<CRLF>

>>Received: from by (LogSat Software SMTP Server) Fri, 16 May 2003 12:34:33 -0400

>>From: "Roberto Franceschetti " <>


>>Subject: test

>>Date: Fri, 16 May 2003 12:34:28 -0400

>>Message-ID: <001901c31bc9$084fcd90$>

>>MIME-Version: 1.0

>>Content-Type: multipart/mixed; boundary="----=_NextPart_000_001A_01C31BA7.813E2D90"

>>X-Priority: 3

>>X-MSMail-Priority: Normal

Posted By: BillStewart
Date Posted: 25 June 2004 at 10:25am

Hi Roberto,

Thanks so much for your reply! I have provided the information to our web folks and am awaiting a reply.


Bill Stewart

Print Page | Close Window