Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - BlockBlankEmailsWithAttachments
  FAQ FAQ  Forum Search   Register Register  Login Login

BlockBlankEmailsWithAttachments

 Post Reply Post Reply
Author
IKILLSPAM1 View Drop Down
Groupie
Groupie


Joined: 02 May 2007
Location: United States
Status: Offline
Points: 70
Post Options Post Options   Thanks (0) Thanks(0)   Quote IKILLSPAM1 Quote  Post ReplyReply Direct Link To This Post Topic: BlockBlankEmailsWithAttachments
    Posted: 07 August 2007 at 10:23am

I have downloaded and applied the latest .703 EXE's. After starting SFI back up, I did not see BlockBlankEmailsWithAttachments=*.pdf in the INI file so I added that just below the other PDF scanning options. I started the exe and have been monitoring things. It does not appear to be working. Am I missing something?

 

 

Back to Top
Desperado View Drop Down
Senior Member
Senior Member
Avatar

Joined: 27 January 2005
Location: United States
Status: Offline
Points: 1143
Post Options Post Options   Thanks (0) Thanks(0)   Quote Desperado Quote  Post ReplyReply Direct Link To This Post Posted: 07 August 2007 at 11:41am
It may be that there is some small (Non printing) HTML code.  Roberto is working on that.
The Desperado
Dan Seligmann.
Work: http://www.mags.net
Personal: http://www.desperado.com

Back to Top
IKILLSPAM1 View Drop Down
Groupie
Groupie


Joined: 02 May 2007
Location: United States
Status: Offline
Points: 70
Post Options Post Options   Thanks (0) Thanks(0)   Quote IKILLSPAM1 Quote  Post ReplyReply Direct Link To This Post Posted: 07 August 2007 at 11:44am

Dan can you provide some text as to what the Log will contain when it uses this new functionality, just so I can quickly scan the log to see if its working. As of right now, I see emails coming in, blank with PDFs attached and they are not getting blocked.

 

Thanks

Back to Top
Desperado View Drop Down
Senior Member
Senior Member
Avatar

Joined: 27 January 2005
Location: United States
Status: Offline
Points: 1143
Post Options Post Options   Thanks (0) Thanks(0)   Quote Desperado Quote  Post ReplyReply Direct Link To This Post Posted: 07 August 2007 at 11:53am
08/07/07 06:32:08:233 -- (5376) Detected blank email with specified attachment
The Desperado
Dan Seligmann.
Work: http://www.mags.net
Personal: http://www.desperado.com

Back to Top
IKILLSPAM1 View Drop Down
Groupie
Groupie


Joined: 02 May 2007
Location: United States
Status: Offline
Points: 70
Post Options Post Options   Thanks (0) Thanks(0)   Quote IKILLSPAM1 Quote  Post ReplyReply Direct Link To This Post Posted: 07 August 2007 at 11:59am

Thank you. As suspected I cannot find that string in my logs.

Can you just confirm that simply having the latest build and

BlockBlankEmailsWithAttachments=*.pdf,*.zip

In my .ini, directly below the SpamPDFMaxPixelHeight=1600  option

is all I need for this to work?

Did I put the BlockBlank text too far into the .ini ? Should it be further up?

Thanks again

Back to Top
Desperado View Drop Down
Senior Member
Senior Member
Avatar

Joined: 27 January 2005
Location: United States
Status: Offline
Points: 1143
Post Options Post Options   Thanks (0) Thanks(0)   Quote Desperado Quote  Post ReplyReply Direct Link To This Post Posted: 07 August 2007 at 12:28pm

From the GUI, hit the "Save Settings Button.  This will remove the old setting and put the new one in if it is not there (or is spelled wrong or something). 

It really doesn't matter where it is so long as it is under "[server settings]" 
BlockBlankEmailsWithAttachments=*.pdf,*.xls,*.zip



Edited by Desperado
The Desperado
Dan Seligmann.
Work: http://www.mags.net
Personal: http://www.desperado.com

Back to Top
IKILLSPAM1 View Drop Down
Groupie
Groupie


Joined: 02 May 2007
Location: United States
Status: Offline
Points: 70
Post Options Post Options   Thanks (0) Thanks(0)   Quote IKILLSPAM1 Quote  Post ReplyReply Direct Link To This Post Posted: 07 August 2007 at 12:44pm

Interesting. I removed the line that I added, after doublechecking for accuracy, which it was correctly typed. I then from the GUI hit save settings. It then placed this option back into the .ini but way down at the bottom. So maybe your assumption as to where it needs to be placed is invalid? Not sure yet if its now working as I havent received any possibilities but Im sure within a few minutes I will.

I will post back.  If nothing else, thanks for the tip on hitting save settings in the GUI. I didnt realize it autopopulates the INI file if it sees newly available options missing.

Back to Top
Desperado View Drop Down
Senior Member
Senior Member
Avatar

Joined: 27 January 2005
Location: United States
Status: Offline
Points: 1143
Post Options Post Options   Thanks (0) Thanks(0)   Quote Desperado Quote  Post ReplyReply Direct Link To This Post Posted: 07 August 2007 at 1:03pm
Mine is near the bottom ... right before the "[Error Response]" section.  Below that is "[NVC]" then "[Authentication settings]" then "[proxy settings]".  I do not think it matters but I believe it should be somewhere in the "[server settings]" section.  I will defer that to Logsat Support however.
The Desperado
Dan Seligmann.
Work: http://www.mags.net
Personal: http://www.desperado.com

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 07 August 2007 at 3:52pm
The placement of the various ini entries is not relevant, as long as they are in the correct section. A section will be indicated by a line like:

[section name]

In this particular case, the "BlockBlankEmailsWithAttachments" entry, like most of the other "hidden" settings in SpamFilter, must be placed in the [server settings] section.
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
IKILLSPAM1 View Drop Down
Groupie
Groupie


Joined: 02 May 2007
Location: United States
Status: Offline
Points: 70
Post Options Post Options   Thanks (0) Thanks(0)   Quote IKILLSPAM1 Quote  Post ReplyReply Direct Link To This Post Posted: 07 August 2007 at 4:18pm

It appears it has blocked 2 emails in the last few hours. I however have already received 2 such emails since that time, so it works and it doesnt work. Any idea why its kinda working? The two that I received are .pdf attachments, 10kb and 15kb in size. Stock ads. One is 4pgs long other is 5pgs. If I recall these pdf's dont get scanned if its over 2 pages? Are people increasing this to catch this? Is that a wise decision?

 

Thanks as always

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 07 August 2007 at 7:54pm
We'd rather not get in too many details publicly, as spammers may monitor the forum.

We released a new pre-release build (3.5.4.704) in the registered user area that should help catch the ones being missed.

Please emails us privately if you'd like more details on the changes.
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
__M__ View Drop Down
Groupie
Groupie


Joined: 30 August 2006
Location: Australia
Status: Offline
Points: 75
Post Options Post Options   Thanks (0) Thanks(0)   Quote __M__ Quote  Post ReplyReply Direct Link To This Post Posted: 12 August 2007 at 10:36pm
Over the last few days we have noticed PDF spam coming in with the *.fdf extension (another Adobe format).

We have obviously been able to use the
BlockBlankEmailsWithAttachments setting to work around this (for blank messages) but I'd thought I'd throw the observation out there in particular for Roberto & Co to ensure that this file extension type is also being scanned like a PDF.


Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.078 seconds.