Print Page | Close Window

win 2012 R2 standard - finestra real time non si a

Printed From: LogSat Software
Category: Spam Filter ISP
Forum Name: Spam Filter ISP Support
Forum Description: General support for Spam Filter ISP
URL: http://www.logsat.com/spamfilter/forums/forum_posts.asp?TID=7079
Printed Date: 21 November 2017 at 9:00am


Topic: win 2012 R2 standard - finestra real time non si a
Posted By: r.trombin
Subject: win 2012 R2 standard - finestra real time non si a
Date Posted: 05 April 2014 at 7:41am
Buongiorno, mi scuso se scrivo in italiano, ho appena migrato l'installazione spamfilter 4.5,1.98 (nuova installazione)  su un win server 2012 r2 STD e attivato il funzionamento come servizio. Quando apro la finestra di spamfilter, questa non si aggiorna in realtime. Il servizio funziona, accetta le connessioni, scrive il log su fgile ma sarebbe utile poter controllare in tempo reale le connessioni in entrata. 

Grazie per il supporto. 
Renato



Replies:
Posted By: LogSat
Date Posted: 05 April 2014 at 9:28am
In Windows 2008 and Windows 2012, when SpamFilter is running as a service its GUI windows will be displayed in a special isolated session in Windows. In order to display windows in this isolated session, the "Interactive Services Detection" Windows service must be running on the server. In Windows 2012 Microsoft has made it a bit more difficult to start that service. The following registry change will allow you to start "Interactive Service Detection" on Windows 2012:

  1. Why won't the Interactive Service Detection service start on Windows 8 and Windows Server 2012?

    Attempting to start the Interactive Service Detection (UI0Detect) service on Windows 8 and Windows Server 2012 can fail with the incomprehensible "Error 1: Incorrect function" message:


    This is because Microsoft has disabled interactive services in these new operating systems!

    Fortunately, it is easy to re-enable interactive services by editing the registry:

    1. http://dottech.org/76670/how-to-launch-regedit-in-windows-8/" rel="nofollow - Start the registry editor ("regedit.exe")
    2. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows on the left side
    3. On the right, double-click the NoInteractiveServices entry and change its value from 1 to 0
    4. Click OK to record your change
    5. Close the registry editor

    The Interactive Service Detection service should start properly after this change.



-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP



Print Page | Close Window