Print Page | Close Window

Mail blocked on one server passes through another

Printed From: LogSat Software
Category: Spam Filter ISP
Forum Name: Spam Filter ISP Support
Forum Description: General support for Spam Filter ISP
URL: http://www.logsat.com/spamfilter/forums/forum_posts.asp?TID=6828
Printed Date: 24 November 2017 at 4:21am


Topic: Mail blocked on one server passes through another
Posted By: baconeater
Subject: Mail blocked on one server passes through another
Date Posted: 29 April 2010 at 2:43pm

I was recently handed the responsibility of troubleshooting issues with Spam Filter ISP after someone left the company I work for.  We currently have Spam Filter ISP setup on two servers.  They do not replicate each other, but when changes are made, the change is applied to both servers. 

 

The issue I am having – when an email is received from mailto:anyaddress@aol.com - anyaddress@aol.com , one of the servers kicks it back (557 You are not allowed to send mail to %EMailTo%) and the other server lets the mail pass.  I need the email to make it through both servers.

 

I have gone through the setting on each of the servers, and they appear to be identical.  Any input or advice that anyone has regarding what I might need to look for or what I need to do to correct this issue would be greatly appreciated.

 

SpamFilter for ISP v. 4.1.2.814

 
Thanks



Replies:
Posted By: LogSat
Date Posted: 30 April 2010 at 10:53pm
baconeater,

If you have not changed the default response codes in SpamFilter, the error:

557 You are not allowed to send mail to .....

Indicates that SpamFilter is configured to use an "Authorized TO" email whitelist to define all the valid email addresses to which emails can be sent, but the "to" address in the email is for a user not present in that list. You should compare the two lists for the "Authorized TO" whitelist to ensure they are 100% the same.

Please  note that a very similar rejection notice, but with a different numeric code:
550 You are not allowed to send mail to .....

is used if the delivery domain is not present in the list of "Local Domains" for which SpamFilter is responsible for. If you haven't modified the defaults however, the error with the 557 code should be the one that applies here.


-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: baconeater
Date Posted: 03 May 2010 at 8:33am
Thanks LogSat,
 
I reviewed the "Authorized TO" email whitelists, and on both of our servers, it looks like there is no list, as the directories are empty and the lists are blank.  I hope this makes sense.
 
For a temporary fix, I removed the MX record of the server that is bouncing the email, but I would really like to figure out exactly what the problem is.
 
Any ideas?
 
Thanks again.


Posted By: LogSat
Date Posted: 03 May 2010 at 7:44pm
baconeater,

Could you please zip and email us (support @ logsat.com) your SpamFilter's activity logfile for today so we can take a look? Please also include in the zip the SpamFilter\SpamFilter.ini file and the entire \SpamFilter\Domains directory structure, so we may see all your settings. If the zipped file is over 8MB in size, please try to upload the file to our ftp server (I'll provide the FTP credential via a PM).


-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: LogSat
Date Posted: 06 May 2010 at 10:33pm
We received the files, and as mentioned in the original response as a possible problem, we see that the domain in question (exce_______lity.com) is not present in the list of local domains on your MX01 server. The list of domains is stored in the file:
C:\Program Files\SpamFilter\domains\SFI\LocalDomains.txt

on both servers. There are actually 3 domains that mismatch, in all three cases due to a missing ".com" extension in the domain name on one of the two MX servers.

I'll send you via PM the 3 domains in question.



-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: baconeater
Date Posted: 07 May 2010 at 8:14am

I thought I paid close attention to detail.  Turns out I was wrong.

Thank you very much for the help.


Posted By: LogSat
Date Posted: 07 May 2010 at 7:48pm
You're very welcome, that's what we're here for Smile !

-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP



Print Page | Close Window