Print Page | Close Window

Quarantine db is not active at startup

Printed From: LogSat Software
Category: Spam Filter ISP
Forum Name: Spam Filter ISP Support
Forum Description: General support for Spam Filter ISP
URL: http://www.logsat.com/spamfilter/forums/forum_posts.asp?TID=6824
Printed Date: 21 November 2017 at 8:47am


Topic: Quarantine db is not active at startup
Posted By: hartsockt
Subject: Quarantine db is not active at startup
Date Posted: 16 April 2010 at 7:50am
For some reason, every time I restart the server running spam filter isp, I have to manually click the 'Save & Activate Conn String'.  Until I do that, the quarantine database remains inactive.  Is there a setting that can make the connection become active automatically at start up without user intervention?

My connection string is as follows:
Provider=SQLNCLI.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=SpamFilterISP

Thank you,

Tom



Replies:
Posted By: LogSat
Date Posted: 21 April 2010 at 11:07pm
Tom,

From your connection string, we see you're connecting to the SQL server using integrated security for authentication. If you're running SpamFilter as a service, it will usually be running as SYSTEM, and the SYSTEM account (which will be the one being picked up by integrated security authentication) most likely won't have access to the SpamFilter database.

Can you please try specifying a SQL username/password in the connection, or even better, use a UDL file to specify the connection? A sample UDL files for a SQL Server connection is included in the \SpamFilter\databases directory. Simply double-click that file to change the connections settings to suit your environment.


-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP



Print Page | Close Window