Print Page | Close Window

Authenticate Mercur

Printed From: LogSat Software
Category: Spam Filter ISP
Forum Name: Spam Filter ISP Support
Forum Description: General support for Spam Filter ISP
URL: http://www.logsat.com/spamfilter/forums/forum_posts.asp?TID=5965
Printed Date: 23 October 2017 at 6:48pm


Topic: Authenticate Mercur
Posted By: pawelz
Subject: Authenticate Mercur
Date Posted: 01 February 2007 at 5:14am

Sorry for ma English. I'am from Poland.

I was instaled SpamFiler 3.1.3.599 eval version and Mercur MailServer on the same comuter .And every works OK. But if I set up on the Mercur that SMTP authentication required nobaty can not send e-mail.

In log file is:

Permission denied: You must authenticate using ESMTP /AUTH.

SpamFilter and Mercur working on W2K Workstation.

Spamfilter listen on 25 port and Mercur on 2525.




Replies:
Posted By: mikek
Date Posted: 01 February 2007 at 5:21am
I'm using Spamfilter and Mercur as well.

You have to set up 2 firewall rules in mercur (this has nothing to do with spamfilter, actually)

1 rule allows relay through your server for all authenticated clients.

the other blocks relay (but accepts local smtp mail) for all other users

i can send you screenshots of our mercur firewall config if you wish.


Posted By: pawelz
Date Posted: 01 February 2007 at 5:30am

Originally posted by mikek mikek wrote:

I'm using Spamfilter and Mercur as well.

You have to set up 2 firewall rules in mercur (this has nothing to do with spamfilter, actually)

1 rule allows relay through your server for all authenticated clients.

the other blocks relay (but accepts local smtp mail) for all other users

i can send you screenshots of our mercur firewall config if you wish.

It is rather problem in SpamFilter, not Mercur. If I turn off SpamFilter and set in Mercur SMTP port on 25, I can send mail.



Posted By: LogSat
Date Posted: 01 February 2007 at 7:42am
Pawelz,

If you configure Mercur for SMTP authentication, and are seing this in the logs:

Permission denied: You must authenticate using ESMTP /AUTH.

That means that whoever is connecting to Mercur and causing that message is not authenticating...
Please note that SpamFilter is a mail server, not a client, so it will not authenticate to Mercur when forwarding it email from the internet. You will need to configure Mercur to allow SpamFilter to deliver it emails *without* authentication.


-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: pawelz
Date Posted: 01 February 2007 at 7:54am

Thank's for the answer.

But in this case, because all users send mail via SpamFilter, I must turn off authentication on Mercur.

I see, that I will be must set SMTP on clients computers on port 2525



Posted By: LogSat
Date Posted: 01 February 2007 at 8:02am
Please note that SpamFilter supports SMTP authentication for clients as well, if you wish to use it. Please also note that you can vey likely implement SpamFilter so that you don't have to change your Mercur configuration, and continue to have Mercur listening on port 25, allowing your clients to still use Mercur.
To do so, you could configure SpamFilter to listen for incoming SMTP traffic on a different IP and/or a different port. For example, if your server is behind a firewall, you should be able to configure port translation on the firewall to accept incoming emails on port 25 from the internet, and to then forward them to SpamFilter on a different port.


-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: pawelz
Date Posted: 02 February 2007 at 8:50am

Thanks.

I was change record MX i my DNS. Now mail serwer is on the other machine that spamfilter.

I have question.

In total Inbound Conection Served is 17

Emails attempt is 2

Emails forwarded is 2. What's happend with 15 mails ?.

In log  is for example:

Connection from: 68.15.247.68  -  Originating country : United States
02/02/07 14:46:11:718 -- (1712) No Data Received
02/02/07 14:46:11:728 -- (1712) Disconnect 

 



Posted By: LogSat
Date Posted: 02 February 2007 at 4:35pm
They are usually just "probes" checking your IP out. Sometimes they just see if there's a mail server listening, other times they may be looking for open relays.

-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP



Print Page | Close Window