Print Page | Close Window

Why do I get this error when starting the software???

Printed From: LogSat Software
Category: Spam Filter ISP
Forum Name: Spam Filter ISP Support
Forum Description: General support for Spam Filter ISP
URL: http://www.logsat.com/spamfilter/forums/forum_posts.asp?TID=4036
Printed Date: 18 December 2017 at 2:14am


Topic: Why do I get this error when starting the software???
Posted By: Guests
Subject: Why do I get this error when starting the software???
Date Posted: 23 July 2004 at 12:03pm

In pushing the button "Start Non Service", I get the message "'mail' is not a valid integer value".

What is this referring to?




Replies:
Posted By: Desperado
Date Posted: 23 July 2004 at 12:34pm

I am just guessing here but check your INI file for the following settings and make sure there are valid entries:

ListenIP=66.66.66.66
ListenFQDN=mail.mydomain.com
ListenPort=25
ErrorHandlerEmailAddress="System Administrator" < mailto:null@mydomain.com" CLASS="ASPForums" TITLE="WARNING: URL created by poster. - null@mydomain.com >
DestinationServer=nextserver.mydomain.com
DestinationPort=25

Regards,

Dan S.



Posted By: Guests
Date Posted: 23 July 2004 at 3:30pm

Thanks for your help.

Would these values not be set using the settings?

When I look in the ini file, I find the following:

;ListenIP=209.26.140.2
;or....
;ListenIP=209.26.140.2,209.26.140.3
ListenFQDN=192.168.2.1
ListenPort=25

;The email address to use in Error Replies to senders
ErrorHandlerEmailAddress="System Administrator" < mailto:postmaster_no_reply@mydomain.com" CLASS="ASPForums" TITLE="WARNING: URL created by poster. - postmaster_no_reply@mydomain.com >

; DestinationServer is where you want all mail received by SpamFilter to be forwarded to
DestinationServer=192.168.2.1
DestinationPort=26

; AllowPercent is used to accept (AllowPercent=1) or reject (AllowPercent=0) emails containing the % character.
; Many SMTP servers are susceptible to being tricked into relaying with this.
; Ex. if you are netwide.net, then a spammer can use
; mail to: mailto:joe%yahoo.com@netwide.net" CLASS="ASPForums" TITLE="WARNING: URL created by poster. - joe%yahoo.com@netwide.net
; to relay mail to mailto:joe@yahoo.com" CLASS="ASPForums" TITLE="WARNING: URL created by poster. - joe@yahoo.com if your server is vulnerable
; Setting AllowPercent to 0 rejects ALL recipients email addresses conatining the % sign
AllowPercent=0

;log daily activity to logfiles
Logging=1
ListenIP=192.168.2.1
MultiThreaded=0
MaxInboundConnections=100

Personally I don't see anything wrong, but maybe you do?



Posted By: Desperado
Date Posted: 23 July 2004 at 3:57pm
Jcarp,
 
Would these values not be set using the settings?
Normally yes
 
When I look in the ini file, I find the following:
 
ListenFQDN=192.168.2.1  Should be the Fully Qualified Domain Name like mail.domain.com
ListenPort=25  Fine
 
;The email address to use in Error Replies to senders
ErrorHandlerEmailAddress="System Administrator" <
mailto:postmaster_no_reply@mydomain.com" CLASS="ASPForums" TITLE="WARNING: URL created by poster. - postmaster_no_reply@mydomain.com Fine
 
; DestinationServer is where you want all mail received by SpamFilter to be forwarded to
DestinationServer=192.168.2.1  If this is your normal mail server, fine
DestinationPort=26   If this is the port that the above listens on, fine
 
AllowPercent=0  ABSOLUTELY
 
;log daily activity to logfiles
Logging=1 Fine
ListenIP=192.168.2.1 
If this is the IP of the SpamFilter machine ... fine
MultiThreaded=0    Fine
MaxInboundConnections=100  Fine
 
Hope this helps,
 
Dan S. (SpamFilter USER)


Posted By: Guests
Date Posted: 23 July 2004 at 4:53pm

Well Dan, if I get this thing to work and decide to purchase, you sure deserve a nice commision from LogSat. I really appreciate your expertise.

I am getting closer.

Step 1: filled in the IPs of all external servers for the SMTP listener socket. All the rest remains unchanged.

Result: Socket Error #10049. Cannot assign requested address.

Step 2: replaced FQDN by mail.one_of_the_domains.com

Result: Could not bind socket. Address and port are already in use.

What now?

My bug is definately sitting in this section.



Posted By: Desperado
Date Posted: 23 July 2004 at 4:58pm

"Jcarp",

Can you email me at daseligmann at hotmail dot com ?  I will then contact you with my "real" address.

Dan S.




Print Page | Close Window