Print Page | Close Window

Attachment blocking not working

Printed From: LogSat Software
Category: Spam Filter ISP
Forum Name: Spam Filter ISP Support
Forum Description: General support for Spam Filter ISP
URL: http://www.logsat.com/spamfilter/forums/forum_posts.asp?TID=3627
Printed Date: 22 November 2017 at 6:18am


Topic: Attachment blocking not working
Posted By: Guests
Subject: Attachment blocking not working
Date Posted: 21 May 2004 at 3:14pm

I am evaluating the spamfilter isp product and have tried everything I can think of to quarantine emails with a certain attachment type.  I go to the BlackList attachments tab and add *.txt for a test.  Then I send an email to that server and it just passes it on through.  I have tried *, txt, *.txt*, *txt*, and just about any other combination I can think of and still the email is not quarantined.

Is it possible that this function does not work in the trial version?

at my wit's end...

Terry




Replies:
Posted By: Guests
Date Posted: 22 May 2004 at 12:15am

Terry,

If you do not currently have the keyword filter enabled, go ahead and enable it, with at least one keyword in the list.  Even if you were not planning to use the keyword filter, just enable it with a single keyword of sufficient length and randomness, like "bqzxryypmw" or something along these lines that would never actually result in a keyword match.  After doing so, test sending the attachment again and see if the attachment filter is working for you.

The "free trial" version of SpamFilter is always a few release-levels older than the licensed version, and this sometimes means that there may be old bugs in the trialware that have since been fixed in the licensed version.  This particular issue was a bug that occurred in build 302... but was reported to LogSat and quickly fixed in their very next build.  For reference, you might also want to take a look at http://www.logsat.com/sfi-release-notes-and-bug-fixes.asp" CLASS="ASPForums" TITLE="WARNING: URL created by poster. - http://www.logsat.com/sfi-release-notes-and-bug-fixes.asp" CLASS="ASPForums" TITLE="WARNING: URL created by poster. - http://www.logsat.com/sfi-release-notes-and-bug-fixes.asp , and read all of the other enhancements and bug fixes that have occurred since build 302.

Jim (SpamFilter customer)



Posted By: Guests
Date Posted: 22 May 2004 at 11:51am
Thanks Jim that did it....


Posted By: LogSat
Date Posted: 23 May 2004 at 10:02pm

Terry,

In the free version there's a bug that has been fixed in later builds:

// New to VersionNumber = '2.0.1.306';
{TODO -cFix : Attachment filtering was not working if keyword list was empty}

That may apply to your case. If that does not help, please email at mailto:support@logsat.com" CLASS="ASPForums" TITLE="WARNING: URL created by poster. - support@logsat.com your SpamFilter.ini file, along with all your local black/white list files and keyword file(s), a copy of your activity logfile that shows a message not being filtered, and possibly the source of the email so we can try to replicate the problem.

Roberto F.
LogSat Software




Print Page | Close Window