Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - Spamfilter using all CPU
  FAQ FAQ  Forum Search   Register Register  Login Login

Spamfilter using all CPU

 Post Reply Post Reply
Author
roaridse View Drop Down
Newbie
Newbie
Avatar

Joined: 16 February 2009
Location: Norway
Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote roaridse Quote  Post ReplyReply Direct Link To This Post Topic: Spamfilter using all CPU
    Posted: 12 August 2009 at 6:21am
Hi,
 
during the summer we have had some problems where spamfilter uses all cpu and being slow responding.
 
Sometimes it will help restarting the service - for several hours, and sometimes just for 10 minutes.
 
It looked a bit like a dos-attack or something, but even after limiting simultaneus connections to just 20 it uses all cpu - and after starting it will use all cpu even with 1-2 connections.
 
 
The process uses about between 650MB and 1,2GB of memory, which is fine.
 
Upgrading to version 4.1.2.812 did not help either.
 
 
Any hints?
 
 
 
Best Regards,
Roar Idsøe
 
Back to Top
WebGuyz View Drop Down
Senior Member
Senior Member


Joined: 09 May 2005
Location: United States
Status: Offline
Points: 348
Post Options Post Options   Thanks (0) Thanks(0)   Quote WebGuyz Quote  Post ReplyReply Direct Link To This Post Posted: 12 August 2009 at 11:54am
Are you by any chance using it on a guest OS under Hyper-v or Virtual Server? It needs at least 2 CPU's or if using it under Virtual Server 2005 then give it a larger percentage of  the overal cpu.
 
If stand alone server then I have no clue. Confused
 
 
http://www.webguyz.net
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 12 August 2009 at 10:13pm
Roar,

Can you please zip and email us your SpamFilter's activity logfile for a day this happened, so we can scan it for errors? IF the file is over 8MB in size, please upload it to our FTP server. I'll provide the login information via a PM.
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
roaridse View Drop Down
Newbie
Newbie
Avatar

Joined: 16 February 2009
Location: Norway
Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote roaridse Quote  Post ReplyReply Direct Link To This Post Posted: 13 August 2009 at 3:27am
Thanks for reply.
 
We run the server in an VMWare ESX environment - I'm not sure that this will apply here as well?
 
The server has been running fine since january/february..
 
 
Back to Top
WebGuyz View Drop Down
Senior Member
Senior Member


Joined: 09 May 2005
Location: United States
Status: Offline
Points: 348
Post Options Post Options   Thanks (0) Thanks(0)   Quote WebGuyz Quote  Post ReplyReply Direct Link To This Post Posted: 13 August 2009 at 9:07am
In Hyper-v or Virtual Server 2005, having a single CPU for spamfilter was not enough. In Hyper-v you can assign number of virtual CPU's and I currently use 4 for my Spamfilter servers. Not sure but assume VMware has something similar where you can overcommit CPU. Try giving it max resources then backing off a little at a time.
http://www.webguyz.net
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 13 August 2009 at 11:16pm
roar,

We don't see anything unusual in the activity logfile after an initial analysis. The log is rather large, so we'll be taking another more in depth look after this.

In the meantime, could you please try disabling the Bayesian filter (and also disable the "learn new incoming emails" option on the same settings tab) to see if it helps? Could you let us know the size of the db.dat and db.dat.prb files in the \SpamFilter\Corpus directory?
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
roaridse View Drop Down
Newbie
Newbie
Avatar

Joined: 16 February 2009
Location: Norway
Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote roaridse Quote  Post ReplyReply Direct Link To This Post Posted: 14 August 2009 at 3:24am
db.dat : 80458KB
db.dat.prb: 73397KB
 
Now Bayesian filter has been disabled.
 
 
Roar
Back to Top
roaridse View Drop Down
Newbie
Newbie
Avatar

Joined: 16 February 2009
Location: Norway
Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote roaridse Quote  Post ReplyReply Direct Link To This Post Posted: 20 August 2009 at 3:41am
Had to enable bayesian filter again - got too much spam...
 
The serverload was fine without bayesian filtering.
 
Any new status with the log i sent?`
 
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 21 August 2009 at 2:08pm
roar,

Unfortunately there was nothing that can help pinpoint the issue with 100% certainty. We did see a sharp spike in incoming connections (see below) at around 9:20AM, but that should not have caused the CPU to be high, especially if you had set the max connections to 20.

It is instead likely that the problem is caused simply by the size of the Bayesian corpus database. To try reducing it, can you please change the value of the parameter:
CleanUpCorpusIntervalDays=7

in the SpamFilter.ini file to about one third or one forth of your current value? For example, if right now you have a value of 7, trying changing that to 2. This should cause old entries in the Bayesian database to be removed sooner, thus hopefully reducing its size to a more manageable 10MB-20MB.


Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.156 seconds.