Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - Spamfilterweb issue when moving mail server
  FAQ FAQ  Forum Search   Register Register  Login Login

Spamfilterweb issue when moving mail server

 Post Reply Post Reply
Author
morten44 View Drop Down
Groupie
Groupie


Joined: 07 March 2008
Status: Offline
Points: 74
Post Options Post Options   Thanks (0) Thanks(0)   Quote morten44 Quote  Post ReplyReply Direct Link To This Post Topic: Spamfilterweb issue when moving mail server
    Posted: 24 March 2009 at 5:53pm
Hi
I have before got this resolved on
 
That time i had one server with www,mail og spamfilter and mysql
I am using windows 2003 with IIS
 
I had it to work from www.e-advice.dk/spamfilterweb with the help of this solution.
 
Now i have got a dedicated mail / spamfilter  server
 
The setup is as follow
 
behind a router i have to server
port 80 is forwarding to IP:x.x.x.10
port 25 is forwarding to IP:x.x.x.16
 
IP:x.x.x.10  (webserver, before also mail/spamfilter server)
IP:x.x.x.16  (new mail server/spamfilter/mysql)
 
Now as i have moved spamfilter and spamfilterweb to x.x.x16 i can on that server if i physically sit on it write
 
But here is the problem
When i sit on  my own homepc i can not access it as there is no domain name on that new server. only an internal IP address.
------------------------------------------------------
on the old webserver i have now redirected spamfilterweb to the new mail server in ISS
I first got a fault that it could not connect
I then edited the line in  db_connect.asp:
con.Open "file name=c:\program files\spamfilter\databases\spamfiltermysql.udl
to
con.Open "file name=c:\\172.18.0.16\spamfilter\databases\spamfiltermysql.udl
 
-------------------------------------------------------
 
I now get the logon box. YES!!!!
 
One problem to go.
It stills look at the mysql on the old mailserver (now only webserver where the redirection is taking place) and not on the mysql server now on the new mail server
 
So here is the question if you could follow so far.  lol
 
When you logon to the smamfilterweb (pressing "Logon")
What file should i edit to get it to validate on the mysql server on 172.18.0.16 instead on the webserver where there redirection is taking place (in this case localhost)
 
Any idea where to adit so it authenitcate on the new mail servers mysql server?
 
Kind Regards
Morten
 
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 24 March 2009 at 11:37pm
Morten,

The "db_connect.asp" page in your spamfilter web directory should contain a line similar to:

     con.Open "File Name=d:\inetpub\Databases\SpamFilter.udl"

The .UDL file referenced in the db_connect.asp should be the one you need to edit (by double-clicking it) to point it to the correct database.
This is if we were able to follow your thread correctly, which I'm not 100% sure I did! So please let us know if this is not what you meant.
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
morten44 View Drop Down
Groupie
Groupie


Joined: 07 March 2008
Status: Offline
Points: 74
Post Options Post Options   Thanks (0) Thanks(0)   Quote morten44 Quote  Post ReplyReply Direct Link To This Post Posted: 25 March 2009 at 2:55pm
Hi
Thanks for your answer. You where on a right path. I am impressed that you understood my explenation:
In db_connect.asp
it was pointing to the Spamfilter.udl file on the new mail server.
When i opened it the build line read:
DSN=spam;DESCRIPTION=spam;SERVER=localhost;UID=root;DATABASE=spamfilter;PORT=3306;SSLVERIFY=
 
As this was on the new mail server and the mysql was also on the new mail server, i was sure i could use localhost, but for some reason it must have interpret "localhost" as the local on the webserver and not the mail server.
I changed the line to
DSN=spam;DESCRIPTION=spam;SERVER=webserver2;UID=root;DATABASE=spamfilter;PORT=3306;SSLVERIFY=
(webserver2 is the name of the new mail server)
and now it works fine
 
Thanks for pointing me in the right direction
 
Kind Regards
Morten
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.063 seconds.