Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - Sometime blocked entries in tblreloadtableinfo
  FAQ FAQ  Forum Search   Register Register  Login Login

Sometime blocked entries in tblreloadtableinfo

 Post Reply Post Reply
Author
Shade View Drop Down
Groupie
Groupie
Avatar

Joined: 20 April 2006
Location: France
Status: Offline
Points: 42
Post Options Post Options   Thanks (0) Thanks(0)   Quote Shade Quote  Post ReplyReply Direct Link To This Post Topic: Sometime blocked entries in tblreloadtableinfo
    Posted: 24 July 2008 at 9:14am
Dear all,

I have a strange problem with SFE 4.0.1.785 (same with non official versions) :

I'm using MySQL 5.x database on a Win32 server machine. All is working perfectly, but sometime, when I add a domain (newest) with MySQL queries, commands stayed in "tblreloadtableinfo" table, and all other queries (for domains still created) are adding to this queue. All other new queries aren't used by SFE, so, If a client add a whitelist email for example, nothing is done. To clean (and execute queries waiting in tblreloadtableinfo to text files) the tblreloadtableinfo, I need to reload SFE, which is very long for me (due to the number of domains).

Here is what I do when created a new domain with MySQL :

1.Add domain in tbl_localdomains, get to ID.
2.Add settings in tbl_filtersettings
3.Add differents settings in tblwl_authorizedtoemails, etc.

Is there a way to resolve this ? A way to make a "graceful" restart of SFE ?

Thank you for reply !


Edited by Shade - 24 July 2008 at 9:16am
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4066
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 24 July 2008 at 10:03pm
Shade,

Once you insert a new domain in the tbl_localdomains table, if the "usedefaults" field for that record is set to "1", that indicates the domain will use default settings, and thus there should not be relative records in the tbl_filtersettings table nor in the other tables.

This said, if you do add a record in the tbl_localdomains table with the "usedefaults" value set to "0", then SpamFilter will, within a few seconds (within 5 sec usually), automatically add a relative record in the "tbl_filtersettings" table with default values. You should thus wait for that record to be added by SpamFilter to the tbl_filtersettings table so that you can then apply the changes you desire to it.

Within several seconds (about a minute or two) the entires created in the tblreloadtableinfo should disappear automatically.
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
Shade View Drop Down
Groupie
Groupie
Avatar

Joined: 20 April 2006
Location: France
Status: Offline
Points: 42
Post Options Post Options   Thanks (0) Thanks(0)   Quote Shade Quote  Post ReplyReply Direct Link To This Post Posted: 25 July 2008 at 10:13am
Thank you for reply...

I have test by waiting about 5 minutes (when created new domain), but still have the same problem :

I noticed some values about 1 or 0 in "updatetable" for information. Don't know if there's any link... Here is what I've done to create new domain :

$mid=mysql_connect('spamfiltermysqlserver', 'root','password');

INSERT INTO `spamfilter`.`tbl_localdomains` (`id` ,`domainname` ,`destsmtpserver` ,`destsmtpserverport` ,`usedefaults` ) VALUES (NULL , 'newdomain.com', 'localsmtpserver', '260', '0');

mysql_close($mid);

At this time, domain is created in tbl_localdomains, and after few seconds, settings appears in tbl_filtersettings

wait 120 seconds (5 minutes for tests)

Doing others settings etc. but for now, all is queued in tblreloadtableinfo, and no new settings are dumped in text files.

here is a dump for my tblreloadtableinfo table, id 1615 is the id for "newdomain.com" in my tests. Ids 1616 and 1617 are others domains created after, but for thoses, no action in tbl_localdomains and tbl_filtersettings :

         id      domainid    tablename    updatetable
      26346 1433 tblbl_honeypotblockedips__id__26346 0
      26347 1433 tblbl_honeypotblockedips__id__26347 0
      26348 1615 tbl_localdomains__id__26348 0
      26349 1433 tblbl_honeypotblockedips 1
      26350 1615 tbl_filtersettings 1
      26351 1615 tblwl_domainsips 1
      26352 1615 tblbl_maps 1
      26353 1615 tblbl_surbl 1
      26354 1615 tblbl_honeypotemails 1
      26355 1615 tblbl_attachments 1
      26356 1615 tblwl_authorizedtoemails 1
      26357 1616 tbl_localdomains 1
      26358 1616 tblwl_domainsips 1
      26359 1616 tblbl_maps 1
      26360 1616 tblbl_surbl 1
      26361 1616 tblbl_honeypotemails 1
      26362 1616 tblbl_attachments 1
      26363 1616 tblwl_authorizedtoemails 1
      26364 816 tblwl_authorizedtoemails 1
      26365 1617 tbl_localdomains 1
      26366 1617 tblwl_domainsips 1
      26367 1617 tblbl_maps 1
      26368 1617 tblbl_surbl 1

Thank you for help.
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4066
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 25 July 2008 at 10:46pm
Shade,

Can you please stop SpamFilter, then edit your SpamFilter.ini file, and look for the line containing this setting (the pathces may be different):

DBPatchesApplied=3.5.3.690,3.5.3.696,4.0.0.767,4.0.0.770,4.0.1.780

Try deleting the various version numbers, leaving just the entry (it's important you don't delete the entire line, the entry must be present, but blank):

DBPatchesApplied=

and then restart SpamFilter.

If this does not help, can you then zip and email us to support at logsat dot com your:

SpamFilter activity logfile for a day you experience the problem
SpamFilter.ini file
If using a UDL file to specify the MySQL connection, please include the UDL file
The name of the domain/domains you tried to add
Another dump like the one above of the tblreloadtableinfo table contents

If the zip is over 5MB in size, we'll provide out FTP info to upload it.
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.079 seconds.