Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - Issue to configure Web Interface
  FAQ FAQ  Forum Search   Register Register  Login Login

Issue to configure Web Interface

 Post Reply Post Reply
Author
morten44 View Drop Down
Groupie
Groupie


Joined: 07 March 2008
Status: Offline
Points: 74
Post Options Post Options   Thanks (0) Thanks(0)   Quote morten44 Quote  Post ReplyReply Direct Link To This Post Topic: Issue to configure Web Interface
    Posted: 26 June 2008 at 7:18pm
Hi
We are running ISP Spamfilter v4.0.1.783 in Standard Mode
I am trying to setup webinterface, because we have 10-15 users who are not happy for not having control of their filter. the rest are very happy with how it is.
 
I have downloaded it and set up db-connect.asp so I get a logon box with e-mail and password. I then went into mysql table tblLogins and created one user and password.
I now logon with that email and password and redirected to Listspam.asp, but the page can not be shown: THE PAGE CAN NOT BE DISPLAYED.
Is there any additional settings I have do to?
Is there any litterature I can read?
As said, I am using mysql and asp and I have downloaded the web interface packet from download
 
Kind Regards
Morten
 
Back to Top
Desperado View Drop Down
Senior Member
Senior Member
Avatar

Joined: 27 January 2005
Location: United States
Status: Offline
Points: 1143
Post Options Post Options   Thanks (0) Thanks(0)   Quote Desperado Quote  Post ReplyReply Direct Link To This Post Posted: 27 June 2008 at 11:03am
Morten,
 
Quick question ... Is the "db-connect.asp" also being properly pointed to from the "listspam.asp" page?
The Desperado
Dan Seligmann.
Work: http://www.mags.net
Personal: http://www.desperado.com

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 27 June 2008 at 5:44pm
Morten,

It's possible you don't have your browser configured to display the "real" error Internet Explorer is experiencing, but rather a generic error message.
You can change this by going (in Internet Explorer) to Tools - internet Options - Advanced and unchecking the "Show friendly HTTP error messages". This should reveal the real problem.
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
morten44 View Drop Down
Groupie
Groupie


Joined: 07 March 2008
Status: Offline
Points: 74
Post Options Post Options   Thanks (0) Thanks(0)   Quote morten44 Quote  Post ReplyReply Direct Link To This Post Posted: 27 June 2008 at 6:19pm

Hi

Thanks to the two of you.

I think you are onto something.
Will check it out, then remove friendly error messages and see what I get.

Thanks so far :)

 

Kind Regards

Morten

Back to Top
morten44 View Drop Down
Groupie
Groupie


Joined: 07 March 2008
Status: Offline
Points: 74
Post Options Post Options   Thanks (0) Thanks(0)   Quote morten44 Quote  Post ReplyReply Direct Link To This Post Posted: 27 June 2008 at 7:54pm
OK. Got a little futher.
I did remove friendly HTML in my browser and I now get the following error:
........................................................................................................................
  • Error Type:
    Microsoft VBScript runtime (0x800A01A8)
    Object required: 'con'
    /SpamFilterWeb/classicasp/authenticate.asp, line 24
  • Browser Type:
    Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; InfoPath.2)

  • Page:
    POST 47 bytes to /SpamFilterWeb/classicasp/ListSpam.asp
  • ...........................................................................................................................

    So I checked authenticate.asp (not done anyting with it) line 24 and it says:

       'Generate query.
       SQL = "SELECT Password "
       SQL = SQL & "FROM tblLogins "
       SQL = SQL & "WHERE EMail = '" & EmailTo & "'"
       Set rs = con.Execute(SQL)  --> LINE 24
       Failure = False

    NOt sure what I have to change here. First I am not using SQL but MYSQL
    Can anyone give me an explenation? I know little about programming so any help world be great. I am using a UDL file in db_connect.asp called SpamfilterMysql.udl and that is connecting OK
     
    Anyone any idears?
    Kind Regards
    Morten
    Back to Top
    LogSat View Drop Down
    Admin Group
    Admin Group
    Avatar

    Joined: 25 January 2005
    Location: United States
    Status: Offline
    Points: 4068
    Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 28 June 2008 at 1:41pm
    Morten,

    The file "Authenticate.asp" includes the file "db_connect.asp". The first line in your authenticate.asp should read:

    <!--#include file="db_connect.asp"-->     

    If this is so, can you please double-check that in your db_connect.asp you have modified the line:

         con.Open "File Name=d:\www\Databases\SpamFilter.udl"

    so that it points to a valid .UDL file on your web server, and that the directory containing that file allows the IUSR_machinename account Read access?
    Roberto Franceschetti

    LogSat Software

    Spam Filter ISP
    Back to Top
    morten44 View Drop Down
    Groupie
    Groupie


    Joined: 07 March 2008
    Status: Offline
    Points: 74
    Post Options Post Options   Thanks (0) Thanks(0)   Quote morten44 Quote  Post ReplyReply Direct Link To This Post Posted: 28 June 2008 at 5:07pm
    Hi again
    Thank you so much for your help.
     
    I now fount out what the problem was.
     
    When I installed ISP spamfilter first time it did install some of the files for the webaccess.
    Among the files where db_connect.asp
     
    As I did not get it to work i downloaded the whole PHP-ASP package from your website and copied into spamfilterweb.
    The problem is that I did not overwrite the old db_connect.asp and that looked different than the one i downloaded from the PHP-ASP package.
    I added the correct line in again as you suggested and it now works fine.
     
    Thanks alot. it saves us from having to be dectectives for some of the users that always think they are loosing mail.
    I must say I think it works very well and we are so far very happy with it.
     
    Kind Regards
    Morten
    Back to Top
    morten44 View Drop Down
    Groupie
    Groupie


    Joined: 07 March 2008
    Status: Offline
    Points: 74
    Post Options Post Options   Thanks (0) Thanks(0)   Quote morten44 Quote  Post ReplyReply Direct Link To This Post Posted: 29 June 2008 at 6:43pm

    Hi. We are nearly there now.

    One probleml left.
    Users can not change password. In browser it returs the following message:
     

    Microsoft OLE DB Provider for ODBC Drivers error '80040e14' [MySQL][ODBC 5.1 Driver][mysqld-5.0.51a-community-nt]You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '[Password] = '123123' WHERE EMail = 'morten@xxxxxx.dk'' at line 1 /SpamFilterweb/classicasp/PasswordChange.asp, line 38

     
    I have then checked PasswordChange.asp to see what the problem is. I have pasted some lines below:
     
     OldPassword = Request.Form("OldPassword")
     If Len(OldPassword) Then
      NewPassword = Request.Form("NewPassword")
      ConfirmNewPassword = Request.Form("ConfirmNewPassword")
      If Len(NewPassword) < 6 Then
       ErrorMessage = "New Password was too short!"
      ElseIf NewPassword <> ConfirmNewPassword Then
       ErrorMessage = "New Password and Confirm New Password did not match!"
      ElseIf OldPassword = NewPassword Then
       ErrorMessage = "New Password was the same as Old Password!"
      Else
       SQL = "SELECT Password "
       SQL = SQL & "FROM tblLogins "
       SQL = SQL & "WHERE EMail = '" & EmailTo & "'"
       Set rs = con.Execute(SQL)
       If Not rs.EOF Then
        If rs("Password") <> OldPassword Then
         ErrorMessage = "Old Password was incorrect!"
        Else
         SQL = "UPDATE tblLogins "
         SQL = SQL & "SET [Password] = '" & NewPassword & "' "
         SQL = SQL & "WHERE EMail = '" & EmailTo & "'"
         con.Execute SQL   ----> THIS IS LINE 38
         Response.Redirect "ListSpam.asp"
        End If
     
    I belive I have to edit something on this line but not sure what and now. Using Mysql
    Any good idears?
     
    Kind Regards
    Morten
    Back to Top
    LogSat View Drop Down
    Admin Group
    Admin Group
    Avatar

    Joined: 25 January 2005
    Location: United States
    Status: Offline
    Points: 4068
    Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 01 July 2008 at 2:26pm
    Morten,

    Can you try to slightly change the following 2 lines #36 and #37 as follows:

                             SQL = SQL & "SET Password = '" & NewPassword & "' "
                             SQL = SQL & "WHERE EMail = '" & EmailTo & "';"

    Roberto Franceschetti

    LogSat Software

    Spam Filter ISP
    Back to Top
    morten44 View Drop Down
    Groupie
    Groupie


    Joined: 07 March 2008
    Status: Offline
    Points: 74
    Post Options Post Options   Thanks (0) Thanks(0)   Quote morten44 Quote  Post ReplyReply Direct Link To This Post Posted: 02 July 2008 at 4:15am
    Hi Roberto
    Thanks for your time.
    Yes it worked :)
    Its a great improvement for our service to be able to provide this. I am not going to use it my self, but you know there are always someones that wants to be in control, and for them its good. Save me from time to go through quarantiend mails to check all the time :)
    Thanks
     
    An additional question:
    If we where to upgrade to Enterprice version, would this interface be the same. I read somewhere that with enterprice each user can also from webinterface, create rules. Like add a "non spam mail" to his white list etc... Is this correct?
    And if is this white list based on "from"  E-mail address?
    Kind Regards
    Morten
    Back to Top
    LogSat View Drop Down
    Admin Group
    Admin Group
    Avatar

    Joined: 25 January 2005
    Location: United States
    Status: Offline
    Points: 4068
    Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 02 July 2008 at 4:26am
    Glad that worked. In the Enterprise version nothing will change, everything will work "as-is". Additionally, in SpamFilter Enterprise, most settings are stored in the database and can thus be more easily changed by external application. We provide a sample administration web interface that allows administration of either the global settings for SpamFilter, and/or the filters for the individual domains (the Enterprise version allows almost every setting/whitelist/blacklist to be configured independently f each domain).
    Roberto Franceschetti

    LogSat Software

    Spam Filter ISP
    Back to Top
    morten44 View Drop Down
    Groupie
    Groupie


    Joined: 07 March 2008
    Status: Offline
    Points: 74
    Post Options Post Options   Thanks (0) Thanks(0)   Quote morten44 Quote  Post ReplyReply Direct Link To This Post Posted: 02 July 2008 at 5:13am
    Hi again
     
    Thanks for info. We might consider an upgrade at some point
     
    Kind Regards
    Morten
    Back to Top
     Post Reply Post Reply
      Share Topic   

    Forum Jump Forum Permissions View Drop Down



    This page was generated in 0.063 seconds.