Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - Mail failure.554 Error: no valid recipients
  FAQ FAQ  Forum Search   Register Register  Login Login

Mail failure.554 Error: no valid recipients

 Post Reply Post Reply
Author
morten44 View Drop Down
Groupie
Groupie


Joined: 07 March 2008
Status: Offline
Points: 74
Post Options Post Options   Thanks (0) Thanks(0)   Quote morten44 Quote  Post ReplyReply Direct Link To This Post Topic: Mail failure.554 Error: no valid recipients
    Posted: 27 May 2008 at 6:04pm
Hi.
I have got a new problem and i am not sure if this has to do with SpamFilter ISP Settings.
I have been running spamfilter isp for about 50 days. little by little i have made some ajustements to it.
Now I have found out that all ASP pages can not send via online formular on their websites.
 
When filling in I get the following message when sending:
Mail failure.554 Error: no valid recipients
 
It has worked since installing the spam filter but now I am not sure if some of my ajustements has caused this issues. I need some advice on what the error means and where to start looking
 
I am using Imail 8.22 as SMTP Server for in and outgoing mail and this is set up with spamfilter.
 
The ASP formular are using something called SoftArtisans SMTPmail.
 
Can anyone tell me where to start to look if this problem for some reasons is caused by the spamfilter.
The websites in dispute are situated on the same server as my Email Server and where spamfilter is installed
 
Thanks for any reply
 
Kind Regards
Morten
 
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4066
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 27 May 2008 at 8:16pm
Morten,

As far as we know SA SMTPMail is configured by specifying an SMTP server to use when sending emails with that component. If this is the case, it is that mail server that is rejecting the emails with the error "554 Error: no valid recipients".

If that server is SpamFilter, we can try to help (even though at first sight that does not look like one of SpamFilter's rejection messages).

If however SA's SMTPMail is configured to use your Imail server, then it is your Imail server that is rejecting the relay attempt from your webserver. In this case, you will need to ensure that Imail is configured to allow your web server's IP to freely relay emails.
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
morten44 View Drop Down
Groupie
Groupie


Joined: 07 March 2008
Status: Offline
Points: 74
Post Options Post Options   Thanks (0) Thanks(0)   Quote morten44 Quote  Post ReplyReply Direct Link To This Post Posted: 28 May 2008 at 6:51am

HI Roberto

Thanks for your answer. It has been resolved.
You pointed me in the right direction by saying  that SA SMTPmail forward to mail server.
I did not know.
I checked some asp files and found out that its forwarding to extern smtp (not our own)
I then check the same form to see what address form was sending from and it was.
I mailed the external SMTP provider and he pointed out that it was cought in his system due to wrong domain name. should be no-reply@e-adice.dk. We changed it and now it works.
The reason why it worked before I think is that they did not use a filter that checked for invalid sender, but now they do.
 
So thanks again Roberto
 
Kind Regards
Morten
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.062 seconds.