Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - blocking 95% or my mails. Help!!
  FAQ FAQ  Forum Search   Register Register  Login Login

blocking 95% or my mails. Help!!

 Post Reply Post Reply
Author
morten44 View Drop Down
Groupie
Groupie


Joined: 07 March 2008
Status: Offline
Points: 74
Post Options Post Options   Thanks (0) Thanks(0)   Quote morten44 Quote  Post ReplyReply Direct Link To This Post Topic: blocking 95% or my mails. Help!!
    Posted: 19 March 2008 at 8:32pm
Hi
I have just installed smap filter on my windows 2000 webserver.No local DNS Server installed. Using the one provided by IP. My Server is behind a firewall using Ip 192.168.0.1.
All trafic on SMTP ports are forwarded from router to mail server behind router.
I am using Imail 8.22
 
Can anyone help me with analizing the following in my log. this is the reason why all mail are blocked.It cant find my lan side of the router when doing Reverse DNS lookup.
Can i add this IP somewhere so it bypass reverse lookup for this IP .
 
It also says "Added 192.168.0.1 to limbo". Can i prevent that?
Does this log tell what the problem is and is there a solution?
 
Hope to hear from anyone :)
Kind Regards
Morten
 
Part of logfile:
 
03-20-08 00:33:05:234 -- (4724) Connection from: 192.168.0.1  -  Originating country : N/A
03-20-08 00:33:05:359 -- (4724) Received MAIL FROM: <oscar@peteroscar.dk>
03-20-08 00:33:05:375 -- (4724) Received RCPT TO: oscar@peteroscar.dk
03-20-08 00:33:05:390 -- (4724) Resolving 192.168.0.1 - Not found
03-20-08 00:33:05:390 -- (4724) - Reverse DNS not found -
03-20-08 00:33:05:406 -- (4724) 192.168.0.1 - Mail from: oscar@peteroscar.dk To: oscar@peteroscar.dk will be rejected
03-20-08 00:33:05:546 -- (4724) Starting bayesian procedures
03-20-08 00:33:05:578 -- (636) Time to add Msg to Bayes corpus:0
03-20-08 00:33:05:609 -- (4724) Blacklist cache - Added 192.168.0.1 to limbo
Back to Top
mbrusl View Drop Down
Groupie
Groupie
Avatar

Joined: 05 December 2005
Location: Thunder Bay Ont
Status: Offline
Points: 61
Post Options Post Options   Thanks (0) Thanks(0)   Quote mbrusl Quote  Post ReplyReply Direct Link To This Post Posted: 20 March 2008 at 2:28am
I believe part of the problem you are having is because you do not have a local DNS server running behind your NAT.  I've run into the same problem myself until I ran the DNS server on the local network.  You may also want to add your 192.168.0.1 to the local domains whitelist under spamfilter configuration, as well as the fully qualified domain name of the box that spamfilter is running on.   Net traffic will not flow into your network if you are using local NAT address's on an outside DNS box.  If you have the mail server on the same box as spamfilter, you will also need to change the SMTP port for IMail and make the destination change in spamfilter to point to the mail server.  I am running the same setup myself almost exactly, except different IPs and IMail version.  PM me if you want details on how to make this work legitly and be legal on the net.
Michael
support@spacequad.com
If blocked, use spacequad@hotmail.com
Spacequad Internet Services
Spacequad AntiSpam Services
Thunder Bay, Ontario
--------------------------------------------------
Back to Top
morten44 View Drop Down
Groupie
Groupie


Joined: 07 March 2008
Status: Offline
Points: 74
Post Options Post Options   Thanks (0) Thanks(0)   Quote morten44 Quote  Post ReplyReply Direct Link To This Post Posted: 20 March 2008 at 5:05am
Hi
Thanks for your responds. I will try to install local DNS and see if that helps :)
Will update late next week as i am going away.
IP added to whitelist.Not sure on domain name as its just a win2000 Server with a one word name "serverweb"
 
Thanks again
Morten
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 20 March 2008 at 11:33pm
Morten,

Please note that most of SpamFilter's various filters rely on the need to "see" the original IP address of the remote server. Some other filters, like the SPF filter for example, instead *require* to see the IP of the sender, or in some cases they will cause valid emails to be rejected. This is because some domains specify via DNS which IP addresses are allowed to send emails on their behalf. If SpamFilter does not see the original IP address, it will reject the email as it see it coming from an un-authorized IP.

If your SpamFilter is behind a firewall, the firewall will need to be configured so that it does not "mask" the IP of the sender. in your sample post we see the connection to SpamFilter originating from 192.168.0.1, which is your firewall, and not the real IP of the remote machine. This will prevent SpamFilter from working correctly.
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
morten44 View Drop Down
Groupie
Groupie


Joined: 07 March 2008
Status: Offline
Points: 74
Post Options Post Options   Thanks (0) Thanks(0)   Quote morten44 Quote  Post ReplyReply Direct Link To This Post Posted: 28 March 2008 at 6:29pm
Hi
Thanks for Following up that Roberto. I understand what you mean. Will look into configurating the firewall.Have been away for a week so sorry for late respond.
Will let you know how I get on :)
 
Kind Regards
MOrten
Back to Top
morten44 View Drop Down
Groupie
Groupie


Joined: 07 March 2008
Status: Offline
Points: 74
Post Options Post Options   Thanks (0) Thanks(0)   Quote morten44 Quote  Post ReplyReply Direct Link To This Post Posted: 07 April 2008 at 12:11pm
Hi Roberto
Thanks for your last answer. The setting was changed in my router and it picked it up correct. now working fine :)
 
Thanks alot
 
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.063 seconds.