Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - Quarantine DB not active
  FAQ FAQ  Forum Search   Register Register  Login Login

Quarantine DB not active

 Post Reply Post Reply
Author
rdemeyer View Drop Down
Newbie
Newbie


Joined: 29 October 2007
Location: United States
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote rdemeyer Quote  Post ReplyReply Direct Link To This Post Topic: Quarantine DB not active
    Posted: 07 January 2008 at 2:26pm
I just notice today while trying to fetch a message in quarantine that SPam Filter isn't connecting to my MS SQL Database.  I stopped the applicationa dn restarted it, tested the connection to the SQL server and get an error that he "server doesn't exist of access was denied.
We haven't changed anything on either server (that I am aware of), what else might be causing the problem.
 
MS SQL 2000
Spam Filter 3.0.1.558
 
Both running on Dell Poweredge servers and Windows 2003 Server.  We don't seem to be having problems with any other of our SQL fed applications.
 
Thanks
 
Randy
Back to Top
WebGuyz View Drop Down
Senior Member
Senior Member


Joined: 09 May 2005
Location: United States
Status: Offline
Points: 348
Post Options Post Options   Thanks (0) Thanks(0)   Quote WebGuyz Quote  Post ReplyReply Direct Link To This Post Posted: 07 January 2008 at 3:33pm
Is the MySQL db on the same server? Can you access MySQL db via some admin tool to make sure its up and operational?
http://www.webguyz.net
Back to Top
rdemeyer View Drop Down
Newbie
Newbie


Joined: 29 October 2007
Location: United States
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote rdemeyer Quote  Post ReplyReply Direct Link To This Post Posted: 07 January 2008 at 5:26pm
The Microsoft SQL Database is running on a different server.  That Server is running fine and has several other active SQL applications that are not experiencing any errors.
 
I am not a expert on SQL databases. so I am not sure if there is a way to determine if the DB is not working correctly on the server.  But I AM certain that the entire SQL application is working, as we have four other programs using it.
 
Thanks
 
Randy
Back to Top
WebGuyz View Drop Down
Senior Member
Senior Member


Joined: 09 May 2005
Location: United States
Status: Offline
Points: 348
Post Options Post Options   Thanks (0) Thanks(0)   Quote WebGuyz Quote  Post ReplyReply Direct Link To This Post Posted: 07 January 2008 at 6:50pm
I would go to ODBC admin on the SF box and try to establish a test connection to your SQL server. This will tell you if your having a connection issue or SF issue. You should be able to click on test connection and verify that the database part is all OK (or not)
 
 
http://www.webguyz.net
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 07 January 2008 at 7:24pm
Randy,

Please see below a section of SpamFilter's user manual that talks how to configure an MS SQL database using UDL files (our recommended approach).

You can download the documentation (that includes the screenshots missing from the post below) from:
www.logsat.com/spamfilter/pub/SpamFilterDocs.zip


The steps to configure SpamFilter ISP to use a Microsoft SQL Server database are:
 
1.    Install Microsoft SQL Server on a server (it can be installed on the same server running SpamFilter).
2.    Create an empty database in SQL Server. The samples below assume this database to be named “spamfilter”, but you can use any other naming convention
3.    In SQL Server, create a new SQL user and assign it dbo privileges for the “spamfilter” database. After the necessary tables have been created, the privileges can be reduced to allow this user only read/write data.
4.    Configure the database connection in SpamFilter to point to the above database. The simplest way to proceed is to use a UDL file (Microsoft's Universal DataLink) to define the connection to the SQL server. In the SpamFilter\database directory you'll find several .UDL files for each database platform. Please double-click on the one for SQL Server, SpamFilterMSSQL.udl. The correct OLE DB Provider should already be selected in the "Provider" tab. Under the "Connection" tab enter the name of your SQL server, and provide the username/password just created. Ensure you check the “Allow saving password” box so the credentials are saved in the UDL file. Please see the screenshot in Figure 13 for sample settings. Click on "Test Connection" to ensure the UDL file works.

Figure 13
5.    In SpamFilter, under the "Settings - Quarantine DB" tab, click on the "..." ellipse button to select a Connection String. In the box that follows, select "Use Data Link File" and select the SpamFilterMSSQL.udl you customized before. See screenshot in Figure 14 for sample settings.
6.    Use the 1-2-3 step wizard in SpamFilter's Quarantine DB tab to create the necessary tables in SpamFilter. On step 3, ensure to click on the “Save & Activate Conn String” button.
7.    Click on the “Save Settings” button.
 

Figure 14
 
 
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
rdemeyer View Drop Down
Newbie
Newbie


Joined: 29 October 2007
Location: United States
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote rdemeyer Quote  Post ReplyReply Direct Link To This Post Posted: 11 January 2008 at 4:51pm

Okay, back to the resolution search.

 
I created new database and tested the connection in the UDL Window.  Tested okay.  However in SPam Filter, when I check the connection in the "settings" it still gives the same error. 
Error Connecting to database!-
[DBNETLIB][ConnectionOpen{Connect{}.]SQL Server
does not exist or access denied
 
Any new ideas?
 
Thanks
 
Randy 
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 11 January 2008 at 5:02pm
Randy,

In the username/password fields, are you sure you specified a valid SQL account (not a Windows account) that has  "db owner" access to the SpamFilter database? Please also ensure the "Save password" box is checked.
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
rdemeyer View Drop Down
Newbie
Newbie


Joined: 29 October 2007
Location: United States
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote rdemeyer Quote  Post ReplyReply Direct Link To This Post Posted: 11 January 2008 at 5:23pm
Sorry I dodn't give you all the info on this.  We did confirm (and created a new) account and checked the db owner addition to the SQL DB files.
 
Can I just hire you to fix this for me?
 
Randy
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 12 January 2008 at 2:25pm
Randy,

If you can email us with information on how we can remote into your server (Remote Destop, VPN, PCAnywhere, etc), we can try to access your server to see what we can do.
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 15 January 2008 at 9:46pm
For documentation purposes, and to help solve similar problems - tere were two issues.
1 - The TCP/IP protocol was disabled in SQL Server, leaving only Named Pipes operational. The "UDL Test" would succeed as it uses named Pipes, but SpamFilter uses TCP/IP to communicate with SQL.

2. After enabling TCP/IP, SQL server still would not use TCP for communications. This turned out to be a Microsoft bug. The symptom and resolution were the same as in this KB article: http://support.microsoft.com/kb/306865


 
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.063 seconds.