Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - EmailTO is not in AuthorizedTOEmail list
  FAQ FAQ  Forum Search   Register Register  Login Login

EmailTO is not in AuthorizedTOEmail list

 Post Reply Post Reply
Author
lyndonje View Drop Down
Senior Member
Senior Member
Avatar

Joined: 31 January 2006
Location: United Kingdom
Status: Offline
Points: 192
Post Options Post Options   Thanks (0) Thanks(0)   Quote lyndonje Quote  Post ReplyReply Direct Link To This Post Topic: EmailTO is not in AuthorizedTOEmail list
    Posted: 18 December 2007 at 11:32am
We are having a problem with a new email address that we've setup. Error reported in log is as seen below:

12/18/07 16:15:55:787 -- (2276) - EmailTO is not in AuthorizedTOEmail list...
12/18/07 16:15:55:787 -- (2276) 65.54.246.84 - Mail from: abc@hotmail.co.uk To: zyx@rcpt-domain.co.uk will be disconnected

I have confirmed that:
- the email address is listed in tblwl_authorizedtoemails table
- SpamFilter has a connection to the database
- \domains\ ALL DOMAINS\WL_AuthorizedTOEmails.txt has the email address listed
- the email address is listed in the GUI under White Lists - 'Authorized TO Emails'

FYI, the recipient domain is not using default settings, and as such I have checked \domains\rcpt-domain.co.uk\WL_AuthorizedTOEmails.txt - but the email address is not listed here - so I am assuming this is where the problem is?

I have tried manually adding the new address into \domains\rcpt-domain.co.uk\WL_AuthorizedTOEmails.txt but the email is still not accepted - guessing this info is saved in memory and only read from TXT files if database is not available on a 'refresh'?

I have upgraded to v3.5.4.718 to see if this cures the problem, however it did not.

I would greatly appreciate a prompt response with this - as we may potentially have this problem with all recently added addresses with per domain configs enabled, and need to get this particular address working.

Thanks.
Back to Top
Desperado View Drop Down
Senior Member
Senior Member
Avatar

Joined: 27 January 2005
Location: United States
Status: Offline
Points: 1143
Post Options Post Options   Thanks (0) Thanks(0)   Quote Desperado Quote  Post ReplyReply Direct Link To This Post Posted: 18 December 2007 at 12:14pm

Lyndonje,

Are you saying that you are using SF in Enterprise mode?  And in the filtersettings in the GUI the address *IS* in the authorized to list?

The Desperado
Dan Seligmann.
Work: http://www.mags.net
Personal: http://www.desperado.com

Back to Top
lyndonje View Drop Down
Senior Member
Senior Member
Avatar

Joined: 31 January 2006
Location: United Kingdom
Status: Offline
Points: 192
Post Options Post Options   Thanks (0) Thanks(0)   Quote lyndonje Quote  Post ReplyReply Direct Link To This Post Posted: 18 December 2007 at 12:22pm
Yes, I am running in Enterprise mode.

The email address was listed when ALL DOMAINS was selected. If I look at the list while the domain in question is select, the address is displayed now - but is this because I've added the address to \domains\rcpt-domain.co.uk\WL_AuthorizedTOEmails.txt manually?

Urm.... does this mean when a new email address is added to tblwl_authorizedtoemails, if the domain to which the address is being added has a per domain config, the corresponding domainid needs to match???
Back to Top
Desperado View Drop Down
Senior Member
Senior Member
Avatar

Joined: 27 January 2005
Location: United States
Status: Offline
Points: 1143
Post Options Post Options   Thanks (0) Thanks(0)   Quote Desperado Quote  Post ReplyReply Direct Link To This Post Posted: 18 December 2007 at 12:36pm
Yes to the adding per domain.  The "AllDomains" is a template of sorts.  It is kinda a pain to manually add an address each time a new account is set up but you can set up some sort of stored procedure to grab a "non-live" file to insert into the SQL database.  What ever is in the SQL database is automatically written out to the text files to be used by SpamFilter.  If you manyally add to those text files, SpamFilter will over-write them with the SQL data.
The Desperado
Dan Seligmann.
Work: http://www.mags.net
Personal: http://www.desperado.com

Back to Top
lyndonje View Drop Down
Senior Member
Senior Member
Avatar

Joined: 31 January 2006
Location: United Kingdom
Status: Offline
Points: 192
Post Options Post Options   Thanks (0) Thanks(0)   Quote lyndonje Quote  Post ReplyReply Direct Link To This Post Posted: 19 December 2007 at 3:54am
Yes I am aware of the database overwriting. Just wasnt aware the domainid would need to match if the domain had its own config. Thanks for your input D, I've modified my code so that if usedefaults is not 1 then lookup the domainid and set that in the records for the email address.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.078 seconds.