Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - "Running as service" mode breaking.
  FAQ FAQ  Forum Search   Register Register  Login Login

"Running as service" mode breaking.

 Post Reply Post Reply
Author
MAS View Drop Down
Newbie
Newbie


Joined: 09 November 2007
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote MAS Quote  Post ReplyReply Direct Link To This Post Topic: "Running as service" mode breaking.
    Posted: 09 November 2007 at 12:53pm
v.3.5.4.718 standard version, On the settings tab, service mode would keep breaking and thereby causing the mail flow to quit unless logged into the console. 

Several service restarts and mode changes occurred to fix it, yet would keep reverting back to stand alone and not running as a service.Nuke

Finally, it took a complete uninstall and reinstall to fix.  Seems to be running smooth for the last 12 hours.  Problem cropped up yesterday, have been running this version since it's release with no problems.

Anyone else had this happen?Confused
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 10 November 2007 at 4:37pm
MAS,

SpamFilter does not use registry entries (other than the one to make it appear in the "Add/Remove Programs" and the one for the Windows Service). All of the files used by SpamFilter are contained within the "SpamFilter" installation directory. For this reason, uninstalling/reinstalling usually has no effect, and there are usually other problems that are lingering if that procedure *appears* to have solved the issue.

The most common problem consists in running multiple versions of SpamFilter concurrently (usually running the service and the standalone version at the same time), or in having another SMTP application (either a mail server or an antivirus server that also protects emails) running along with SpamFilter.

Please the following section of our manual for some things to consider when running SpamFilter, and possible problems with Terminal Services.

SpamFilter can run in two different ways.

As a Windows service (the most common - SpamFilterSvc.exe).
As a standalone application using SpamFilter.exe. This is mostly used for troubleshooting and testing purposes.

If SpamFilter is already running as a service, subsequently running the standalone application (SpamFilter.exe) will open a new instance of SpamFilter, it will not be the GUI for the service. This will most likely create a conflict, as two applications cannot bind to the same port on a server.

Please note that the SpamFilter service does show display a GUI (launched from an icon in the tray bar), but if you are accessing a Windows 2000 server remotely using Terminal Services will not be able to display the GUI. This is because Terminal Services in Windows 2000 is not able to display the server's physical console.

Looking at the physical server's screen, or using a product like PCAnywhere, DameWare, VNC etc that displays the actual screen will reveal the console.

Microsoft fixed this limitation in Windows 2003. In this version of the operating system, Terminal Services allows RDP clients to connect to the server's console.

 
Some Terminal Services clients have a checkbox in their settings that forces them to connect to the console. In the Remote Desktop client that ships with Windows XP, Microsoft (in)conveniently decided to not make this checkbox available. In this case, to view the server's physical console, you'll need to invoke Remote Desktop from the command line as follows:

mstsc -console



Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.141 seconds.