Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - Problem with multidomains on same mail server
  FAQ FAQ  Forum Search   Register Register  Login Login

Problem with multidomains on same mail server

 Post Reply Post Reply
Author
RBarrow View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote RBarrow Quote  Post ReplyReply Direct Link To This Post Topic: Problem with multidomains on same mail server
    Posted: 20 May 2003 at 1:32pm

We have a mail server which has several domains (Notes).  If someone from one of these domains sends an email to someone at another domain (same server), the message is routed to the SpamFilter, accepted but never delivered.

I have setup the domains to bypass all rules but still doesn't work...

 

Ideas?

roy

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4066
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 20 May 2003 at 2:48pm

Roy,

It appears as if the users of your domains are using the IP is listening on as their "outgoing mail server" in their email client configuration.

SpamFilter is designed to handle only your incoming email. The outgoing email from your users still needs to be handled by your SMTP server. There are several postings on this topic in the forum. If you search for "relay" or "outgoing" you should find most of them.

In short, your DNS MX record should point to the IP SpamFilter is listening on. You may also be able to configure your firewall to redirect incoming internet traffic on port 25 to the IP SpamFilter is listening on. You'll probably want to leave the IP address of your existing SMTP server as is, so that your clients will not have to change their configuration and keep pointing to it to use it as their outgoing smtp server.

Roberto Franceschetti
LogSat Sotware

Back to Top
Wayne View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Wayne Quote  Post ReplyReply Direct Link To This Post Posted: 20 May 2003 at 3:31pm

Your internal DNS where your clients point needs to resolve your MX records to your mailservers internal IP address, not it's external IP address and the internal DNS should be your clients primary DNS. This internal DNS could do any recursive lookups to the outside DNS server when required or you could proxy the users out.

Your mailserver could use the internal DNS for it's lookups if that DNS will do the recursion for external resolution. Barring that you can point your mailserver and spamfilter to an external DNS machine.

 

Back to Top
RBarrow View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote RBarrow Quote  Post ReplyReply Direct Link To This Post Posted: 20 May 2003 at 3:47pm

OK...let's try again...I understand MX records and DNS... not the problem...

Our SpamFilter server sets at xxx.xxx.xxx.10 for example

Our Notes server sets at xxx.xxx.xxx.15 for example

The Notes server handles several domains... Each domain has 2 mx records...high priority one points to the SpamFilter server, the other to the Notes server (in case the SpamFilter server goes down, mail still flows).

User1 on domain A sends an email to User2 on domain B (both domains are on the same Notes server). The mail routes to through the Notes SMTP MTA, looks up the DNS MX entry for Domain B (this points to the SpamFilter server), and initiates the session with the Spamfilter server.

The Spamfilter server says OK... check my rules for this message and this domain...and should forward the message back to the Notes server (this time it is inbound for User2 on domain B). But... the message never gets back to the Notes server... Spamfilter gets confused, lost, etc.  and the message just hangs...

Turn the Spamfilter server off and the message delivers fine...

Does that clarify the problem?

Tnx,

Roy

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4066
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 20 May 2003 at 4:06pm

Yes, now the picture is clearer.

It is strange Notes has to resort to an MX lookup for an email addressed to a domain it already owns, but it is absolutely a valid thing to do.

Having your internal DNS configured so that there is only one MX record for your domains, all pointing to your Notes server would render the process more efficient. Instead of having an email going from your User1:DomainA go to Notes, which then sends to SpamFilter, which then sends back to Notes to User2:DomainB, having a single internal MX pointing to Notes would make things work like User1:DomainA --> Notes --> USer2:DomainB.

Even though it's not the ideal configuration, SpamFilter should still work in your current configuration. If you can send us your SpamFilter.ini file and its activity log showing the incoming email we can take a look.

Roberto Franceschetti
LogSat Software

Back to Top
RBarrow View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote RBarrow Quote  Post ReplyReply Direct Link To This Post Posted: 20 May 2003 at 9:53pm

Well... since we are an ISP...there are no internal DNS servers...<G>

I will send the INI and the log in the AM..

 

Thanks,

Roy

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.094 seconds.