Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - timeout connection with Novell Groupwise
  FAQ FAQ  Forum Search   Register Register  Login Login

timeout connection with Novell Groupwise

 Post Reply Post Reply
Author
Dan B View Drop Down
Senior Member
Senior Member
Avatar

Joined: 09 February 2005
Location: United States
Status: Offline
Points: 104
Post Options Post Options   Thanks (0) Thanks(0)   Quote Dan B Quote  Post ReplyReply Direct Link To This Post Topic: timeout connection with Novell Groupwise
    Posted: 11 December 2006 at 3:58pm

Has anybody run into this issue?

A customer of ours has a DSL connection running their own mailserver.  They have their MX records pointing to our SpamFilter servers (primary & backup) so incase their DSL, or router, etc goes down and after scanning we redirect their outbound mail connection from port 25 to 20025 to connect to their Novell box.  We are seeing this happen more often than not.  That the SF servers will stop connecting to it and their mail gets queued on the SF servers.  The retry is set for 5 mins and SF is showing that it's trying and trying and trying while the Novell Engineer monitors the Groupwise connections and does not see any connections from our SF servers.  We stop and restart the service and then the queued mail starts delivering.  We have this type of setup on a few other customers but they are not using Novell.  We do not have any issues with them.  The problem occurs only with this one customer with Novell.  The Novell Engineer has tried every different setting to see if it's a timeout issue.

The tough part of this is...  it works for a few hours and stops. Then after about 12 hours not working, it starts working again on its own or if we restart the SF service.

Roberto, can you tell me what the timeout is for outbound connections?  Is it the same time setting as the incoming, or do you have something I can try?

Thanks,
Dan Blickensderfer
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 11 December 2006 at 7:40pm
Dan,

Starting from build 3.1.3.597, the timeout for the outgoing connections can be specified in the SpamFilter.ini file. The default is 60 seconds, and the value can be modified using the:

ReadTimeoutOutgoing

option. Could you zip us a few hours of SpamFilter's activity logfile for a day this happens, so we can try to spot any problems from the logs?

Also, could you try changing the option:

SpoolQueueFilesToMemory

in the SpamFilter.ini file, and set it to 0 (zero)? This prevents a new feature in version 3.x that spools outgoing files to memory, and forces them to be spooled to disk.

Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.063 seconds.