Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - non-RFC-compliant?
  FAQ FAQ  Forum Search   Register Register  Login Login

non-RFC-compliant?

 Post Reply Post Reply
Author
Seeb View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Seeb Quote  Post ReplyReply Direct Link To This Post Topic: non-RFC-compliant?
    Posted: 29 June 2006 at 4:53am

Hello

I have another question - during tests of my domain from http://www.dnsreport.com page I received an error:

ERROR: I could not complete a connection to any of your mailservers!

xxx.xxxx.xxx: The mailserver terminated the connection before the transaction was complete (state 8). This is not RFC compliant, and therefore either due to an error, or it may be the result of a non-RFC-compliant mailserver or non-RFC-compliant anti-spam program.

Of course site was trying to connect to Spam Filter.

Is that correct?

regards

Seeb

Back to Top
lyndonje View Drop Down
Senior Member
Senior Member
Avatar

Joined: 31 January 2006
Location: United Kingdom
Status: Offline
Points: 192
Post Options Post Options   Thanks (0) Thanks(0)   Quote lyndonje Quote  Post ReplyReply Direct Link To This Post Posted: 29 June 2006 at 10:30am

Not sure, but I have noticed the same since using SF. Be interesting to know what the reason is.

May be due dnsreport only doing some sort of 'quick' check, rather than emulating what an actual SMTP server would really do, and therefore the two get a different responses from SF which dnsreport interprets as a problem.

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 29 June 2006 at 4:31pm
SpamFilter is indeed forcefully terminating the connection from the remote server in some cases. This is not RFC compliant, as the RFC would like SpamFilter to simply output an error message to the remote server, allowing them to try again, and again and again... Until they get a correct recipient or a correct email.

The RFC is quite old in some sections, and they really need to update it to consider "spam" in the equation, as it was of no concern several years ago.

I do not believe we are going to follow the RFC strictly, and DNSReport has been advised that they should not consider those disconnect as "Errors" as they are by design.
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
Seeb View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Seeb Quote  Post ReplyReply Direct Link To This Post Posted: 30 June 2006 at 3:09am

Thank you for explanation

regards

Seeb

Back to Top
Desperado View Drop Down
Senior Member
Senior Member
Avatar

Joined: 27 January 2005
Location: United States
Status: Offline
Points: 1143
Post Options Post Options   Thanks (0) Thanks(0)   Quote Desperado Quote  Post ReplyReply Direct Link To This Post Posted: 03 July 2006 at 12:52am
Seeb,
 
In your "Allowedomains" list add:
[xxx.xxx.xxx.xxx]
where xxx.xxx.xxx.xxx is your mail server listen IP
 
In your BlockedToEmail list add:
where xxx.xxx.xxx.xxx is your mail server listen IP
 
DNSReport will then pass but you will not get any additional spam.
 
DnsReport uses the "Literal" address form to test your mail server and this makes SpamFilter accept the literal but then null it.


Edited by Desperado
The Desperado
Dan Seligmann.
Work: http://www.mags.net
Personal: http://www.desperado.com

Back to Top
Seeb View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Seeb Quote  Post ReplyReply Direct Link To This Post Posted: 03 July 2006 at 8:45am

Thanks Desperado,

I do not need to see DnsReport test pass. I just noticed it reports such thing and wanted to ask if is that intended in SpamFilter and I got my answer ;)

regards

Seeb

Back to Top
cwbrandsdal View Drop Down
Newbie
Newbie


Joined: 25 September 2007
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote cwbrandsdal Quote  Post ReplyReply Direct Link To This Post Posted: 18 June 2008 at 6:16am
Originally posted by Desperado Desperado wrote:

Seeb,
 
In your "Allowedomains" list add:
[xxx.xxx.xxx.xxx]
where xxx.xxx.xxx.xxx is your mail server listen IP
 
In your BlockedToEmail list add:
where xxx.xxx.xxx.xxx is your mail server listen IP
 
DNSReport will then pass but you will not get any additional spam.
 
DnsReport uses the "Literal" address form to test your mail server and this makes SpamFilter accept the literal but then null it.


We use the latest version of SpamFilter ISP, but can not find these lists.. Can anyone help uss on how to do this? We would like to have a clean dnsreport hehe

Thanks,
Christopher
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 18 June 2008 at 6:46am
If you're using SpamFilter Enterprise, you can follow the screenshot at:
http://www.logsat.com/sfi-spam-filter-screenshots/sfi-more-filtering-options.asp
and add the domain:

[xxx.xxx.xxx.xxx]

in the list of domains.

If you're using SpamFilter ISP, in the screenshot above, the list of domains in the upper left corner of the window will not be there, while instead you will see a tab labeled "Local Domains". That is the list Desperafo refers to, where the domain [xxx.xxx.xxx.xxx] should be added.

For the "BlockedToEmail" list Desperado refers to, that is actually the tab labeled "TO Email" in the Blacklist group of tabs, and that is where you should add *@[xxx.xxx.xxx.xxx]:null
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
cwbrandsdal View Drop Down
Newbie
Newbie


Joined: 25 September 2007
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote cwbrandsdal Quote  Post ReplyReply Direct Link To This Post Posted: 18 June 2008 at 7:29am
Thanks!

That worked, but now I get a more serious error. Is there any way to stop this?:

WARNING: One or more of your mailservers appears to be an open relay. If so, this means that you are allowing spammers to freely use the mailserver to send out spam! It is possible that your mailserver accepts all E-mail and later bounces it, or accepts the relay attempt and then deletes the E-mail, but this is not common.

WARNING: xxxx.xxxxxxx.no appears to be an open relay: 250 Not.abuse.see.www.DNSreport.com.from.IP.xxx.xxx.xxx.xxx@DNSreport.com Address Okay <br />
Back to Top
cwbrandsdal View Drop Down
Newbie
Newbie


Joined: 25 September 2007
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote cwbrandsdal Quote  Post ReplyReply Direct Link To This Post Posted: 19 June 2008 at 3:30am
I finally figured it out!

I had to remove :null from *@[xxx.xxx.xxx.xxx]:null.
Somehow DnsReport got a 250 respons back when the mail was sent to null.
What is prefered when we add to the blacklist? should we use :null or not? I would like to send as little respons as possible back to the sender lol.

Thanks!
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.094 seconds.