Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - Visual C++ Runtime error
  FAQ FAQ  Forum Search   Register Register  Login Login

Visual C++ Runtime error

 Post Reply Post Reply
Author
tgif View Drop Down
Newbie
Newbie


Joined: 24 November 2005
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote tgif Quote  Post ReplyReply Direct Link To This Post Topic: Visual C++ Runtime error
    Posted: 21 December 2005 at 9:10pm
Running SF 2.6.3.487 on Win2K SP4 with C 1.7 cpu and 512 mb ram.  Just got a Microsoft Visual C++ Runtime Library error:

Runtime Error!
Program: C:\......\SpamFilterSvc.exe
R6025
-pure virtual function call

No relating event was logged in either the SP log or application log.  SF continues to run with this error message displayed on screen.  SF service drops out as soon as I click on the OK button of this error message but was able to restart from service manager without a reboot.  Everything else seems to be working fine after service restart..... so far...

Have searched the entire SF ISP support and found nothing close to what I am having.  Any ideas please?
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 21 December 2005 at 9:53pm
That's extremely odd as we absolutely do not use Microsoft Visual C++ (nor any other Microsoft compilers...) to program SpamFilter.

Do you use the antivirus plugin? The DLLs used by the A/V are third party applications that are instead created with Microsoft C++.

Could you zip and email us SpamFilter's activity logfile for the day it crashed, so we can hopefully try to see if there are any pointers as to what may have happened?
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
tgif View Drop Down
Newbie
Newbie


Joined: 24 November 2005
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote tgif Quote  Post ReplyReply Direct Link To This Post Posted: 22 December 2005 at 2:52am
The computer was installed with only the basic just two days ago, not even anti-virus.  Only Win 2K Server Standard SP4 (with the endless list of M$ patchs and updates of course), MySQL,  SF ISP, VNC server and all other necessary connectors and plugin to make SF work.

Have sent you the log files, thanks.
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 22 December 2005 at 7:45am
From the logs we see that SpamFilter was working without a glitch even with the error dialog box on screen, until 9:52:44, which is when you "OK'd" it. This supports our initial theory that it is not a SpamFilter error (as again we do not use C), but rather an error from another appliction which took "ownership" of a SpamFilter thread, and that shut down SpamFilter when it errored out.

Please note that these are all theories, as in the last 4 years we've *never* seen anything like this...

Going back to the logs, we notice that between 2:10:00 and 2:14:48 your MySQL server was unavailable. Could you please check the MySQL logs to see if there were any failures at that time? A remote possibility is that MySQL shut down the process that owns a connection (SpamFilter...) when it crashed, and this only occurred when you clickeed on the OK button.
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.063 seconds.