Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - new setup - no mails
  FAQ FAQ  Forum Search   Register Register  Login Login

new setup - no mails

 Post Reply Post Reply
Author
cpufan View Drop Down
Newbie
Newbie
Avatar

Joined: 11 May 2005
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote cpufan Quote  Post ReplyReply Direct Link To This Post Topic: new setup - no mails
    Posted: 11 May 2005 at 4:35pm

Hi

I have installed Spamfilter on my server, running on the same ip as my mailserver (merak).

SMTP listener:
IP: "blank"
port: 25
FQDN: 80.196.52.171

Destination server:
ip: 127.0.0.1
port 26

Entered 3 dns-server's ip

entered in whitelist:
adweb.dk:80.196.52.171:26

Only thing I can see is this in log:
05-11-05 21:57:25:849 -- (1108) - SPF analysis for fep32.mail.dk done: - none
05-11-05 21:57:25:849 -- (1108) - Warning: Error during SPF record check - Socket Error # 11004
I don't get any mails sent through!!!

turning of SPF, let met rid of the above, but doesn't bring me any mails...

Using telnet to communicate on the two ports, are giving the correct answers

What is wrong??

//cpufan

Back to Top
Desperado View Drop Down
Senior Member
Senior Member
Avatar

Joined: 27 January 2005
Location: United States
Status: Offline
Points: 1143
Post Options Post Options   Thanks (0) Thanks(0)   Quote Desperado Quote  Post ReplyReply Direct Link To This Post Posted: 11 May 2005 at 6:18pm
SMTP listener:
IP: "blank"
IP:  I prefer to put the actual IP I want it to listen on but this should work.  If your IP is a translated Private IP, put that private IP in.
port: 25
FQDN: 80.196.52.171
FQDN means fully qualified domain name so should be something like mail.mydomain.com ... NOT an IP Address

Destination server:
ip: 127.0.0.1
ip should really be the "listener ip" of the destination server but this will work if the destination responds to it
port 26

Entered 3 dns-server's ip
entered in whitelist:
adweb.dk:80.196.52.171:26
Change this line to adweb.dk
Let the destination server information serve as the default.
 
Try telnetting into your destination server with port 26.  If it responds then make sure the destination server is not refusing traffic from "itself".

Regards,
The Desperado
Dan Seligmann.
Work: http://www.mags.net
Personal: http://www.desperado.com

Back to Top
cpufan View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote cpufan Quote  Post ReplyReply Direct Link To This Post Posted: 12 May 2005 at 4:07am
SMTP listener:
IP: "blank"
IP:  I prefer to put the actual IP I want it to listen on but this should work.  If your IP is a translated Private IP, put that private IP in.
now: 80.196.52.171
port: 25
FQDN: 80.196.52.171
now
FQDN: mail.adweb.dk
FQDN means fully qualified domain name so should be something like mail.mydomain.com ... NOT an IP Address

Destination server:
ip: 127.0.0.1
now: 80.196.52.171
ip should really be the "listener ip" of the destination server but this will work if the destination responds to it
port 26

Entered 3 dns-server's ip
entered in whitelist:
adweb.dk:80.196.52.171:26
now adweb.dk
Change this line to adweb.dk
Let the destination server information serve as the default.
 
Try telnetting into your destination server with port 26.  If it responds then make sure the destination server is not refusing traffic from "itself".
It is possible to telnet:
80.196.52.171:25
80.196.52.171:26
127.0.0.1:26
 
The destinationserver allows relaying from
80.196.52.171
127.0.0.1
and other locals.
 
But no mails coming through....
I can't even see anything in the activity-log,
but I can see that several servers made attempts in the statistics-menu.
 
So it has to be from the Spamfilter to the mailserver.
In Denmark the server is on a internetconnection, where the provider, only allow smtp-traffic to go through their server. It's the national phone-company - -
So to send mail from the spamfilter to the mailserver, i believe that i have to use a local ip, like 127.0.0.1 but that doesn't work either.

Any good suggestions??
I'm kind of desparate at the moment.....
 
// cpufan
Back to Top
lead View Drop Down
Newbie
Newbie
Avatar

Joined: 08 March 2005
Status: Offline
Points: 18
Post Options Post Options   Thanks (0) Thanks(0)   Quote lead Quote  Post ReplyReply Direct Link To This Post Posted: 17 May 2005 at 7:47am
destination server:

80.196.52.171:26

or

127.0.0.1:26

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4066
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 17 May 2005 at 4:37pm
Can you please provide the "Welcome Banner" that you receive in all three cases when telnetting to:

80.196.52.171:25
80.196.52.171:26
127.0.0.1:26

Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
jacksun View Drop Down
Newbie
Newbie


Joined: 24 February 2005
Status: Offline
Points: 31
Post Options Post Options   Thanks (0) Thanks(0)   Quote jacksun Quote  Post ReplyReply Direct Link To This Post Posted: 17 May 2005 at 4:48pm
You have spamfilter listening on port 25, but your email server needs to be listening on port 26 to receive the emails spamfilter is sending it. Simply putting x.x.x.x:26 won't work, the server must be listening on port 26 for SMTP.
I prefer to have spamfilter listen on 26 (my firewall forwards all port 25 traffic to mymailserverIP:26 where spamfilter intercepts it, does its thing and then forwards it to port 25 on my mail server)
 
What mail server are you running? You need to tell it to listen on port 26.


Edited by jacksun
Back to Top
cpufan View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote cpufan Quote  Post ReplyReply Direct Link To This Post Posted: 18 May 2005 at 11:20am

well, when i made the install as service it started to work,

but it cannot run as non-service.....

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4066
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 18 May 2005 at 4:44pm
Both service and standalone version of SpamFilter use the same configuration files, and will thus work the same. If you are having one work and the other not, it's very possible that youmay have IP-port conflicts with other applications (your SMTP server). Please note that only one application can listen on a certain port (ex. 25) on a specific IP. If multiple apps are configured to use the same combination IP:port, only the one that starts and "grabs" the IP 1st will be able to use it.
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.078 seconds.