Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - Can you please check this spf entry
  FAQ FAQ  Forum Search   Register Register  Login Login

Can you please check this spf entry

 Post Reply Post Reply
Author
Terry View Drop Down
Senior Member
Senior Member


Joined: 06 February 2005
Status: Offline
Points: 155
Post Options Post Options   Thanks (0) Thanks(0)   Quote Terry Quote  Post ReplyReply Direct Link To This Post Topic: Can you please check this spf entry
    Posted: 15 February 2005 at 3:07pm

When I run tests on this spf entry it comes back as "passed" however SpamFilter seems to give it a fail.  Can you check this out please...

user@tideworks.com from 12.129.5.51

Log entries...

02/15/05 09:55:11:391 -- (3160) Resolving 12.129.5.51 - mail1.tideworks.com
02/15/05 09:55:11:501 -- (3160) found SPF record for tideworks.com: v=spf1 mx -all
02/15/05 09:55:11:516 -- (3160) SPF query result: fail
02/15/05 09:55:11:516 -- (3160) - SPF analysis for tideworks.com done: - fail

Thanks

Terry

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 15 February 2005 at 6:00pm
Terry,

Can you please let us know what version of SpamFilter you're using?  There was a change made in build 2.1.2.405 that changed the way SPF queries are made, and with that build the test for the address you provided passes.
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
Terry View Drop Down
Senior Member
Senior Member


Joined: 06 February 2005
Status: Offline
Points: 155
Post Options Post Options   Thanks (0) Thanks(0)   Quote Terry Quote  Post ReplyReply Direct Link To This Post Posted: 15 February 2005 at 6:18pm

I am on 2.1.2.406.  Shortly after I posted this the spf started passing the connection.  It was failing between 2/3/2005 and today.  I wonder if they have made some dns changes on that day?  They don't think they did but I can't prove they did or didn't.  Next time if it happens again I will capture all their dns records while it is failing.

Terry

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 15 February 2005 at 7:08pm
You should be able to go back in SpamFilter's log to verify that. Most SPF details are logged, as you can see in the section you posted:

found SPF record for tideworks.com: v=spf1 mx -all

You can then see if the SPF record logged earlier is the same for the later one (and/or if the IP involved is the same or not).
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
Terry View Drop Down
Senior Member
Senior Member


Joined: 06 February 2005
Status: Offline
Points: 155
Post Options Post Options   Thanks (0) Thanks(0)   Quote Terry Quote  Post ReplyReply Direct Link To This Post Posted: 15 February 2005 at 7:52pm

I did go back from 2/3 forward and the ip address and the spf entry was always the same...My understanding (which is limited I admit) is that the mx part of the spf entry says that any server identified with an mx record can send email...if that is true then I cannot explain the problem showing up and then later resolving unless something else is happening...

log enties from the 3rd.....

02/03/05 14:18:24:121 -- (3648) Connection from: 12.129.5.51  -  Originating country : United States
02/03/05 14:18:24:621 -- (3648) Resolving 12.129.5.51 - mail1.tideworks.com
02/03/05 14:18:24:730 -- (3648) found SPF record: v=spf1 mx -all
02/03/05 14:18:24:746 -- (3648) SPF query result:
02/03/05 14:18:24:746 -- (3648) - SPF analysis for tideworks.com done: - pass

then from the 4th......

02/04/05 10:30:31:989 -- (3004) Connection from: 12.129.5.51  -  Originating country : United States
02/04/05 10:30:32:130 -- (3004) Resolving 12.129.5.51 - mail1.tideworks.com
02/04/05 10:30:32:286 -- (3004) found SPF record: v=spf1 mx -all
02/04/05 10:30:32:286 -- (3004) SPF query result:
02/04/05 10:30:32:286 -- (3004) - SPF analysis for Tideworks.com done: - fail
02/04/05 10:30:32:286 -- (3004) failed SPF test (fail) - Disconnecting 12.129.5.51

Terry

 

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 15 February 2005 at 10:57pm
This has us baffled... It does not look like the DNS entry for the SPF data has changed from your posts, but the fact that the result changed within hours is strange. We've looked at all their DNS servers and they seem in sync, right now the SPF test shows as "pass" for us as well...
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.078 seconds.