Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - Webinterface wount send registering emails
  FAQ FAQ  Forum Search   Register Register  Login Login

Webinterface wount send registering emails

 Post Reply Post Reply
Author
Ronny View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ronny Quote  Post ReplyReply Direct Link To This Post Topic: Webinterface wount send registering emails
    Posted: 30 June 2004 at 11:56am
Hi
 
I use the ASP version of the webinterface on a IIS server and the DB is MSSQL
 
When users register it connects and add the user and generates the password but it doesn't send the user the email.
 
If I get the username/password from the tbllogin table the user can log in fine and even select and "deliver selected" this is working as it should, but it absolutely refuses to send password to newly registered users, this baffles me as I can not see where it fails...
 
Any good ideas ??
I am using registered spamfilter 2.0.1.357
 
short version:
can register
can/will NOT send email to new registered users (basically, all is fine except this, and thus rendering it useless for me to give to my users)
can log in with new registered user
can send/deliver mail from quarantene
 
Back to Top
Desperado View Drop Down
Senior Member
Senior Member
Avatar

Joined: 27 January 2005
Location: United States
Status: Offline
Points: 1143
Post Options Post Options   Thanks (0) Thanks(0)   Quote Desperado Quote  Post ReplyReply Direct Link To This Post Posted: 30 June 2004 at 5:27pm

Make sure your sql message query looks close to :

 Message = Message & "." & vbCRLF
 SQL = "SELECT * FROM tblMsgs WHERE 0 = 1"
 rs.Open(SQL)
 rs.AddNew
 rs("Msg") = Message
 rs.Update
 MsgID = rs("MsgID")
 rs.Close
 SQL="SELECT * FROM tblQuarantine WHERE 0 = 1"
 rs.Open(SQL)
 rs.AddNew
 rs("EMailFrom") = "support@yourdomain.com"
 rs("EMailTo") = EMail
 rs("Subject") = "Your quarantine area password"
 rs("MsgID") = MsgID
 rs("MsgDate") = MessageDate
 rs("Expire") = 0
 rs("Deliver") = 1
 rs("ServerID") = 1  '(OR YOUR CORRECT SERVER ID)
 rs("RejectDetails") = ""
 rs("RejectID") = 0
 rs.Update
 rs.Close
 Set rs = Nothing

Regards,

Dan S.

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 01 July 2004 at 12:07am

Ronny,

In the "Register.asp" page, can you try modifying the line:

rs("EMailFrom") = "System Administrator <>"

to something like:

rs("EMailFrom") = "someemail@yourdomain.com"

Roberto F.
LogSat Software

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.078 seconds.