Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - bind () error 10048
  FAQ FAQ  Forum Search   Register Register  Login Login

bind () error 10048

 Post Reply Post Reply
Author
Chipsin View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Chipsin Quote  Post ReplyReply Direct Link To This Post Topic: bind () error 10048
    Posted: 13 May 2004 at 8:24am

Need Help!

I have two public IPs assigned to a NIC. When I run two SMTP services with Different IP and same Port No (25) i receive bind () error 10048. Different IPs cannot have same port numbers??,. If so please point me to the resource which says so.  It works when i change port No to different one for any one SMTP but I want to use same port for both SMTP.

IPAddress 1: Port 25

IPAddress 2: Port 25

Thanks in Advance

Chipsin

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 13 May 2004 at 10:02pm

Chipsin,

What two "SMTP services" are you running? Soome applications are well behaved, and will only bind to specific IPs if you configure them so. Others instead will grab any free IP on the server and bind to it no matter what.

Roberto F.
LogSat Software

Back to Top
Chipsin View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Chipsin Quote  Post ReplyReply Direct Link To This Post Posted: 14 May 2004 at 12:21am

Dear Sir,

The Fist SMTP is the Microsoft SMTP server on IIS.. and the second one is a customised SMTP server which we developed in Microsoft VC++ 6.0 on Winsock API .

We have a .ini file for the SMTP server which we developed and there is a provision to define the IP the server has to use. Are there still chances for grabbing another IP which is already alloted to MS SMTP? .

Many Thanks

Chip

Back to Top
bpogue99 View Drop Down
Groupie
Groupie


Joined: 26 January 2005
Status: Offline
Points: 59
Post Options Post Options   Thanks (0) Thanks(0)   Quote bpogue99 Quote  Post ReplyReply Direct Link To This Post Posted: 19 May 2004 at 11:12am

This issue is called Socket Pooling. Search for that term plus maybe "IIS" "SMTP" "share" or other similar terms. The issue comes down to that IIS, when it starts, doesn't care what the IP is nor does it care how many adapters may exist. Even if you go into the settings and select the specific IP to bind to for IIS SMTP it won't change how IIS grabs all IP's on all adapters. To change this "feature" you have to disable Socket Pooling. This is a metabase edit so be careful, but the KB article clearly explains the steps and it's not very difficult. Once you make that change IIS, or Exchange, or whatever Microsoft product it is that's stomping all over the IP's will stop doing that and will bind only to the adapter chosen in the properties settings. This will allow you to load up SF on a specific IP and load IIS SMTP on a different IP but both use the same ports. The main reason that Socket Pooling is not disabled by default is to support multi-homed servers.

IP Switch's IMail has this same problem with grabbing port 25 on all IP's, but there's no feature or edit to get their service to bind to a specific IP only. When IP Switch's smtp service loads it grabs all the IP's; however, when SF loads it will "take over" the answering of that IP as long as SF is last to load. If you then restart the SMTP service on IMail it will attempt to retake control of port 25 on the IP that SF grabbed, and when it can't, it fails to start. I've contacted IP Switch about this issue but the response has been less than favorable towards a solution. So, whenever I restart IMail SMTP I also restart SF... luckily I have only 1 customer using IMail. <G>

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.063 seconds.