Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - New Install, Errors and Quarentine issues??
  FAQ FAQ  Forum Search   Register Register  Login Login

New Install, Errors and Quarentine issues??

 Post Reply Post Reply
Author
Ed View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ed Quote  Post ReplyReply Direct Link To This Post Topic: New Install, Errors and Quarentine issues??
    Posted: 25 September 2003 at 12:32pm

Error from legite e-mail - not forwarding
 09/25/03 10:28:25:921 -- (359) Mail from: emfinkk@hotmail.com  ((This is my hotmail account that worked before SPAM Filter))
 09/25/03 10:28:28:296 -- (337) Exception occurred during RECEIVEMESSAGE: Insufficient base table information for updating or refreshing

Response in my Hotmail Account:
 Final-Recipient: rfc822;finke@eaglestl.com
 Action: failed
 Status: 5.0.0
 Diagnostic-Code: smtp;557 The server encountered an error while processing this
 message. Please retry later.
 nsed Evaluation Copy

I use the default MAPS Servers
I have a notepad attached under domains (Black/White Lists) - Taken from my Exchange server under the connections settings.  I have been adding to this for a year it has over 9000 entries

Error quarentine - No entries in quarentine database - Shows Active  ((Below is a legit sender that worked before SPAM Filter))
 09/25/03 10:41:38:515 -- (365) 194.3.224.25 - Mail from: deborah.sanford@cgey.com To: sanfordjs@eaglestl.com will be quarantined
 09/25/03 10:41:39:031 -- (365) Exception occurred during RECEIVEMESSAGE: Insufficient base table information for updating or refreshing
 09/25/03 10:41:43:890 -- (365) Disconnect

My Database Connection String

 Provider=MSDASQL.1;Persist Security Info=False;Extended Properties="DBQ=E:\Program Files\SpamFilter\Database\SpamFilter.mdb;DefaultDir=E:\Program Files\SpamFilter\Database;Driver={Microsoft Access Driver (*.mdb)};DriverId=25;FIL=MS Access;FILEDSN=E:\Program Files\SpamFilter\Database\SpamFilter.dsn;MaxBufferSize=2048;MaxScanRows=8;PageTimeout=5;SafeTransactions=0;Threads=3;UID=admin;UserCommitSync=Yes;"

My Database Step 2

================
please wait...
Found tblQuarantine
Found tblMsgs
Found tblRejectCodes
Found tblLogins
Found tblServers
Added Server to tblServers
Retrieved ServerID from tblServers: 0
Done.
I am using the Access database provided with the software


A sample of other events from the Activity log
 09/25/03 08:37:02:468 -- (345) EMail from rebekah@crossteccorp.com to kriebaumd@eaglestl.com  was forwarded to 192.168.0.10
09/25/03 08:37:35:531 -- (359) Connection from: 69.6.16.123  -  Originating country : United States
09/25/03 08:37:35:828 -- (359) Resolving 69.6.16.123 - 23.bluerocketonline.com
09/25/03 08:37:35:953 -- (359) Mail from: b.TailWaggingOffer.0-22c080f-48d4.eaglestl.com.-mitch@23.bluerocketonline.com
09/25/03 08:37:35:984 -- (359) - MAPS search done... 521 The IP 69.6.16.123 is Blacklisted by bl.spamcop.net.5Blocked - see http://spamcop.net/bl.shtml?69.6.16.123 .
09/25/03 08:37:35:984 -- (359) 69.6.16.123 - Mail from: b.TailWaggingOffer.0-22c080f-48d4.eaglestl.com.-mitch@23.bluerocketonline.com To: mitch@eaglestl.com will be quarantined
09/25/03 08:37:36:609 -- (359) Exception occurred during RECEIVEMESSAGE: Insufficient base table information for updating or refreshing
09/25/03 08:37:41:406 -- (359) Disconnect
09/25/03 08:38:11:312 -- (331) Connection from: 170.135.240.61  -  Originating country : United States
09/25/03 08:38:11:625 -- (331) Resolving 170.135.240.61 - mail1.usbank.com
09/25/03 08:38:11:765 -- (331) Mail from: KRISTI.FREELAND@usbank.com
09/25/03 08:38:17:046 -- (331) - MAPS search done... .
09/25/03 08:38:17:046 -- (331) RCPT TO: TrottsT@eaglestl.com accepted
09/25/03 08:38:17:312 -- (331) EMail from KRISTI.FREELAND@usbank.com to TrottsT@eaglestl.com was queued. Size: 3 KB
09/25/03 08:38:17:312 -- (357) Sending email from KRISTI.FREELAND@usbank.com to TrottsT@eaglestl.com
09/25/03 08:38:26:468 -- (357) EMail from KRISTI.FREELAND@usbank.com to TrottsT@eaglestl.com  was forwarded to 192.168.0.10
09/25/03 08:38:44:781 -- (331) Disconnect
09/25/03 08:39:17:500 -- (342) Connection from: 212.113.98.98  -  Originating country : Russian Federation
09/25/03 08:39:18:453 -- (342) Resolving 212.113.98.98 - mail.paymailbox.com
09/25/03 08:39:18:562 -- (342) Mail from: ECQ412342O611l@paymailbox.com
09/25/03 08:39:23:968 -- (330) Connection from: 69.36.206.6  -  Originating country : N/A
09/25/03 08:39:24:140 -- (342) - MAPS search done... .
09/25/03 08:39:24:140 -- (342) RCPT TO: daym@eaglestl.com accepted
09/25/03 08:39:24:234 -- (330) Resolving 69.36.206.6 - Not found

I like what I see so far and would love to get these bugs worked out to fully evaluate.

Any help is greatly appreciated - Thank You

 

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 25 September 2003 at 2:58pm

Ed,

From the error description it looks like a problem with the database.

First of all make sure you have MDAC 2.7 or higher installed, as previous version have problems. Note that even if you install 2.7, some applications overwrite dll with older ones when they are installed. We recommend using the MDAC Component Checker to see what version is actually on the server (http://msdn.microsoft.com/library/default.asp?url=/downloads/list/dataaccess.asp.).

In case the dabase is corrupted, try to close SpamFilter, delete the SpamFilter.mdb database and replace it with the one in the SpamFilter.zip file (in the win32\database path in the zipped archive). Restart SpamFilter. Your connection string should still be there, do not run Step 2 in the database wizard this time.

Roberto F.
LogSat Software

Back to Top
Ed View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ed Quote  Post ReplyReply Direct Link To This Post Posted: 25 September 2003 at 4:23pm

I did not have the correct MDAC.  I have installed MDAC 2.8 and replaced the .mdb file.  I still recieve the following:

/25/03 15:01:13:156 -- (343) 12.110.253.50 - Mail from: UPC_PeopleSoft@upbna.com To: upservice@eaglestl.com will be quarantined
09/25/03 15:01:13:437 -- (343) Exception occurred during RECEIVEMESSAGE: Insufficient base table information for updating or refreshing
09/25/03 15:01:13:468 -- (343) Disconnect

This is a valid e-mail account and nothing is showing up in the quarentine.  Under "Quarentine DB" in "Settings" I ran ONLY step 1 and recieved "...Successfully connected.."

 

Back to Top
eric View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote eric Quote  Post ReplyReply Direct Link To This Post Posted: 05 October 2003 at 8:43am

i am having the same problem with / after upgrading to windows 2003

logsat just stopped working with the mdb connection,

sql however runs fine, but i don`t want my firewall have 1433 open with the slammer still present on the net.

i had to go back to version 1.1.2.124 without database, to get it running, on 2003

on 2003 i ran the mdac 2.8 setup to make sure...

i guess 206 is not of the happiest releases so far.

 

tried on several servers and hardware....

.201 is running fine bye the way on w2k3, but i want the options from

.206 !

 

-eric-

 

 

Back to Top
eric View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote eric Quote  Post ReplyReply Direct Link To This Post Posted: 05 October 2003 at 8:49am

.206 on windows 2003 with mdac 2.8 :

what you are telling here gives :

10/05/03 14:45:52:664 -- Starting to process queue directory...
10/05/03 14:46:10:630 -- Exception occurred during ProcessQuarantineQueue: Class not registered
10/05/03 14:46:15:617 -- Exception occurred during ProcessQuarantineQueue: Class not registered

how do we make the tables now ?

step2 corrupts the mdb file totally (on multiple systems)

some database tables not found : recreating ->

then a real heavy error occurs, drwatson and the mdm jump in and logsat hangs.

spamfilter says cannot open file and hangs forever.

 

 

Back to Top
Ed View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ed Quote  Post ReplyReply Direct Link To This Post Posted: 06 October 2003 at 9:12am

I am not sure what happened.  I did some furhther vrifying of the datatbase, shutdown and restarted the LogSat server.  Quarentined items now show in the GUI. 

Another problem.  I cannot send items from quarentine to recipient via GUI.  I am not using the web interface yet.  I get error:

10/06/03 07:34:38:609 -- Exception occurred during MarkQuarantineItemsForDelivery: -1 is not a valid value for field 'Deliver'. The allowed range is 0 to 65535.

I have verified that 'Deliver' = 0 and server ID=1.  Where would I look to verify 'MarkQuarantineItemsForDelivery' = ?.  Any other ideas?

 

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 06 October 2003 at 10:06pm

We're in the process of testing the Access database on a Windows 2003 server to try to reproduce the problem.

Roberto F.
LogSat Software

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 06 October 2003 at 10:07pm

Ed,

Can you please let us know what version of Windows you are using?

Roberto F.
LogSat Software

Back to Top
Ed View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ed Quote  Post ReplyReply Direct Link To This Post Posted: 07 October 2003 at 8:42am
Using my WINNT 4.0 Server sp6   Spam Filter v. 1.2.0.178
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 09 October 2003 at 11:07pm

Ed,

We were not able to reproduce the problem. We have a new beta version available on our website. Have you tried that to see if you receive the same errors?

Roberto F.
LogSat Software

Back to Top
Ed View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ed Quote  Post ReplyReply Direct Link To This Post Posted: 10 October 2003 at 9:17am

Did you try to reproduce on a WIN 2003 machine or a WINNT.  There is a response from an "eric" talking about a WIN 2003 machine.  I am using a WINNT 4.0 SP6.  The "eric" message is not part of my forum.

Back to Top
eric View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote eric Quote  Post ReplyReply Direct Link To This Post Posted: 11 October 2003 at 7:21pm

great, please note that it are large dual x86 intel machines withalotta ram...

and hyperthreading ON

2048mb or more...

i am also still tracing the problem, but so far no info...

NOTE : if i use .206 on a normal compaq or dell 1 cpu machine 1gb ram , no problem at all

 

logsat is a great produkt so far,

many thanx from 3000+ users behing my server,

they never will understand why //""they never get spam""//  haha

 

Back to Top
eric View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote eric Quote  Post ReplyReply Direct Link To This Post Posted: 11 October 2003 at 7:43pm

GOTCHA

machines with 2 - 4gb ram and hyperthreading : (4+ cpu`s for logsat to play with..)

tun off hyperthreading

add /3gb switch in boot ini file

logsat runs

when turning it on again, logsat refuses to access the msaccess database,

however mysql and mssql run fine, with any option.

i suspect a ram commit failure in ms odbc mdac 2.7 and 2.8,

NOT LOGSAT !

-eric-

happyness :

================
please wait...
Found tblQuarantine
Found tblMsgs
Found tblRejectCodes
Found tblLogins
Found tblServers
Added Server to tblServers
Retrieved ServerID from tblServers: 2
Done.

Back to Top
eric View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote eric Quote  Post ReplyReply Direct Link To This Post Posted: 12 October 2003 at 12:08pm

i did mail my tracedump to ms$ in order to have them acknowledge the problem

with 2gb+ systems

i have a EA6 contract with them, so i can report them directly.

so far, logsat seems NOT the problem, the ACCESS odbc connector and mdac 2.7sp1 and mdac 2.8 are the problem.

i was able to build the error on an athlon also with XP :

    <MATCHING_FILE NAME="kernel32.dll" SIZE="930304" CHECKSUM="0xCBCCF8A9" BIN_FILE_VERSION="5.1.2600.1106" BIN_PRODUCT_VERSION="5.1.2600.1106" PRODUCT_VERSION="5.1.2600.1106"

FILE_DESCRIPTION="Windows NT BASE API Client DLL" ORIGINAL_FILENAME="kernel32" INTERNAL_NAME="kernel32" ms$ : //"spamfiltersvc.exe what is that ?"//    :-)

 

lowering ram under 2048 mb solves the problem.

-eric-

 

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 13 October 2003 at 12:22am

Eric,

Thanks for letting us know, we were banging our heads against a wall trying to reproduce it. None of our test boxes have more that 1GB of RAM (SpamFilter takes up so little it's no use to us :-) so never saw anything like you're seing.

Roberto F.
LogSat Software

Back to Top
eric View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote eric Quote  Post ReplyReply Direct Link To This Post Posted: 13 October 2003 at 9:12pm

no answer yet from the ms$ friends.....

and sorry for saying this of course :

<NOT TRUE>//i guess 206 is not of the happiest releases so far.// </NOT TRUE>

-eric-

Back to Top
eric View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote eric Quote  Post ReplyReply Direct Link To This Post Posted: 09 November 2003 at 6:11pm

guess what, my Technical Account Manager doesn`t want to talk to me anymore :

eric : that weird jet 8 (30-10-2003) update fixed all my 2gb+ memory errors in logsat

tam : oh great

eric : do i or logsat get our own Kb article now ? like sysinternals .....

tam : it has nothing to do with your question

eric : oh ? thus it is fixed, like uhm the pfy-dilbert case

tam makes a weird noise and walks away....

eric : well thanks anyway ms$ for fixing my non-existing problem, with the M-alloc heap

in mdac, if i worked for you, i would be a millionaire now... !

.....

the sad part is that is is a true story....

 

Back to Top
jerry View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote jerry Quote  Post ReplyReply Direct Link To This Post Posted: 20 June 2005 at 5:00am
Originally posted by Ed Ed wrote:

Error from legite e-mail - not forwarding
 09/25/03 10:28:25:921 -- (359) Mail from: emfinkk@hotmail.com  ((This is my hotmail account that worked before SPAM Filter))
 09/25/03 10:28:28:296 -- (337) Exception occurred during RECEIVEMESSAGE: Insufficient base table information for updating or refreshing

Response in my Hotmail Account:
 Final-Recipient: rfc822;finke@eaglestl.com
 Action: failed
 Status: 5.0.0
 Diagnostic-Code: smtp;557 The server encountered an error while processing this
 message. Please retry later.
 nsed Evaluation Copy

I use the default MAPS Servers
I have a notepad attached under domains (Black/White Lists) - Taken from my Exchange server under the connections settings.  I have been adding to this for a year it has over 9000 entries

Error quarentine - No entries in quarentine database - Shows Active  ((Below is a legit sender that worked before SPAM Filter))
 09/25/03 10:41:38:515 -- (365) 194.3.224.25 - Mail from: deborah.sanford@cgey.com To: sanfordjs@eaglestl.com will be quarantined
 09/25/03 10:41:39:031 -- (365) Exception occurred during RECEIVEMESSAGE: Insufficient base table information for updating or refreshing
 09/25/03 10:41:43:890 -- (365) Disconnect

My Database Connection String

 Provider=MSDASQL.1;Persist Security Info=False;Extended Properties="DBQ=E:\Program Files\SpamFilter\Database\SpamFilter.mdb;DefaultDir=E:\Progr am Files\SpamFilter\Database;Driver={Microsoft Access Driver (*.mdb)};DriverId=25;FIL=MS Access;FILEDSN=E:\Program Files\SpamFilter\Database\SpamFilter.dsn;MaxBufferSize=2048; MaxScanRows=8;PageTimeout=5;SafeTransactions=0;Threads=3;UID =admin;UserCommitSync=Yes;"

My Database Step 2

================
please wait...
Found tblQuarantine
Found tblMsgs
Found tblRejectCodes
Found tblLogins
Found tblServers
Added Server to tblServers
Retrieved ServerID from tblServers: 0
Done.
I am using the Access database provided with the software


A sample of other events from the Activity log
 09/25/03 08:37:02:468 -- (345) EMail from rebekah@crossteccorp.com to kriebaumd@eaglestl.com  was forwarded to 192.168.0.10
09/25/03 08:37:35:531 -- (359) Connection from: 69.6.16.123  -  Originating country : United States
09/25/03 08:37:35:828 -- (359) Resolving 69.6.16.123 - 23.bluerocketonline.com
09/25/03 08:37:35:953 -- (359) Mail from: b.TailWaggingOffer.0-22c080f-48d4.eaglestl.com.-mitch@23.blu erocketonline.com
09/25/03 08:37:35:984 -- (359) - MAPS search done... 521 The IP 69.6.16.123 is Blacklisted by bl.spamcop.net.5Blocked - see http://spamcop.net/bl.shtml?69.6.16.123 .
09/25/03 08:37:35:984 -- (359) 69.6.16.123 - Mail from: b.TailWaggingOffer.0-22c080f-48d4.eaglestl.com.-mitch@23.blu erocketonline.com To: mitch@eaglestl.com will be quarantined
09/25/03 08:37:36:609 -- (359) Exception occurred during RECEIVEMESSAGE: Insufficient base table information for updating or refreshing
09/25/03 08:37:41:406 -- (359) Disconnect
09/25/03 08:38:11:312 -- (331) Connection from: 170.135.240.61  -  Originating country : United States
09/25/03 08:38:11:625 -- (331) Resolving 170.135.240.61 - mail1.usbank.com
09/25/03 08:38:11:765 -- (331) Mail from: KRISTI.FREELAND@usbank.com
09/25/03 08:38:17:046 -- (331) - MAPS search done... .
09/25/03 08:38:17:046 -- (331) RCPT TO: TrottsT@eaglestl.com accepted
09/25/03 08:38:17:312 -- (331) EMail from KRISTI.FREELAND@usbank.com to TrottsT@eaglestl.com was queued. Size: 3 KB
09/25/03 08:38:17:312 -- (357) Sending email from KRISTI.FREELAND@usbank.com to TrottsT@eaglestl.com
09/25/03 08:38:26:468 -- (357) EMail from KRISTI.FREELAND@usbank.com to TrottsT@eaglestl.com  was forwarded to 192.168.0.10
09/25/03 08:38:44:781 -- (331) Disconnect
09/25/03 08:39:17:500 -- (342) Connection from: 212.113.98.98  -  Originating country : Russian Federation
09/25/03 08:39:18:453 -- (342) Resolving 212.113.98.98 - mail.paymailbox.com
09/25/03 08:39:18:562 -- (342) Mail from: ECQ412342O611l@paymailbox.com
09/25/03 08:39:23:968 -- (330) Connection from: 69.36.206.6  -  Originating country : N/A
09/25/03 08:39:24:140 -- (342) - MAPS search done... .
09/25/03 08:39:24:140 -- (342) RCPT TO: daym@eaglestl.com accepted
09/25/03 08:39:24:234 -- (330) Resolving 69.36.206.6 - Not found

I like what I see so far and would love to get these bugs worked out to fully evaluate.

Any help is greatly appreciated - Thank You

 

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 21 June 2005 at 7:06pm
Jerry,

This topic, along with solutions, was posted back in 2003. Do you have any new information to add?
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.094 seconds.