Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - Allowing Internal IP Addresses that have no reverse DNS
  FAQ FAQ  Forum Search   Register Register  Login Login

Allowing Internal IP Addresses that have no reverse DNS

 Post Reply Post Reply
Author
John View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote John Quote  Post ReplyReply Direct Link To This Post Topic: Allowing Internal IP Addresses that have no reverse DNS
    Posted: 08 September 2003 at 4:52pm

I am behind a firewall at 192.168.1.X  the mail server is at an outside address on the same router.  Although connected to the same router I get an error that my email is rejected due to no reverse dns.

The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was 'jalbr8@yahoo.com'. Subject 'test', Account: 'ALBRIGHT', Server: 'X.X.X.X', Protocol: SMTP, Server Response: '557 Your IP 192.168.1.11 does not have a reverse DNS entry. Disconnecting...', Port: 25, Secure(SSL): No, Server Error: 557, Error Number: 0x800CCC79

How do I allow Internal addresses?

The mail software post.office and your spam software are on the same server.  While the spam software monitors port 25, I have the mail software SMTP set to port 26.  The spam software forwards to the server of the same name at the altered port 26.

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 08 September 2003 at 5:54pm

John,

SpamFilter is designed to handle incoming email only, outgoing email should still be processed by your existing post.office SMTP server. There are many posts on this forum and on our website that show sample configurations on how to accomplish this with minimal network changes.

This said, there are some users who still wish to use SpamFilter to handle outgoing traffic as well.

A couple of solutions for your issue would be (1) to add an inaddr reverse zone to your external DNS so it can resolve 192.168.1.X to a valid IP, or (2) to add 192.168.1.X to the IP whitelist (note that this will cause all your outgoing connection to not be filtered).

Roberto F.
LogSat Software

Back to Top
eric View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote eric Quote  Post ReplyReply Direct Link To This Post Posted: 14 September 2003 at 11:38am

it is always recommended to install an caching dns server on the host where logsat runs,

this dns server speeds up logsat an little 100 % :-)

note that this server can be spoofed in the cache because it is a ms$ dns,

configure your firewall so it only communicates with your main nameserver only (allow tcp/udp53 only from main to logsat server)

cached rbl dns rules.

i use also :

customised ttl in my cache of 1 day, so the burden on mij nameserver is low.

-eric-

 

ps : please remember that logsat performrs rdns and rbl dns lookup per mail...

 

 

 

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.094 seconds.