Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - Experiencing Slow performance
  FAQ FAQ  Forum Search   Register Register  Login Login

Experiencing Slow performance

 Post Reply Post Reply
Author
Thomas W. View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Thomas W. Quote  Post ReplyReply Direct Link To This Post Topic: Experiencing Slow performance
    Posted: 07 July 2003 at 12:37pm

We've been experiencing some REALLY slow performance this past week, and I'm not sure why.

We're running v1.1.2.124 on a P4 2Ghz w/256MB memory.  We normally get about 1k message per day and usually get only 5-6 concurrent connections (we've been running SpamFilter for about 2 months now with no problems).  Our keyword list is a paltry 30k.

This past few days, we've been getting upwards to 50-70 connections that don't seem to disconnect. (Surprisingly, the vast majority is coming from Hotmail servers).  CPU usage spikes up to 100%, and memory usage slowly grows to the point where performance bogs down and we can't get email.

The connections list doesn't show a "Mail From" value for the Hotmail server connections, though it does display the IP.  These are the connections that don't go away.

Which brings up one question: what is the "Kill" column for in the Connections window?

 

I'd appreciate any ideas/thoughts/suggestions!

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 07 July 2003 at 4:26pm

Thomas,

If receiving large messages the number of keywords that are scanned for in the email affect performance greatly. Your list is quite large and if you have multiple concurrent incoming emails with large attachments that will cause problems.

The good news is that version 1.2 has an option to disable keyword scanning for messages sizes over a user-selectable threshold, which greatly enhances performance. I strongly recommend you to upgrade if you are still experiencing these issues.

The "Kill" attempts to force a disconnect of the remote connection.

Roberto Franceschetti
LogSat Software

Back to Top
Thomas W. View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Thomas W. Quote  Post ReplyReply Direct Link To This Post Posted: 07 July 2003 at 5:33pm

Hi Roberto,

We took your advice and upgraded to v1.2 build 178. 

Without changing any of the configuration after the upgrade, our problem was resolved.  The persistent connections from the Hotmail servers disconnected properly after a short period.

Thanks!

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.064 seconds.