Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - Relay settings
  FAQ FAQ  Forum Search   Register Register  Login Login

Relay settings

 Post Reply Post Reply
Author
Terry Kuntz View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Terry Kuntz Quote  Post ReplyReply Direct Link To This Post Topic: Relay settings
    Posted: 01 April 2003 at 12:00am

I have a problem with relaying and I'm hoping it's just a configuration problem. I have my main domain setup but I have users with email addresses at the local university that need to send email out through our gateway. Their email address shows the university email and SpamFilter blocks it as it considers it relaying. Is there a way to get the university email to go through SpamFilter?

Thanks

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 01 April 2003 at 12:00am

Terry,

Are the university users trying to send *you* email, or are they trying to send email to the outside (eg to joe@yahoo.com)?

If the answer is the 2nd (to the outside), that should not work. SpamFilter is designed to handle your *incoming* email only. Users mailing to the outside should sitll have in their "outgoing SMTP server" settings in their email clients the address of your SMTP server, not SpamFilter.

If the problem is that they can't send email to you, are you sure that you entered your domain in the "Local Domains" list?

If you want to email us a copy of your spamfilter.ini file at support@logsat.com, along with a description of the meial domains involved in this, we'll take a look.

Roberto Franceschetti LogSat Software

Back to Top
Terry Kuntz View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Terry Kuntz Quote  Post ReplyReply Direct Link To This Post Posted: 01 April 2003 at 12:00am

Yes, they are trying to send from the university address. I have SpamFilter running on the same machine as the mail server. SpamFilter intercepts port 25 and send to the mail server at port 26. Most of my users are using the Eudora mail client. I have sent them an email to see if there is a way to specify a nonstandard port for SMTP.

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 01 April 2003 at 12:00am

Terry,

It would be easier to leave you SMTP server's IP and port unchanged, so that all your (and university) clients will not have to change their settings. It'd be better to install SpamFilter on a new, separate IP address, and then change your primary MX record to deliver email to SpamFilter rather than to your SMTP server (you can leave your SMTP serrver as a secondary MX record while testing).

Robert F. LogSat Software

Back to Top
Terry Kuntz View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Terry Kuntz Quote  Post ReplyReply Direct Link To This Post Posted: 01 April 2003 at 12:00am

Thanks for the comments. If I get to where I can add another box to the server room I'll put SpamFilter on a separate server. For now I have had the users add a line to their eudora.ini file to send SMTP to port 26.

Thanks Again.

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 01 April 2003 at 12:00am

You're probably aware of this already, but let me say it just in case. If you have available IP from your network group, you should be able to add (bind) a new IP to the NIC card on the existing server, and have SpamFilter listen on that new IP without interfering with the existing one assinged to your smtp server.

Roberto

Back to Top
Lee View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Lee Quote  Post ReplyReply Direct Link To This Post Posted: 01 April 2003 at 12:00am

Terry, I read through the entire post and it might be me but it sounded like there was still some confusion.

["Their email address shows the university email and SpamFilter blocks it as it considers it relaying. Is there a way to get the university email to go through SpamFilter? "]

Keep in mind EVEN if your users are sending mail FROM the University domain they can NOT send mail to the Spamfilter machine/software that is bound for someone OUTSIDE the University. So if lee@university.edu was sending an email to terry@yahoo.com and tried to send it through Spamfilter, it will be blocked.

The Domain List determines which domains to accept mail FOR so it will only pass email being sent TO:lee@university.edu. I have the same problem because I have users outside of my network and I have all inbound mail coming through Spamfilter and outbound going through another machine.

Maybe I misunderstood your config but if I read it correct you can't do what you want.

Lee

Back to Top
Jeroen van der Linden View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Jeroen van der Linden Quote  Post ReplyReply Direct Link To This Post Posted: 01 May 2003 at 10:46am

Even easier is just installing spamfilter on another port eg 1025, and reconfiguring your firewall/router to redirect incoming SMTP to port 1025 on the spamfilter box. Tell spamfilter to send its outgoing mail to port 25 and you're settled! Minimal fuss, and no need to reconfigure the outgoing mail for your network.

Jeroen.

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.094 seconds.