Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - Error with Spam-Quarantine to a MySQL Server onto Linux
  FAQ FAQ  Forum Search   Register Register  Login Login

Error with Spam-Quarantine to a MySQL Server onto Linux

 Post Reply Post Reply
Author
Bruno View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Bruno Quote  Post ReplyReply Direct Link To This Post Topic: Error with Spam-Quarantine to a MySQL Server onto Linux
    Posted: 02 July 2003 at 12:04pm

Hi,

I'll get following error-message in the log-window of spamfilter :

07.02.03 17:48:10:198 -- (289) Exception occurred during RECEIVEMESSAGE: [MySQL][ODBC 3.51 Driver][mysqld-4.0.13]You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near '.`tblMsgs` (`Msg`) VALUES ('Received: from 192.168.1.5 by 192.1

does anybody know, how to change the syntax ??? or is there a fix ?

cu

bruno!

Back to Top
Bruno View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Bruno Quote  Post ReplyReply Direct Link To This Post Posted: 02 July 2003 at 12:07pm

...

here the output on step 2 while configuring the spam-db :

 

Adding default Reject Codes...
Error working with tblRejectCodes - [MySQL][ODBC 3.51 Driver][mysqld-4.0.13]You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near '.`tblRejectCodes` (`RejectID`,`RejectDesc`) VALUES (1,'Domain i
Error working with tblServers - [MySQL][ODBC 3.51 Driver][mysqld-4.0.13]You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near '.`tblServers` (`ServerName`) VALUES ('analytek_pdc')' at line 1

 

thanks to all !

bruno

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 02 July 2003 at 3:21pm

For both this posting and the other posted just after this, have you tried running the "MySql.sql" setup script in the spamfilter/database directly against the database from within MySQL or MySqlCC ? What errors, if any, does it produce?

Roberto Franceschetti
LogSat Software

Back to Top
Bruno View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Bruno Quote  Post ReplyReply Direct Link To This Post Posted: 03 July 2003 at 12:42am

hi,

please see the post you regarding to ... it's the same error.

thank's

bruno

Back to Top
Bruno View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Bruno Quote  Post ReplyReply Direct Link To This Post Posted: 03 July 2003 at 12:50am

Hi, here some additional output after creating a new DB with the MySQL.sql directly. I've made step1 ( ok ) , step2 gives following output :

================
please wait...
Found tblQuarantine
Found tblMsgs
Found tblRejectCodes
Found tblLogins
Found tblServers
Adding default Reject Codes...
Error working with tblRejectCodes - [MySQL][ODBC 3.51 Driver][mysqld-4.0.13]You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near '.`tblRejectCodes` (`RejectID`,`RejectDesc`) VALUES (1,'Domain i
Error working with tblServers - [MySQL][ODBC 3.51 Driver][mysqld-4.0.13]You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near '.`tblServers` (`ServerName`) VALUES ('analytek_pdc')' at line 1
Done.

Info:

MySQL Server Version 4.0.13

Linux Version : SuSE Linux 7.2 - Kernel 2.4.4-4GB

MyODBC Driver 3.51

System running with Spamfilter : Windows NT 4 SP 6a

Access-grants : ALL PRIVILEGES ( connect as root )

cu

tuxx

Back to Top
Bruno View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Bruno Quote  Post ReplyReply Direct Link To This Post Posted: 03 July 2003 at 3:19am

I got it :

22 Query INSERT INTO `spamfilter`..`tblMsgs` (`Msg`) VALUES ('Received: from

it's very unusual to select a table with a dubble-dot !?! isn't it ??? how do I change that ???

cu

bruno

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 03 July 2003 at 9:46am

Can you try setting the following two MySQL ODBC properties as in the screenshot below (http://www.logsat.com/SpamFilter/images/MySQLODBC.gif) and see if that makes a difference? We were not able to duplicate your error by using your version of MySQL and of the ODBC driver. The only difference is that our MySQL runs on Windows, not Linux. SHould not make a difference, buyt maybe some defaults are different.

Roberto Franceschetti
LogSat Software

WARNING: Image embedded by poster.

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 03 July 2003 at 9:56am

The trace you are seing is how Microsoft's ADO (OLE/DB) interpets the commands SpamFilter sends and translates them into platform-specific SQL statements. Unfortunately we have no control over them.

This issue may be fixed if you apply the two MySQL ODBC settings in the other posting. If not, can you please let us what version of MDAC (Microsoft Data Components) you have on the server, and what connection string you are using in SpamFilter to connect to MySQL? If you are not using the sample UDL file we provided, can you try doing so?

Roberto Franceschetti
LogSat Software

Back to Top
Bruno View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Bruno Quote  Post ReplyReply Direct Link To This Post Posted: 04 July 2003 at 7:48am

Hi,

I am using the sample file, and changed the neccessary values. I've tried the modifications on the mysql-odbc driver but isn't working yet :-( ...

cu

bruno

Back to Top
Bruno View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Bruno Quote  Post ReplyReply Direct Link To This Post Posted: 04 July 2003 at 7:52am

Hi,

how do I find out which MDAC version I'm running ?

cu ::bruno::

Back to Top
Bruno View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Bruno Quote  Post ReplyReply Direct Link To This Post Posted: 04 July 2003 at 8:25am

Hi,

I got it ! It's possibly a bug at the MySQL ODBC Driver for Windows ... have installed Version 2.5 directly for WinNT/2k/XP and is working now correctly ...

cu

bruno

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.078 seconds.