Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - Spontaneous restarting
  FAQ FAQ  Forum Search   Register Register  Login Login

Spontaneous restarting

 Post Reply Post Reply
Author
fabravo View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote fabravo Quote  Post ReplyReply Direct Link To This Post Topic: Spontaneous restarting
    Posted: 20 June 2003 at 10:06am
We have been running SpamFilterISP for some time (1.1.2.124, now). It is on a Win2K machine. Every once and a while, the machine that it is running on will just spontaneously restart.

At first I thought it was the machine, but when I looked closer, I saw that when I launched SpamFilterISP (or if I had it running as a Service and it started) it would cause the machine to restart. I finally figured out that if I kill the file(s) in the queue directory, things would be restored to normal.

I could not find anything wrong with any of the files I deleted until today when I read the post by Tony Bearman about the Corrupted Attachments. I don?t know if this is anything or not, but when it did it this morning (just a few minutes ago), I checked the message and it contained ?0A?s in it. Once I changed the ?0A? to something else (it was SPAM, so it didn?t matter), the message went through.

This sounds weird and I don?t even know if they are connected or not, but I can't seem to find any other reason for it...

Has anyone else seen spontaneous restarts on their systems?

\frank
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 21 June 2003 at 12:41am

Frank,

We were able to reproduce Tony's problem and are testing a fix right now for it. This weekend we will be releasing the non-beta, final retail release of the new v1.2 that will include this fix.

The attachment issue above is very specific, and it involves the erranous replacements of certain bytes in the attachment. We doubt that this would cause a reboot, nevertheless nothing can be excluded.

Please let us know if you plan on upgrading your 1.1.2.124 build to v1.2 (free upgrade). If not, we'll try to prepare a patch for the previous version you are using.

Roberto Franceschetti
LogSat Software

Back to Top
fabravo View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote fabravo Quote  Post ReplyReply Direct Link To This Post Posted: 22 June 2003 at 10:00am
Yes, I am planning on making the upgrade when it is available.

\frank
Back to Top
fabravo View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote fabravo Quote  Post ReplyReply Direct Link To This Post Posted: 30 June 2003 at 12:56pm
I did a little more research into what was going on with this and this is what I found....

I installed the same version on another machine and when I went to process the messages that caused the spontaneous restarting, I saw two types of messages before they restarted:

- Server error - max line length exceeded - Email from - - no recipients found, deleteing from queue

I am working on getting the new version working, so it may not matter, but I wanted to pass the info along.

\frank
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 30 June 2003 at 8:40pm

Frank,

If you see the same problem, please email us the

Ind-NNN.tmp

and

Ind-NNN.tmp.rcpt

files in the SpamFilter/queue directory so we can see what the issue is.

Roberto Franceschetti
LogSat Software

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.063 seconds.