Print Page | Close Window

2012R2 and access db problem

Printed From: LogSat Software
Category: Spam Filter ISP
Forum Name: Spam Filter ISP Support
Forum Description: General support for Spam Filter ISP
URL: http://www.logsat.com/spamfilter/forums/forum_posts.asp?TID=7152
Printed Date: 12 December 2017 at 1:39am


Topic: 2012R2 and access db problem
Posted By: mmmctune
Subject: 2012R2 and access db problem
Date Posted: 09 September 2017 at 11:19am
Moving our registered spamfilter install to a 2012R2 server and can't get spamfilter to connect to the access db.  Used the standard install and in step 1 just get 'can't connect to db'.  Did some research, downloaded and installed Access database Engine 2016 ( https://www.microsoft.com/en-us/download/details.aspx?id=54920" rel="nofollow - https://www.microsoft.com/en-us/download/details.aspx?id=54920 ), then changed the provider in the udl file to “Microsoft.ACE.OLEDB.12.0”.  Now when attempting step 1 I get an error 'The program can't start because api-ms-win-crt-stdio-l1-1-0.dll is missing from your computer'.
 
Help please, thanks.



Replies:
Posted By: LogSat
Date Posted: 09 September 2017 at 5:31pm
Support for MS Access has always been present in SpamFilter, but it was intended for testing purposes and/or installations with a very small email traffic. We always recommend to use either MS SQL Server or MySQL as backend databases as they are true server products that allow SpamFilter to process emails without issues.

Microsoft does not provide 64bit drivers for the Jet engine anymore, so running SpamFilter in 64bit mode makes it harder to use Access as a database. There are a couple of options to proceed in your case.

1. Install and use the 32bit version of SpamFilter instead of the 64bit. The 32bit version will use the 32bit Jet drivers, which are still available.
2. Install the Microsoft Access Database Engine 2010 Redistributable (I think the 2016 version you mention in the post should work as well). When doing that, you'll have access to the ACE provider which can be used to replace the JET provider. Once installed that, you can edit the "SpamFilterAccess.udl" file and replace:

Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Program Files\SpamFilter\Database\SpamFilter.mdb;Persist Security Info=False

with
Provider=Microsoft.ACE.OLEDB.12.0;Data Source=C:\Program Files\SpamFilter\Database\SpamFilter.mdb;Persist Security Info=False

And proceed straight to "Step 3" in the wizard which will allow you to save the connection string. 

Remember to change the number of days for which emails are stored in the quarantine from "0" to something else >0 to activate the database.



-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: mmmctune
Date Posted: 10 September 2017 at 12:42pm
32bit Spamfilter and 32bit Microsoft Access Database Engine 2010 Redistributable solved that, thank you!
 
How can I telnet to it to test?  I keep getting the below 500 error.
 
telnet <IP> 25
220 *******************************
EHLO domain.com
500 2.0.0 'XXXX XXXXXXXXXXXX' : command not understood
HELO domain.com
500 2.0.0 'XXXX XXXXXXXXXXXX' : command not understood


Posted By: LogSat
Date Posted: 10 September 2017 at 12:54pm
If you're seeing the ***************** when attempting to connect to port 25, it's very likely that you are not connecting to SpamFilter, but rather to another firewall/appliance that is sitting in front of SpamFilter that is intercepting the traffic on port 25 and securing it. An example is a Cisco ASA firewall with MailGuard enabled. MailGuard will not allow telnet connections to be used to send emails when typing command manually via a keyboard (the ASA will allow regular, non-human-generated connections thru though).

-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: mmmctune
Date Posted: 10 September 2017 at 7:33pm
Was working through an ASA vpn and thinking the asa wasn't going to assume the connection as it would from the Internet.  Sent test via telnet from a machine inside and it worked.
 
Thanks for your assistance.


Posted By: yapadu
Date Posted: 01 October 2017 at 11:15pm
You should really not use the mailguard (I think it is called that) feature on the firewall.

I know it sounds crazy, but both Cisco and Microsoft have released documentation stating that using the mailguard feature in front of your SMTP service can cause problems with legitimate email.

It works most of the time, but you will end up with that one domain that can't email you...  really a pain in the butt.

Cisco published an article in 2008 (which the URL is changed so I don't have the link) which stated:

If you have an ESMTP server behind the PIX, such as a Microsoft Exchange Server, you might need to turn off the Mailguard feature to allow mail to flow properly.

Microsoft has also released documentation stating you will have issues if you use mailguard.  That article is still online:  https://support.microsoft.com/en-us/help/320027/cannot-send-or-receive-e-mail-messages-behind-a-cisco-pix-or-cisco-asa" rel="nofollow - Cannot send or receive e-mail messages behind a Cisco PIX or Cisco ASA firewall

Bottom line, do not use mailguard Confused


-------------
--------------------------------------------------------------
I am a user of SF, not an employee. Use any advice offered at your own risk.



Print Page | Close Window