Print Page | Close Window

Strange Queuing Issue

Printed From: LogSat Software
Category: Spam Filter ISP
Forum Name: Spam Filter ISP Support
Forum Description: General support for Spam Filter ISP
URL: http://www.logsat.com/spamfilter/forums/forum_posts.asp?TID=7091
Printed Date: 23 November 2017 at 7:18pm


Topic: Strange Queuing Issue
Posted By: ebzed
Subject: Strange Queuing Issue
Date Posted: 25 June 2014 at 11:44pm
Hi There...
We have a report from a user where he have sent 2 test e-mails from hotmail.com
and only one did arrived to his mail box
Spam Filter:
06/25/14 12:55:58:677 -- (167558784) Received MAIL FROM: xxx@xxx.com
06/25/14 12:55:58:711 -- (167558784) Received RCPT TO: yyy@yyy.com
06/25/14 12:53:58:187 -- (39589808) Read timed out. - forwarding to:111.111.111.11:11 - message queued - xxx@xxx.com to: yyy@yyy.com -- 
06/25/14 12:57:02:683 -- (39591824) EMail from xxx@xxx.com to yyy@yyy.com --  was forwarded to 111.111.111.11:11

On the mail server we do get it:
06/25/2014 07:56:56 PM  Router: Message 005D1985 transferred to uuuu/uuu/uuu for yyy@yyy.com from xxx@xxx.com  Size: 2K via Notes

So far so good...
a few minutes earlier:
06/25/14 12:52:47:597 -- (40316176) Received MAIL FROM: xxx@xxx.com
06/25/14 12:52:47:629 -- (40316176) Received RCPT TO: yyy@yyy.com
06/25/14 12:52:48:019 -- (40316176) EMail from xxx@xxx.com to yyy@yyy.com was queued (Indy37A9202C-930D-40B0-84AA-BA47E0AC76D0.~tmp). Size: 0 KB, 958 bytes
06/25/14 12:52:48:019 -- (39589808) Sending email from xxx@xxx.com to yyy@yyy.com -- 
06/25/14 12:53:58:187 -- (39589808) Read timed out. - forwarding to:111.111111.111:11 - message queued - xxx@xxx.com to: yyy@yyy.com 

and the message is since then in the queue, trying to restart spamfilter didnt help processing it out of the queue, increasing the time out to 120 (from 60 via ini) didnt helped...


Any idea how to force it ?
(i also noticed old e-mails in the queue, how to force spamfilter to process them?)

thanks,
Eran. 




Replies:
Posted By: LogSat
Date Posted: 26 June 2014 at 7:48am
Eran,

In the queue folder there should be two files with the base name of "Indy37A9202C-930D-40B0-84AA-BA47E0AC76D0" and different extensions. Can you please zip and email them to us at support at logsat.com so we can see what is happening?

In the email could you please also let us know what IP and port they are being forwarded to (the "111.111111.111:11" in your log sample above). We may need to try forwarding the email to that destination SMTP server manually to troubleshoot this (assuming the server is accessible for the internet).

Thanks,

Roberto


-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: LogSat
Date Posted: 26 June 2014 at 9:34pm
Eran,

For an unknown reason at this moment, when SpamFilter was unable to deliver the emails it queued them and left the .~tmp extension in the filename. That extension should have been changed to .tmp (without the tilde). SpamFilter will re-deliver the files in the \queue folder, but only if the extension is .tmp (without the tilde). If you rename those files changing the extension from .~tmp to .tmp SpamFilter should be delivered the next time the queue is processed.


-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: ebzed
Date Posted: 04 July 2014 at 4:15pm
Thank You,
Renaming the files did solved the problem...




Print Page | Close Window