Print Page | Close Window

SpamFilter 4.5 beta

Printed From: LogSat Software
Category: Spam Filter ISP
Forum Name: Spam Filter ISP Support
Forum Description: General support for Spam Filter ISP
URL: http://www.logsat.com/spamfilter/forums/forum_posts.asp?TID=7005
Printed Date: 21 November 2017 at 12:34pm


Topic: SpamFilter 4.5 beta
Posted By: Wayne
Subject: SpamFilter 4.5 beta
Date Posted: 24 January 2012 at 5:28am
Roberto

We don't have permission to reply on your announcement so I start a new thread here.

We're testing it now in production environment, no risk no fun Wink
As far as I can see it works very well. The GUI looks nice and a bit more modern, sure, but do you have a changelog or any other feature implemented?

Regards


-------------
SF4.5.0.1-beta



Replies:
Posted By: roaridse
Date Posted: 24 January 2012 at 7:17am
Hi,

Do anyone else running 4.5.0.1-beta experienced a problem with national characters in mails being rewritten? 

Seems for me that some characters is rewritten into rubbish - got a mail forwarded from a customer where swedish characters is messed up. 

Any ideas?

PS. I don't have the original mail as I just got it forwarded.. 


Posted By: Wayne
Date Posted: 24 January 2012 at 8:28am
roaridse

I couldn't find a swedish email right now, but have also some special characters in here with other countries and I checked now some danish, russian and arabic emails and no problems were recorded in this regard.

-------------
SF4.5.0.1-beta


Posted By: roaridse
Date Posted: 24 January 2012 at 8:40am
Seems to happen with Norwegian characters too - but not always. Might be happening on some encodings or mailformats? 


Posted By: Wayne
Date Posted: 24 January 2012 at 9:01am
So, searched now some Norwegian and Finnish emails, with HTML and just plain text, ESMTP/TLS/RC4-MD5; Content-Class: urn:content-classes:message MIME-Version: 1.0, Content-Type: multipart/mixed;  but they are all just normal, all characters look like they should, I guess LOL

Will let you know when we have also some strange behaviours.


-------------
SF4.5.0.1-beta


Posted By: LogSat
Date Posted: 24 January 2012 at 3:52pm
Originally posted by Wayne Wayne wrote:

Roberto
 As far as I can see it works very well. The GUI looks nice and a bit more modern, sure, but do you have a changelog or any other feature implemented?
 Regards
Hi Wayne,

The change log is pretty simple actually, as no new filtering features or settings have been added. The GUI change is only a "skin" that we applied to try modernizing a bit the looks of the interface while we work on web-enabling it. The major change deals with a major upgrade of the internal SMTP engine used by SpamFilter, but that is all internal "stuff" that is not exposed to the users. Other than immediate, built-in support for TLS in addition to the existing SSL, not much is visible. The new engine supports IPv6, while the old one didn't, so we'll be able to implement it very quickly when the times comes in a few months (we're now focusing on finishing up the new remote GUI).


-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: roaridse
Date Posted: 25 January 2012 at 8:21am
Hi,

found a mail where the norwegian characters ÆØÅ is rewritten into "?" (for some mails it is rewritten into chinese-alike characters, or just deleted)

According to mailheaders charset on the mail is "us-ascii" - which seems to be incorrect for the actual content:

Received: from spam01.hesby.net (81.29.32.160) by ex03.hesby.net
 (81.29.32.161) with Microsoft SMTP Server id 8.1.436.0; Wed, 25 Jan 2012
 01:30:27 +0100
Received: from 146.xxx.xxx.xxx by spam01.hesby.net (LogSat Software SMTP Server);
 Wed, 25 Jan 2012 01:30:23 +0100
Received: from xxx.xxx.xxx.146.static.xxxxx.com[146.xxx.xxx.xxx]
 (helo=alp-metrow1.appdmz.xxxxx.com) by spam01.hesby.net[81.29.32.160] with
 esmtp (LogSat Software SMTP Server)
Received: from m2s1 (m2s1 [192.168.241.70]) by alp-metrow1.appdmz.xxxxx.com
 (8.13.1/8.13.1) with ESMTP id q0P0UIkZ019905 for <xxx@xxx.NET>; Wed,
 25 Jan 2012 01:30:18 +0100
Date: Wed, 25 Jan 2012 01:30:18 +0100
From: "Aksess@xxxxx.com" <Aksess@xxxxx.com>
To: <xxx@xxx.com>
Subject: XXXXXXXXXXXXXXXXXXXXX
MIME-Version: 1.0
Content-Description: XXXXXXXXXXXXXXXXXXXXXX
X-SF-RX-Return-Path: <Aksess@xxxxx.com>
X-SF-HELO-Domain: alp-metrow1.appdmz.xxxxx.com
X-SF-Originating-IP: 146.xxx.xxx.xxx
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline
Message-ID: <02820706-5310-4455-90a6-d94501b39297@EX03.hesby.net>
Return-Path: Aksess@xxxxx.com
X-MS-Exchange-Organization-Antispam-Report:
 ContentFilterConfigBypassedRecipient
X-MS-Exchange-Organization-SCL: -1



Posted By: LogSat
Date Posted: 26 January 2012 at 10:46pm
roaridse,

Do you have access to the original, unmodified source of the email, so we can try to reproduce it? If so, could you please forward it to as at support @ logsat.com in a text/zip attachment so we can take a look?

Thanks!



-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: LogSat
Date Posted: 01 February 2012 at 8:48pm
To update this thread, we've not been able to reproduce the problem even with the original emails provided by roaridse. Characters are displaying normally in their original language when received by the new 4.5 beta.

-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: yapadu
Date Posted: 11 February 2012 at 7:28am
I have not been brave enough to actually try the new beta, but I did download it and run it.  It appears there is no database changes, as after running it the most recent version in the database folder is from 4.2.4.834 so is it safe to say there are no database changes?

We communicate to spamfilter directly through the database so need to confirm if any changes are being made before we try it out.


-------------
--------------------------------------------------------------
I am a user of SF, not an employee. Use any advice offered at your own risk.


Posted By: Wayne
Date Posted: 11 February 2012 at 8:04am
Hmmm, can't confirm this, the only negative change at the database we recognized is we aren't able anymore to sort the coloumns, but it's still working. We use anyway our own Access DB and linked all the tables from the SF DB coz we want to have some special queries.

-------------
SF4.5.0.1-beta


Posted By: LogSat
Date Posted: 11 February 2012 at 12:42pm
In the current beta there are no database changes. In the new beta that will be released this weekend there will be however a minor change (the addition of one more field in a table) to handle a feature request for supporting the optional tagging of whitelisted emails in the subject line.

-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: LogSat
Date Posted: 12 February 2012 at 10:46pm
FYI updated beta 4.5.0.3 has been released.

-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: sgp-se
Date Posted: 14 February 2012 at 5:34am
Hi. We have the same Problem with Character encoding. IN vers 4.2.4.851 everthing works fine. In the beta 4.5 some E-Mails look funny cause Spamfilter kills charakters like Ö,Ä,Ü.




Posted By: sgp-se
Date Posted: 14 February 2012 at 5:36am
Ohh Forum kills my Charakters to ;) the Chars are called "Umlaut" in German.


Posted By: LogSat
Date Posted: 14 February 2012 at 8:13pm
We've still been unable to reproduce any issues with character encodings. Could you please try sending us one or more email samples at support @ logsat.com so we can try to see if we see the same issue?

-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: LogSat
Date Posted: 28 February 2012 at 6:53pm
We have finally been able to resolve the issues with accented characters (and other non US-ASCII symbols as well). SpamFilter 4.5.0.9-beta has been made available with the patch.

-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP



Print Page | Close Window