Print Page | Close Window

557 error on 4.2.4.844 release with inline images

Printed From: LogSat Software
Category: Spam Filter ISP
Forum Name: Spam Filter ISP Support
Forum Description: General support for Spam Filter ISP
URL: http://www.logsat.com/spamfilter/forums/forum_posts.asp?TID=6998
Printed Date: 17 December 2017 at 8:34am


Topic: 557 error on 4.2.4.844 release with inline images
Posted By: peet
Subject: 557 error on 4.2.4.844 release with inline images
Date Posted: 21 December 2011 at 10:11pm
Hi,
Looks like my spamfilter fives the error:
 - 557 The server encountered an error while processing this message. Please retry later.

This happens when a 5.5MB e-mail comes through with 10 embedded jpg images in the message.

What is that error, and what could be causing it?
How could we troubleshoot it and resolve it?

This seems to happen recently occasionally.
Thanks,
-Peet



Replies:
Posted By: peet
Date Posted: 05 January 2012 at 12:47pm
Does anyone experience this error? Any ideas what could be causing it?


Posted By: LogSat
Date Posted: 05 January 2012 at 5:41pm
Sorry peet, we completely missed this post back in December, and noticed it just now. Are you able to reproduce the error at anytime? If so, could you try sending that email to us as well at support@logsat.com?

-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: peet
Date Posted: 05 January 2012 at 7:30pm
yupp.. lookslike I can still replicate it.
I'm sending the e-mail to you from my yahoo email address, with subject merch orders N 17-26


Posted By: LogSat
Date Posted: 05 January 2012 at 8:08pm
We received it without problems, and tried feeding the same exact email to your older version of SpamFilter v4.2.4.844. That older version however is able to process it fine.

If you can duplicate it at will on your end, could you please try adding us as a CC or BCC in the same email that you can send to your server causing the error to come up? I just want to be sure that nothing is altered in the original source of the "problem" email, since I see that the one we received was forwarded multiple times between different email addresses.


-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: peet
Date Posted: 05 January 2012 at 8:17pm
ok, I've resent it to my server, and CC-d to you. I got the error message back again and forwarded it to you as well.


Posted By: LogSat
Date Posted: 07 January 2012 at 10:14pm
Peter,

After failing to reproduce this issue when using your settings, I looked at your SpamFilter logfile to see if there clues there as to what may have been happening. Unfortunately we were so focused on reproducing the problem that we resorted to the logfile too late, since that log is showing exactly what the issue is. In the logs we see a very large number of "Out of memory" errors. They are mostly occurring when SpamFilter tries to add spam emails to the database, but there were 11 instances when they occurred while receiving an email, and one of them is for your large email below:

01/05/12 16:28:19:549 -- (3200) Detected TCP Connection: 98.139.52.147
01/05/12 16:28:19:549 -- (3200) Connection from: 98.139.52.147  -  Originating country : United States
01/05/12 16:28:19:721 -- (3200) Received MAIL FROM: < mailto: - p.......@yahoo.com >
01/05/12 16:28:19:799 -- (3200) Received RCPT TO:  mailto: - peter@p......com
01/05/12 16:28:19:799 -- (3200) Bypassed all rules for:  mailto: - peter@p........com  from  mailto: - p.....@yahoo.com  ( Whitelisted EMail Address From)
01/05/12 16:28:36:441 -- (3200) Exception occurred during RECEIVEMESSAGE: ( 1 2 2b 3 111) Out of memory -- 

Can you please check the server to ensure SpamFilter has enough memory to operate? Judging from your logs, you only receive 10,000/15,000 emails per day, and for that small amount SpamFilter only needs about 500MB of RAM, but if you're sharing that server with other applications, you should ensure SpamFilter has enough.

In case SpamFilter is using too much memory, can you try clearing out the corpus for the Bayesian filter by:
  • stop SpamFilter
  • delete (or rename) the SpamFilter/corpus directory
  • then restart SpamFilter?
Please let me know if you still are unable to resolve the memory problems after looking into this, so we can try to help further.




-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP



Print Page | Close Window