Print Page | Close Window

Windows 2008 R2 x64 and SQL x64 Support

Printed From: LogSat Software
Category: Spam Filter ISP
Forum Name: Spam Filter ISP Support
Forum Description: General support for Spam Filter ISP
URL: http://www.logsat.com/spamfilter/forums/forum_posts.asp?TID=6886
Printed Date: 22 October 2017 at 1:27pm


Topic: Windows 2008 R2 x64 and SQL x64 Support
Posted By: jym5960
Subject: Windows 2008 R2 x64 and SQL x64 Support
Date Posted: 26 October 2010 at 5:58pm
Hi,
 
last year, i tried to setup SF with SQL2005 x64 without success, because paths were not correct. After having tried to change paths in SQL scripts, I gave up and setup an x86 SQL engine.
 
Nevertheless, my last Windows 2003 x86 servers must disappear next year. Most of them (VM) have already been replaced with Windows 2008 R2 x64.
 
 
Will you provide nearly x64 SQL scripts for correct setup with MS SQL 2008 R2 x64?
 
Thanks by advance.



Replies:
Posted By: LogSat
Date Posted: 26 October 2010 at 9:47pm
jym5960,

Just yesterday we discovered (one of our users actually did) an issue with SpamFilter and SQL Server on x64 servers when using the SQL Native Client to connect to SQL Server. 

A patch is already available for download (SpamFilter build 4.2.4.838).

As a side-note, while the patch is required with SpamFilter Enterprise, there is a simple workaround when using SpamFilter ISP "standard". With the standard version, you can go to the "Settings - Database Setup" tab, then go to the "Step 1" tab in the wizard tabs, and manually select the "MS SQL Server" radio button, without clicking on the "Check DB Connection String", and then going thru the other two steps in the setup.


-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: yapadu
Date Posted: 29 October 2010 at 6:35pm
I am having troubles on a new x64 based system as well, using mysql.  Spamfilter can not see the datasource.  Have not found a solution (am running 4.2.4.838).
 
Have been trying to use a mysql oledb provider which I have not been able to get working either.  Should spamfilter be able to work with a mysql oledb provider?


-------------
--------------------------------------------------------------
I am a user of SF, not an employee. Use any advice offered at your own risk.


Posted By: LogSat
Date Posted: 30 October 2010 at 10:31pm
yapadu,

Can you please post/email us your connection string (or the contents of the UDL file if you are using them - you can edit such files with notepad to see its content)?


-------------
Roberto Franceschetti

http://www.logsat.com" rel="nofollow - LogSat Software

http://www.logsat.com/sfi-spam-filter.asp" rel="nofollow - Spam Filter ISP


Posted By: yapadu
Date Posted: 31 October 2010 at 1:56pm
I finally figured out my issue.  My first x64 bit server, I installed the ODBC driver but SF could not see it.

Turns out because SF is 32 bit it can not see the 64 bit ODBC setup.

You need to run the 32bit ODBC administrator and define the data source there, then SF is able to see and use it.


-------------
--------------------------------------------------------------
I am a user of SF, not an employee. Use any advice offered at your own risk.



Print Page | Close Window