Print Page | Close Window

table ’tblMsgs’ is full - solved

Printed From: LogSat Software
Category: Spam Filter ISP
Forum Name: Spam Filter ISP Support
Forum Description: General support for Spam Filter ISP
URL: http://www.logsat.com/spamfilter/forums/forum_posts.asp?TID=5817
Printed Date: 24 October 2017 at 3:52am


Topic: table ’tblMsgs’ is full - solved
Posted By: aaron
Subject: table ’tblMsgs’ is full - solved
Date Posted: 06 October 2006 at 6:12pm

I have had SF v3.1.3.597 running on Windows 2000 and a MySQL v4.0.23-nt database running on a different machine (also win2k) for some time without any problems.  Both machines utilize NTFS.

Since last night I have been getting the following error when trying to quarantine messages:
(1924) Error occurred during TAddToQuarantineThread when accessing the quarantine database: [MySQL][ODBC 3.51 Driver][mysqld-4.0.23-nt]The table 'tblMsgs' is full ( 83 84 85 86 86a 86b 86c 87 88 89 90 91)

There is available disk space on the machine hosting the MySQL server and I have tried running REPAIR statements that completed successfully, but have not fixed my problem.  I also did an ALTER TABLE statement which completed successfully, yet did not help either. 

Any ideas on how to solve my problem?




Replies:
Posted By: aaron
Date Posted: 06 October 2006 at 7:04pm
Upon further examination, my tblMsgs had rows with august dates, even though my quarantine should be deleting them after 18 days...  I removed some of those and now it is quarantinely properly again... I wonder what could be causing this table to not have entries automatically removed?


Posted By: aaron
Date Posted: 07 October 2006 at 9:27am
Hmmm on the settings tab, under quarantine db, the interval in minutes for when expired emails are deleted from the database was set at 0.  I know it wasn't always set to that.  Well anyway, that seems to have fixed it for now.



Print Page | Close Window