Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - spamfilter has stalled twice in last 2 days
  FAQ FAQ  Forum Search   Register Register  Login Login

spamfilter has stalled twice in last 2 days

 Post Reply Post Reply
Author
Terry View Drop Down
Senior Member
Senior Member


Joined: 06 February 2005
Status: Offline
Points: 155
Post Options Post Options   Thanks (0) Thanks(0)   Quote Terry Quote  Post ReplyReply Direct Link To This Post Topic: spamfilter has stalled twice in last 2 days
    Posted: 29 August 2014 at 11:59am
I am on v4.6.0.113.  Twice during the last 2 days spamfilter has stalled and stops processing transactions.  I can't see anything meaningful in the logs just a break in the processing until we either restart the service of reboot the machine...nothing shows in the event logs either...
here is an excerpt from the logs:
 
08/29/14 07:01:11:423 -- (256260240) Detected TCP Connection: 181.31.207.65
08/29/14 07:01:11:423 -- (105656384) Resolving 50.194.112.129 - 50-194-112-129-static.hfc.comcastbusiness.net
08/29/14 07:01:11:423 -- (256260240) Connection from: 181.31.207.65  -  Originating country : Argentina
08/29/14 07:01:11:423 -- (256260240) GreyList limbo - Added 181.31.207.65
08/29/14 07:01:11:423 -- (256260240) IP is in not in GreyList Allowed. Disconnecting: 181.31.207.65
08/29/14 07:01:11:423 -- (256260240) No Data Received
08/29/14 07:01:11:423 -- (256260240) Disconnect
08/29/14 08:07:31:018 -- SpamFilter ISP v4.6.0.113 Listening on all IPs port 25 - SSL port 465 (64bit service mode)
08/29/14 08:07:31:720 -- (93876864) Found new domain in tbl_LocalDomains: SFI. Creating new FilterObject
08/29/14 08:07:31:861 -- (93876864) Detected differences in file timestamps - forcing DB export
08/29/14 08:07:31:923 -- (93876864) Reloading filter.ini: domains\SFI\Filters.ini
08/29/14 08:07:31:923 -- (93876864) Reloading file for tbl_LocalDomains: domains\SFI\AllowedDomains.txt (93 bytes)
08/29/14 08:07:32:032 -- (93876864) Reloading file for tblWL_EmailsFrom: domains\SFI\excludefrom.txt (1090 bytes)
 
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 29 August 2014 at 4:54pm
Terry,

We'd need to see the entire SpamFilter activity logfile to get a better idea of what is happening. Can you please zip us the following so we can take a look:

• SpamFilter's activity logfile for today

• The \SpamFilter\Domains directory structure (if the files containing any of your blacklists/whitelists are outside that directory tree, please include those as well.


If the zipped file is over 8MB in size, I'll send you via PM the URL where you can upload the file.


Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 29 August 2014 at 11:19pm
Terry,

We received the files, thank you. While we're still going thru the logs, I noticed that SpamFilter was shut down gracefully at exactly 6:00AM, and restarted a few seconds after that. Then just like you said, an hour and a minute afterwards at 7:01 all activity simply stops.
Could you please confirm that the shutdown at 6AM was either performed by a scheduled task or performed manually by an admin, so we can eliminate it from being related to the issue an hour later?

Also, could you please also upload us the logfile for the previous time this happened, in the hope we see some correlating events?

Thanks,

Roberto
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
Terry View Drop Down
Senior Member
Senior Member


Joined: 06 February 2005
Status: Offline
Points: 155
Post Options Post Options   Thanks (0) Thanks(0)   Quote Terry Quote  Post ReplyReply Direct Link To This Post Posted: 30 August 2014 at 9:36am
the shutdown is scheduled every day at 6am so this was expected.  Still trying to figure out how to upload the second log...the upload to the cloud doesn't seem to take yet...
Back to Top
Terry View Drop Down
Senior Member
Senior Member


Joined: 06 February 2005
Status: Offline
Points: 155
Post Options Post Options   Thanks (0) Thanks(0)   Quote Terry Quote  Post ReplyReply Direct Link To This Post Posted: 30 August 2014 at 9:43am
still unable to upload the second log...do you need to send me another upload link?
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 30 August 2014 at 7:24pm
Yes, I saw several incomplete uploads. As an upgrade of the OwnCloud website was due anyways, we proceeded with the upgrade just now. Could you please try again to see if that works? 

If not, unless you have a URL where I can download them from your website, I can setup an FTP site for you to upload.

I'm sorry for the trouble,

Roberto
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
Terry View Drop Down
Senior Member
Senior Member


Joined: 06 February 2005
Status: Offline
Points: 155
Post Options Post Options   Thanks (0) Thanks(0)   Quote Terry Quote  Post ReplyReply Direct Link To This Post Posted: 31 August 2014 at 10:19am
I have uploaded the logfile...you should see it stopped at 3pm and we did not catch the fact that it was not running till the next morning...
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 31 August 2014 at 8:35pm
Terry,

We're still looking to see if there are commonalities between the two logs at the time spamFilter stopped processing traffic.

In the meantime, we see that on both days at 6AM SpamFilter was stopped than then restarted a few seconds later:

08/27/14 06:00:03:102 -- Shutting down all threads. Please wait up to 15-20 seconds....
08/27/14 06:00:12:774 -- SpamFilter ISP v4.6.0.113 Listening on all IPs port 25 - SSL port 465 (64bit service mode)
...............
08/27/14 15:00:20:926   SpamFilter stopped with no reason


08/29/14 06:00:02:968 -- Shutting down all threads. Please wait up to 15-20 seconds....
08/29/14 06:00:09:894 -- SpamFilter ISP v4.6.0.113 Listening on all IPs port 25 - SSL port 465 (64bit service mode)
...............
08/29/14 07:01:11:423   SpamFilter stopped with no reason


Is there an automated process that caused this to happen? If so, does it only occur at 6AM?
When SpamFilter stopped processing traffic (times in bold above), when you logged onto the server did you still see SpamFilter's GUI on screen (or the SpamFilterSvc.exe process running), or did SpamFilter completely crash/shutdown?
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
Terry View Drop Down
Senior Member
Senior Member


Joined: 06 February 2005
Status: Offline
Points: 155
Post Options Post Options   Thanks (0) Thanks(0)   Quote Terry Quote  Post ReplyReply Direct Link To This Post Posted: 01 September 2014 at 9:48am
Yes we have an automated process that shuts down the spamfilter service at 6am and restarts it a few minutes later....and when it was stalled the service was still running however we could not get to the gui.  We could however at least once restart the service and get it running (I did not find it the second time I believe the person restarted the server )
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.059 seconds.