Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - rejected - no relay allowed or % found in FROM add
  FAQ FAQ  Forum Search   Register Register  Login Login

rejected - no relay allowed or % found in FROM add

 Post Reply Post Reply
Author
dcook View Drop Down
Senior Member
Senior Member
Avatar

Joined: 31 January 2005
Location: United States
Status: Offline
Points: 174
Post Options Post Options   Thanks (0) Thanks(0)   Quote dcook Quote  Post ReplyReply Direct Link To This Post Topic: rejected - no relay allowed or % found in FROM add
    Posted: 17 February 2010 at 4:08pm
When adding new domains in the Spamfilter settings  today (enterprise).  The service crashed and I had to restart it.  Then it started rejecting email with "rejected - no relay allowed or % found in FROM address" errors.  I have inserted a *.*.*.* entry under excluded domains and IP's white list to bypass the error.
 
How can I best resolve this?  Any ideas?Ouch
Dwight
www.vividmix.com
Back to Top
dcook View Drop Down
Senior Member
Senior Member
Avatar

Joined: 31 January 2005
Location: United States
Status: Offline
Points: 174
Post Options Post Options   Thanks (0) Thanks(0)   Quote dcook Quote  Post ReplyReply Direct Link To This Post Posted: 17 February 2010 at 6:06pm
I am rebuilding the database as I believe it is corrupted.  Documentation indicates (in forum) that the allowed domains is the reason for this error in the stand-alone version.  The GUI crashed when I was adding domains to the enterprise version - ans I believe that corrupted the domains allowed in enterprise.


Dwight
www.vividmix.com
Back to Top
dcook View Drop Down
Senior Member
Senior Member
Avatar

Joined: 31 January 2005
Location: United States
Status: Offline
Points: 174
Post Options Post Options   Thanks (0) Thanks(0)   Quote dcook Quote  Post ReplyReply Direct Link To This Post Posted: 18 February 2010 at 10:42am
I tried to initiate a new instance of the database but the domain section of the enterprise GUI was greyed out - not letting me add domains.  I am therefore running will only greylisting operational till someone offers me some help.
Dwight
www.vividmix.com
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 18 February 2010 at 3:59pm
Dwight, can you please zip and email us your SpamFilter activity logfile for today so we can see what is happening? Please also include your SpamFilter.ini file and your SpamFilter\Domains directory structure. 

If the zipped file is over 8MB in size, please try to upload the file to our ftp server (I also sent you an email with the ftp login credentials).
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
dcook View Drop Down
Senior Member
Senior Member
Avatar

Joined: 31 January 2005
Location: United States
Status: Offline
Points: 174
Post Options Post Options   Thanks (0) Thanks(0)   Quote dcook Quote  Post ReplyReply Direct Link To This Post Posted: 19 February 2010 at 9:16am
I sent you an email invite to a dropbox will all of the requested files.  Let me know if you did not get access or need something else.  Thank you.
Dwight
www.vividmix.com
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 19 February 2010 at 6:06pm
Dwight,

We just received the emails from dropbox about 90 minutes ago. From the logs unfortunately it does appear that your MySQL database was corrupted, even though it looks like you were able to restore most of it. There are still errors occurring however. I'd recommend having SpamFilter re-apply all the database patches that are needed. This may cause errors to be logged when the scripts are trying to add database fields that exist already, but these errors can be ignored.

To proceed, please:
1. Stop SpamFilter
2. Find and remove the line starting with DBPatchesApplied= in the SpamFilter.ini file
and then
3. Restart SpamFilter. 

When done, the line you removed should have been automatically re-added.
If things are still not working correctly, can you please zip us a new, updated logfile to debug?
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
dcook View Drop Down
Senior Member
Senior Member
Avatar

Joined: 31 January 2005
Location: United States
Status: Offline
Points: 174
Post Options Post Options   Thanks (0) Thanks(0)   Quote dcook Quote  Post ReplyReply Direct Link To This Post Posted: 20 February 2010 at 8:15am
Thank you Logsat for fixing our corrupted database. Now we are operational again. Spamfilter has been wonderful for years and continues to be so much beetter than filters in our mail servers.  As an ISP and company, it is a must.
 
Even with greylisting alone I got 500+ mails a day most of it spam a day personally - now most spam is gone and I get 1/5th the mail with little spam.
 
I tried two of your iphone apps today, registered sex tracker and family tracker today - great stuff guys.
 
DwightTongue
Dwight
www.vividmix.com
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.031 seconds.