Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - 50% CPU Usage, what is it doing?
  FAQ FAQ  Forum Search   Register Register  Login Login

50% CPU Usage, what is it doing?

 Post Reply Post Reply
Author
yapadu View Drop Down
Senior Member
Senior Member


Joined: 12 May 2005
Status: Offline
Points: 272
Post Options Post Options   Thanks (0) Thanks(0)   Quote yapadu Quote  Post ReplyReply Direct Link To This Post Topic: 50% CPU Usage, what is it doing?
    Posted: 04 November 2009 at 9:45pm
I tried monitoring with perfmon, but with 2008 version I can't figure out how to save the performance logging info.  Guess I will have to read up on it.

The system just went into 50% usage mode again, so it lasted about 5 days or so before the problem showed up.

I will try the perfmon again...

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 30 October 2009 at 12:07am
yapadu,

SpamFilter performs a few cleanup tasks on regular intervals. If you can log the CPU usage and let us know how often it presents itself, we can try to isolate the specific task being performed. Please also provide us your SpamFilter.ini file, as some of the timings involved in the tasks can be modified by entries in that file.
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
yapadu View Drop Down
Senior Member
Senior Member


Joined: 12 May 2005
Status: Offline
Points: 272
Post Options Post Options   Thanks (0) Thanks(0)   Quote yapadu Quote  Post ReplyReply Direct Link To This Post Posted: 29 October 2009 at 10:30pm
I've got one machine on Windows 2008 server, and from time to time it will start using 50% of the available CPU.  The machine is dual core, but it is actually using 50% of each, not 100% of just one.

It even uses up 50% if there are no connections to the server, no bayesian is in use on the server.

The quarantine database folder and message que are empty, so what could it be doing? 

Any clue as to what I could look for in the logs that might indicate what SF is doing with the 50% usage?

If I stop and start SF the problem clears, but will come back eventually.  The system runs OK, don't currently have a load issue so I have not bothered about it much.


Edited by yapadu - 29 October 2009 at 10:36pm
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.078 seconds.