Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - Spam Filter and Imail Coexistence
  FAQ FAQ  Forum Search   Register Register  Login Login

Spam Filter and Imail Coexistence

 Post Reply Post Reply
Author
answerman View Drop Down
Newbie
Newbie


Joined: 22 September 2006
Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote answerman Quote  Post ReplyReply Direct Link To This Post Topic: Spam Filter and Imail Coexistence
    Posted: 08 December 2006 at 6:25pm
Hey all...

In my third day of evaluating Spam Filter, and mostly lovin' it.  Had a glitch today, however, and was wondering if this had happened to anyone else.

My setup: running Spam Filter on IP xxx.xxx.xxx.2 (DNS A record "mail2") and Imail 8.15 on IP xxx.xxx.xxx 1 (DNS A record "mail").  Both are running on port 25.

My monitor told me this morning that "mail" was not responding.  No new mail was coming in, and users could not send mail.  In looking into it, it appeared that Imail's SMTP service was running just fine, but wasn't accepting any connections.  The Spam Filter logs showed that it was receiving mail, dealing with the bad stuff, and then attempting to forward the good stuff to Imail's SMTP but receiving a "not available" message, so it was queued for later delivery.

After a few hours of mucking around with it, I finally ran FPort and it told me that the only program running on port 25 was SpamFilterSvc.  Even though Imail told me that it was running on port 25, it apparently was not.

What I *think* solved it was to stop both services, start Imail SMTP, and then start SpamFilterSvc.  After I did that, both services showed up in FPort, and everything seemed to fix itself.

My guess is that Imail's SMTP service stopped for some reason (it happens occasionally) and when it attempted to restart it found that since Spam Filter was already running on port 25, it saw a conflict and did not bind to the port.

As I understand it, there should not be a problem running both SpamFilter and Imail on the same port as long as they are on different IP addresses.  Do I have that correct?  Is there an issue with the order in which the services start... i.e. does Imail need to be running before Spam Filter starts?  Or am I way off base here?

(Something else I thought of... do I need to "delete" the IP address used for Spam Filter from Imail?  It appears that I can do that)


Edited by answerman
Back to Top
jerbo128 View Drop Down
Senior Member
Senior Member
Avatar

Joined: 06 March 2006
Status: Offline
Points: 178
Post Options Post Options   Thanks (0) Thanks(0)   Quote jerbo128 Quote  Post ReplyReply Direct Link To This Post Posted: 08 December 2006 at 7:02pm

answerman,

We run the same setup, and after tweaking a bit, have found it to be very stable and reliable.  Both services start automatically without and issues.

 You may know this already...

In order to have imail bind to only one ip, you have to set the option in the imail manager.  We also had to change a few registry keys to point our primary and virtual hosts to the ip that we wanted.  We found the methods and corresponding keys on ipswitch's KB.  Once we stumbled through that, all was happy.

My only complaint with the setup is this:  You cannot limit imail to accept external smtp traffic from only from the spamfilter.  If you do, your customers will not be able to send mail out, even if authenticated to imail.  Because we can not restrict imail to receiving from only a single source, some spammers have figured out to send mail to the "mail.domain.com" and bypass the spamfilter.  We removed all "mail.domain.com" host records from our customers dns records, and directed each customer to an alternate mail server name.  This keeps spammers from quering dns for "mail.domain.com" and has helped with the filter bypass

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 08 December 2006 at 7:13pm
Also, make sure you configure SpamFilter as well to listen only on xxx.xxx.xxx.2. You can do this on the "Settings - Configuration" tab, under the "SMTP Listener Socket". That way, even if the xxx.xxx.xxx.1 IP becomes available when Imail stops, SpamFilter won't try to bind to it.

As a side note, SpamFilter will only bind to IPs upon startup. Once it's running (and configured to bind to all IPs) it won't use an IP even if it frees up.
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
answerman View Drop Down
Newbie
Newbie


Joined: 22 September 2006
Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote answerman Quote  Post ReplyReply Direct Link To This Post Posted: 09 December 2006 at 1:36pm
Originally posted by LogSat LogSat wrote:

Also, make sure you configure SpamFilter as well to listen only on xxx.xxx.xxx.2. You can do this on the "Settings - Configuration" tab, under the "SMTP Listener Socket".

Since it's Windows 2000 Server, and since it's 30 miles away, I can't see the GUI through Terminal Services.  I am admininstering Spam Filter by editing SpamFilter.ini (which seems to be working fine for me... don't really need the GUI).  I see two entries: "ListenIP" and "ListenFQDN".  I do have "ListenIP" set to xxx.xxx.xxx.2, but I am not sure what to do with "ListenFQDN" (there is nothing about it in the *.ini comments) so I have it set to the FQDN of the server.  Should it be set to mail2.domain.com, or left blank, or do I have it set properly? 

I am also looking through the Ipswitch KB to find out what to do with the Imail IP binding issue a couple of posts back, so we can hopefully consider that issue closed.


Edited by answerman
Back to Top
answerman View Drop Down
Newbie
Newbie


Joined: 22 September 2006
Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote answerman Quote  Post ReplyReply Direct Link To This Post Posted: 09 December 2006 at 1:46pm
Originally posted by jerbo128 jerbo128 wrote:


In order to have imail bind to only one ip, you have to set the option in the imail manager.  We also had to change a few registry keys to point our primary and virtual hosts to the ip that we wanted.  We found the methods and corresponding keys on ipswitch's KB.  Once we stumbled through that, all was happy.

Mmm... what version of Imail are you running?  According to the Imail KB article I am looking at, it appears as though that option only exists in +v8.2, and I am running v8.15.

Another option I am looking at is to make the SpamFilterSvc dependent on the Imail SMTP svc, so that if Imail restarts, it will force SpamFilter to restart also.  If all else fails...
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 09 December 2006 at 2:05pm
You have both settings correct. "ListenIP" is the IP you want SpamFilter to bind to. If it's blank, it will bind to all free IPs. The FQDN is the Fully Qualified Domain Name diplayed in the welcome banner.
As a side note, the ListenIP, ListenPort, and ListenFQDN are the *only* three parameters that will require a restart of SpamFilter to take effect, as they are directly related the socket bindings.
Roberto Franceschetti

LogSat Software

Spam Filter ISP
Back to Top
jerbo128 View Drop Down
Senior Member
Senior Member
Avatar

Joined: 06 March 2006
Status: Offline
Points: 178
Post Options Post Options   Thanks (0) Thanks(0)   Quote jerbo128 Quote  Post ReplyReply Direct Link To This Post Posted: 12 December 2006 at 9:00pm

Originally posted by answerman answerman wrote:

Mmm... what version of Imail are you running?  According to the Imail KB article I am looking at, it appears as though that option only exists in +v8.2, and I am running v8.15.Another option I am looking at is to make the SpamFilterSvc dependent on the Imail SMTP svc, so that if Imail restarts, it will force SpamFilter to restart also.  If all else fails...

I am running Imail 8.22.  I wasn't aware that older versions did not support the single IP.  Good luck - They'll want an arm and a leg for an upgrade.

Back to Top
answerman View Drop Down
Newbie
Newbie


Joined: 22 September 2006
Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote answerman Quote  Post ReplyReply Direct Link To This Post Posted: 16 December 2006 at 2:36am
Originally posted by jerbo128 jerbo128 wrote:

I am running Imail 8.22.  I wasn't aware that older versions did not support the single IP.  Good luck - They'll want an arm and a leg for an upgrade.


And I am keeping all my limbs. Purchased SmarterMail Pro mailserver today and plan on migrating this weekend.  Seems like Spam Filter in front of SmarterMail should be a winning combination.
Back to Top
kfries View Drop Down
Newbie
Newbie


Joined: 16 August 2006
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote kfries Quote  Post ReplyReply Direct Link To This Post Posted: 18 December 2006 at 2:45pm
mstsc -console

type that into the run box and you get the console of rdp, which then you will have the gui when using terminal services.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.141 seconds.