Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - issues with 1.2.0.174
  FAQ FAQ  Forum Search   Register Register  Login Login

issues with 1.2.0.174

 Post Reply Post Reply
Author
Alan View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Alan Quote  Post ReplyReply Direct Link To This Post Topic: issues with 1.2.0.174
    Posted: 30 June 2003 at 12:27pm

1) Connections grid is not working.

2) Getting strange errors in Activity Log:

06/30/03 09:20:04:500 -- (180) String matching error for (bellsouth.net --and-- (?#---other block lists---)) : TRegExpr(comp): ?+*{ Follows Nothing (pos 1)

06/30/03 09:20:57:421 -- (180) String matching error for (lists.servitall.com --and-- (?#---other block lists---)) : TRegExpr(comp): ?+*{ Follows Nothing (pos 1)

06/30/03 09:23:57:921 -- (221) String matching error for (hotmail.com --and-- (?#---other block lists---)) : TRegExpr(comp): ?+*{ Follows Nothing (pos 1)

 

Back to Top
Desperado View Drop Down
Senior Member
Senior Member
Avatar

Joined: 27 January 2005
Location: United States
Status: Offline
Points: 1143
Post Options Post Options   Thanks (0) Thanks(0)   Quote Desperado Quote  Post ReplyReply Direct Link To This Post Posted: 30 June 2003 at 2:02pm

Alan,

I have nothing like that in my logs at all. Is this a problem with one of your RegEx's ? Also, my connection grid is working whe I don't disable it.  There is a check box on the main configuration page for disabling the connections grid.  I don't suppose that is checked?

Dan S.

 

Back to Top
Alan View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Alan Quote  Post ReplyReply Direct Link To This Post Posted: 30 June 2003 at 3:02pm

No this is something new.  Any idea what filtering events might cause this message?  The only RegEx expression in use is the one that was suggested by Roberto, but with the "+" modification applied.

As for the Connection Grid, yes I am aware of the "Disable Connection Grid" option and did try that to see if playing with that would fix it, but it does not.  The grid appears blank with blank grey cells where the field titles should appear.

Back to Top
Alan View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Alan Quote  Post ReplyReply Direct Link To This Post Posted: 30 June 2003 at 4:22pm

Ah I found the problem.  I was looking in the Keywords blacklist for problems but it was elsewhere.

I had been using text comment RegEx such as (?#---other block lists---) in my domain blacklist to help organize entries.  They were transparant to the filtering in the previous version but seem to generate an error now in the newest registered version.

Can anyone see why it is choking on my (?# ) comments?  Are the dashes causing the problem?

Back to Top
Desperado View Drop Down
Senior Member
Senior Member
Avatar

Joined: 27 January 2005
Location: United States
Status: Offline
Points: 1143
Post Options Post Options   Thanks (0) Thanks(0)   Quote Desperado Quote  Post ReplyReply Direct Link To This Post Posted: 30 June 2003 at 5:19pm

Alan,

Actually ... I also had put comments into my allowed IP's list so I would remember who I was allowing to relay through my server.  It broke the list!  I think Roberto is going to have to let us know if there is a way to anotate (spelling?) any of the filter text files.

Dan S

Back to Top
Alan View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Alan Quote  Post ReplyReply Direct Link To This Post Posted: 30 June 2003 at 5:26pm
Since the problem did not occur (in my case) until the newer build, I am thinking that there may be a problem with the current build.  In the previous version it never errored with the RegEx comments.
Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 30 June 2003 at 8:35pm

Allan,

With build .169 we found and fixed a rather big bug in the way RegEx expressions were searching thru the lists and email contents. The lists were skipped altogether from searches actually.. which is why probably the errors you saw never showed up before.

Regarding the connections grid, that's a new one. Other than ensuring the option to disable the grid is selected, we're out of answers on that one. If you can email us your ini file we can try to duplicate it.

Roberto Franceschetti
LogSat Software

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4065
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 30 June 2003 at 8:36pm

Sorry Dam, the lists need to be as they are, no comments allowed. Sorting thru them  to distinguish between search strings and comments would hurt performance too much.

Roberto Franceschetti
LogSat Software

Back to Top
Desperado View Drop Down
Senior Member
Senior Member
Avatar

Joined: 27 January 2005
Location: United States
Status: Offline
Points: 1143
Post Options Post Options   Thanks (0) Thanks(0)   Quote Desperado Quote  Post ReplyReply Direct Link To This Post Posted: 30 June 2003 at 8:43pm

Roberto,

No hardship there ... I already have a cheap and dirty database I have been using with my previous mailers. I can live with that!

Dan S.

Back to Top
George View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote George Quote  Post ReplyReply Direct Link To This Post Posted: 01 July 2003 at 3:41am

Two memory errors with .174: Note this testing system has Y2K with Service pack 4 installed on it, Computer name has been removed for security reasons. Reverted back to .173 since no errors have been received with it yet.

Event Type: Error
Event Source: SpamFilterSvc.exe
Event Category: None
Event ID: 1
Date:  7/1/2003
Time:  12:15:34 AM
User:  N/A
Computer: ********

Description:
The description for Event ID ( 1 ) in Source ( SpamFilterSvc.exe ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event: Access violation at address 7175239C in module 'comctl32.dll'. Read of address 046FFFF4.

 

Event Type: Error
Event Source: SpamFilterSvc.exe
Event Category: None
Event ID: 1
Date:  7/1/2003
Time:  12:16:11 AM
User:  N/A
Computer: ********

Description:
The description for Event ID ( 1 ) in Source ( SpamFilterSvc.exe ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event: Access violation at address 7175239C in module 'comctl32.dll'. Read of address 046FFFF4.

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.105 seconds.