Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - Reject message 521
  FAQ FAQ  Forum Search   Register Register  Login Login

Reject message 521

 Post Reply Post Reply
Author
Paul View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Paul Quote  Post ReplyReply Direct Link To This Post Topic: Reject message 521
    Posted: 31 March 2003 at 12:00am

I have version .80 and the cutomized reject message doesn't seem to be getting sent. A message "521 Server does not accept mail" is sent instead. I had this problem with version.70 and was told .73 would fix the problem. I've been running .73 since late last week, and received this error message today. I just installed .80 today. Is the customized messages fixed?

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 31 March 2003 at 12:00am

Paul,

Please read the other posting in this thread as well for a sample. Yes, customized messages are supposed to be fixed. Can you please provide us with more details if you are still having problems?

Roberto Franceschetti LogSat Software

Back to Top
Brian View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Brian Quote  Post ReplyReply Direct Link To This Post Posted: 31 March 2003 at 12:00am

Yeah get similar with the 557 set for keywords.

<<< 557 554 5.0.0 Service unavailable

It does not send custom message.

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 31 March 2003 at 12:00am

Can you please provide us with more details? We should have fixed this bug (or at least thought so) with build .80.

Following is the transcript of an actual SMTP conversation on our running production version of SpamFilter. The keywords that trigger the reject are "mortgage click here". It correctly sent the cusomized error response.

Roberto Franceschetti LogSat Software

>>220 mail2.netwide.net Welcome to LogSat's Software SMTP Server v1.0
<<HELO CMCTRF1
>>250 Hello CMCTRF1
<<RSET
>>250 Ok
<<MAIL FROM:<roberto3@netwide.net>
>>250 roberto3@netwide.net Address Okay
<<RCPT TO:<roberto4@netwide.net>
>>250 roberto4@netwide.net Address Okay
<<DATA
>>354 Start mail input; end with <CRLF>.<CRLF>
<<Forward-Path: <roberto2@netwide.net>
<<From: roberto3@netwide.net
<<To: roberto4@netwide.net
<<Subject: test
<<Date: Mon, 31 Mar 2003 13:24:55 -0500
<<
<<this is a test
<<mortgage click here
<<.
>>557 This email is rejected. It contains keywords rejected by the antispam content filter.

Back to Top
Brian View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Brian Quote  Post ReplyReply Direct Link To This Post Posted: 31 March 2003 at 12:00am

This is what the returned mail from RR says:

The original message was received at Sun, 30 Mar 2003 22:45:56 -0500 (EST) from 253.42.35.65.cfl.rr.com

----- The following addresses had permanent fatal errors ----- <someone@mydomain.com> (reason: 557 )

----- Transcript of session follows ----- ... while talking to mail.mydomain.com.:

>>> DATA

<<< 557 554 5.0.0 Service unavailable

******************************* Just get Service unavailable as reason nothing about keywords. This was a keyword rejection test. PS: changed email address & server to generic names just for this post to avoid spam :-).

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 31 March 2003 at 12:00am

Just tried ourselves with RR and received the following. The onlny udifference with your seems to be that on your end the description line after the "557" is not there. Can you email us at support@logsat.com your SpamFilter.ini file so we can ensure it is correct?

Roberto

The original message was received at Mon, 31 Mar 2003 18:48:05 -0500 (EST) from 48.215.8.67.cfl.rr.com [67.8.215.48]

----- The following addresses had permanent fatal errors ----- <roberto3@netwide.net> (reason: 557 This email is rejected. It contains keywords rejected by the antispam content filter.)

----- Transcript of session follows ----- ... while talking to mail2.netwide.net.: >>> DATA <<< 557 This email is rejected. It contains keywords rejected by the antispam content filter. 554 5.0.0 Service unavailable

Back to Top
Brian View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Brian Quote  Post ReplyReply Direct Link To This Post Posted: 31 March 2003 at 12:00am

I uninstalled .80 and then deleted the program folder for SpamFilter, then I reinstalled fresh. Still get this with a rejected keyword test from rr to mydomain.

The original message was received at Mon, 31 Mar 2003 21:06:50 -0500 (EST) from 253.42.35.65.cfl.rr.com [65.35.42.253]

----- The following addresses had permanent fatal errors ----- <me@mydomain.com> (reason: 552 Requested mail action aborted: exceeded storage allocation)

----- Transcript of session follows ----- ... while talking to mail.mydomain.com.:

>>> DATA

<<< 552 Requested mail action aborted: exceeded storage allocation 554 5.0.0 Service unavailable

?

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 31 March 2003 at 12:00am

Brian,

The correct customized response should be:

557 This email is rejected. It contains keywords rejected by the antispam content filter.

Unfortunately I just noticed that this build (.80) went back to a numeric error code of 552, so when you did a clean install your response went back to:

552 This email is rejected. It contains keywords rejected by the antispam content filter.

If you change the customized line to the correct one things should work.

This whole issue arises from the fact that some mail servers (ex. RR in this case) take the numeric code (552) and interpret it in their way, appending their own description to it, ignoring the one sent by SpamFilter. This happens because 552 is used usually to indicate that the user's mailbox is full. An error code of 557 is unused, to the mail server can't append its description, and leaves SpamFilter's alone.

Back to Top
Brian View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Brian Quote  Post ReplyReply Direct Link To This Post Posted: 31 March 2003 at 12:00am

Just as a test I set keyword reject to 557, still the same results. Does not send custom message.

The original message was received at Mon, 31 Mar 2003 21:46:28 -0500 (EST) from 253.42.35.65.cfl.rr.com [65.35.42.253]

----- The following addresses had permanent fatal errors ----- <me@mydomain.com> (reason: 557 )

----- Transcript of session follows ----- ... while talking to mail.mydomain.com.:

>>> DATA

<<< 557 554 5.0.0 Service unavailable

This is error returned to sender, maybe the error to sending mail server is different?

Back to Top
Brian View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Brian Quote  Post ReplyReply Direct Link To This Post Posted: 31 March 2003 at 12:00am

Also when using error code from: http://www.mailsbroadcast.com/email.bolts&nuts/smtp.return.codes.error.htm

The original message was received at Mon, 31 Mar 2003 21:27:13 -0500 (EST) from 253.42.35.65.cfl.rr.com [65.35.42.253]

----- The following addresses had permanent fatal errors ----- <me@mydomain.com> (reason: 530 )

----- Transcript of session follows ----- ... while talking to mail.mydomain.com.:

>>> DATA

<<< 530 554 5.5.0 Remote protocol error

From above web link: 530 = Access denied

Maybe it's just RR CFL ? I guess it doesn't matter as long as it's blocked. I did a clean install using defaults with same results. So, I guess it doesn't really matter, as long as it's blocked.

Back to Top
Paul View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Paul Quote  Post ReplyReply Direct Link To This Post Posted: 31 March 2003 at 12:00am

So, for my problem with "521 Server does not accept mail" instead of sending my customized message, do I need to change the "521" to 557?

Also, do you know where on the Internet I can get a listing of e-mail error codes and their definitions?

Thanks

Back to Top
LogSat View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2005
Location: United States
Status: Offline
Points: 4068
Post Options Post Options   Thanks (0) Thanks(0)   Quote LogSat Quote  Post ReplyReply Direct Link To This Post Posted: 31 March 2003 at 12:00am

Yes, please try changing just the number from 521 to 557, and leaving whatever description you want after that.

2nd question - try http://www.rfc-editor.org/rfc/rfc2821.txt, specifically on page 44./45

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.095 seconds.