Spam Filter ISP Support Forum

  New Posts New Posts RSS Feed - spamfilter on Exchange 2000 server
  FAQ FAQ  Forum Search   Register Register  Login Login

spamfilter on Exchange 2000 server

 Post Reply Post Reply
Author
Curtis View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Curtis Quote  Post ReplyReply Direct Link To This Post Topic: spamfilter on Exchange 2000 server
    Posted: 19 June 2003 at 1:42pm

Anyone running spamfilter on their Exchange 2000 box? I'm trying to set this up and having a little trouble. If I stop the SMTP service, then spamfilter seems to start and events show up in the log and it seems to work (althougth the mail doesn't get to Exchange because the SMTP service is stopped). If I leave the SMTP service running and try to start spamfilter, nothing shows up in the log, no error messages, and I can't make and telnet connection on port 25 to the IP used for spamfilter. When I try to telnet it instantly closes the telnet connection. I'm using a new seperate IP for spamfilter. The SMTP protocol options in Exchange are set to use the specific IP (old IP) not "all unassigned". Any ides?

Second question for anyone who has loaded spamfilter on their Exchange 2000 box, how much is performance impacted?

Thanks for any info

Back to Top
KJ View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote KJ Quote  Post ReplyReply Direct Link To This Post Posted: 20 June 2003 at 11:27am
I had the same issues.  This is how we are getting around it.  Set spam filter up to receive on 25 but have it forward out to port 26.  Then go into Exchange System Manager.  Under servers, protocols, smtp, default smtp server right click and properties.  Under General tab click on Advanced button.  Change port to 26.  Save changes.  Restart SMTP server.  This should allow it to work and forward to Exchange.
Back to Top
Curtis Muncy View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Curtis Muncy Quote  Post ReplyReply Direct Link To This Post Posted: 20 June 2003 at 4:36pm

Thanks,

that did the trick, and as an added bonus, I didn't have to use a new IP and I didn't have to change the MX record!

Back to Top
MartinC View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote MartinC Quote  Post ReplyReply Direct Link To This Post Posted: 21 June 2003 at 7:10am

hi guys,

are you just running a single exchange 2000 box?

you'll be fine if this is the case. no problems like this afaik.

however, if you are running multiple servers then there is no way to tell the other servers the new port number you have for smtp. Exchange 2000 uses the smtp connector for non-standard binary messages so you are likely to run into problems if you have multiple servers.

the same thing applies to any piece of software that hooks in as an smtp service so nai webshield etc, so you need to run a separate box as a spam smtp server.

Back to Top
MarvinFS View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote MarvinFS Quote  Post ReplyReply Direct Link To This Post Posted: 21 June 2003 at 11:42am
No u dont need a separate server if there are some more servers is your exchange organization... . just add another NIC, bind to a separate iP, and BINGO! u got it running... also this may help to get exhange running correctly.. Use ms technet http://www.microsoft.com/technet, search for KB322023 Event ID 115 Message Occurs When You Start SMTP Service

start reading from After you have verified that you are server publishing SMTP, configure Exchange 2000 to listen only on your internal IP address. To do so: ....

and dont forget about inherit checkbox in metaedit or it'll not work...
Back to Top
MartinC View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote MartinC Quote  Post ReplyReply Direct Link To This Post Posted: 23 June 2003 at 8:58am

thanks Marvin,

that's really useful info.

I tried doing this with Exchange and Webshield but no joy...,

It must be Webshield that tries to run as all active IP addresses on a server rather than Exchange.

Back to Top
Tony Bearman View Drop Down
Guest Group
Guest Group
Post Options Post Options   Thanks (0) Thanks(0)   Quote Tony Bearman Quote  Post ReplyReply Direct Link To This Post Posted: 23 June 2003 at 4:00pm

> Change port to 26.  Save changes.  Restart SMTP server.

Trivia time. You don't actually need to restart SMTP. Change the port, then at a command line, enter (note the trailing space in the quotes)

netstat -an | find ":26 "

Repeat until you see the service pick up on the new port automagically after a few seconds.

Cheers.

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 1.406 seconds.